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Test Title: Kernel Overview Validation Procedure

Candidate Platform: _____________________________________

Date:  __________________________________________

Tester:  








Estimated Runtime:  ____8 hours ____________________
Start Time:  _____________
  End Time:   ___________________
Actual Runtime:__________________________________
Test Site/Organization:  __________________________________

Overall Test Result: Circle One:  PASS  /  FAIL

Configuration Validated

Hardware Platform: ________________________________________
System Software: 






Network Type: 







Printer: _________________________________________

Local Devices (if any):  ________________________________________________________________________________________

Test Purpose/Scope: This Kernel Overview test provides a high level test of the full range of fundamental Kernel Platform functionality.  Each of the other Kernel Platform Compliance (KPC) tests provides a deeper (i.e. more thorough) test of a specific narrower range of Kernel Platform function.  In addition, this test procedure established the baseline content of many system configuration files.  For this reason, execution of this test after initial OS load is recommended.

This test also assures that the Graphical User Interface (GUI) presented to the user for basic system operation is consistent across all compliant Posix-based DII COE platforms.  This test assures that the operations invoked and exercised have identical results that are consistent across all compliant Posix-based Defense Information Infrastructure (DII) Common Operating Environment (COE) platforms.

Description:  These test procedures exercise the following basic functionality, with the relevant test steps identified in parenthesis.

-Login (A), and Logout (Z)

-Access to and Configuration of Default Accounts (C),

-Verify Candidate Platform configuration and major function (D), including

--
Default Router (D1), Domain Naming Service (D2),

--
Print service (D3), basic trusted operation (D4), local disk mount (D5),

--
Change hostname and IP address (D6),

--
Network File System export (D12 & D13), mount (D15), and unmount (D19),

-Ability to create a segment on local removable storage media (B),

-A variety of segment installation scenarios, including:

--
Install multiple segments from a local removable media to the default installation location, i.e. "/h/seg" (D9),

--
Install multiple segments from an NFS mounted volume to a newly created local partition, i.e. "/home3" (D10),

--
Load multiple segments from the COE Segment Installation Server application running on the Validation Host into the Candidate Platform COE Segment Installation Server Repository (D14),

--
Install multiple segments from the COE Segment Installation Server application running on the Validation Host to the default installation location on the Candidate Platform "/h/seg" (D16),

--
Install multiple segments from the COE Segment Installation Server application running on the Candidate Platform to the default installation location on the Validation Host "/h/seg" (D17),

--
Remove multiple segments from the Segment Installation Server Repository on the Candidate Platform (D18),

-Ability to operate without Network Information System (NIS) and as a (NIS) client (D20 & D21),

-Verify Account Group and Profile configuration and major function (E), including:

--
Setup new local accounts (E1),

--
Setup new global accounts (E2).

Overall Test Result:  The overall PASS/FAIL result for this test is determined as follows:  The overall test result is "PASS" if and only if all steps marked as PASS/FAIL steps in the Observed Result column, have a test step "PASS" result.

Test Step Results:  For each step with a "Circle One:  PASS/FAIL" in the Observed Result column, the tester compares the directly observed Candidate Platform behavior with the "PASS" criteria.  Unless other PASS criteria are noted in the test step, the test step result is "PASS" if and only if the Candidate Platform presents all of the behaviors and conditions described in the Expected Result column for that test step.  The test step result if "FAIL" if the Candidate Platform fails to satisfy any of the PASS criteria.

If the test step result is "PASS", the tester will circle "PASS" and note the actual behaviors and conditions presented in the Observed Result column.  If the observed result precisely matches the expected result, the Observed Result column for the step may contain the statement "as expected."

If the test step result is "FAIL", the tester will circle "FAIL" in the Observed Result column and note the actual behaviors and conditions presented in the Observed Result column.  Additional documentation detailing the reasons for the test step failure is included in the Validation Test Report.
Note 1: Due to the complexity of any Candidate Platform, it is impossible to completely specify all aspects of their operation in the space provided.  Many of the expected Candidate Platform behaviors for any test step are implicitly assumed based on industry practice, commercial testing or prior testing, and may not be explicitly described in the Expected Result column.  DISA reserves the right to consider implicit as well as explicit PASS/FAIL criteria which could adversely affect the ability of the Candidate Platform to satisfy DoD mission requirements when used as a component of the DII.

If implicit PASS/FAIL criteria are involved in a "FAIL" determination, the tester will circle "FAIL" in the Observed Result column and note the objectionable behavior in the Observed Result column at the point of observation during the test.  Additional documentation detailing the full rationale for the "FAIL" determination is to be included in the Validation Test Report.

Note2:  Test steps which are "grayed out" (i.e., the entire table row is set to a gray background) are to be considered as waived by DISA for this test version only.  Grayed out test steps are not to be executed nor is observed behavior to be recorded.  These test steps may be returned to the overall test at a future date and are retained for information purposes only.  PASS/FAIL criteria identified in these test steps will not be used in the determination of the overall test result.

Note3:  The symbol “(” (inverted triangle) denotes a blank space.  The “[RETURN]” symbol denotes a carriage return.
Test Data/Media Required:  The following KPC test data segments are required to execute this test:  

1. The KPC test data  (kpc.tar) must loaded in the "/home1/KPC" subdirectory on the Validation Host IAW the "Validation Host Configuration" section of the DII COE Kernel Platform Compliance Program document.

2. The following sample segments are part of the developers toolkit:  SampleAcctGrp, SampleAgg, SampleAggChild, SampleCOTS, SampleDataGlobal, SampleDataLocal, SampleDataSegment, SampleSW, SamplesSW.P1, and SamplesSW2.  This test data must be in raw date (tar) format, and located in the "/h/DII_DEV" subdirectory on the Validation Host IAW the "Validation Host Configuration" section of the DII COE Kernel Platform Compliance Program document.  A ‘Sample Segment – Solaris’ tape is assumed to have been created in advance, in accordance with the procedure in Step B below. 

Step B of this procedure creates two segment tapes (or other media suitable for use on the vendors candidate platform) containing the sample tar segments mentioned in item 2 above.  The first tape, created in step B.1, contains seginfo file MACHINE & CPU fields specific to the vendor’s candidate platform, and is labeled “Sample Segments – Vendor”.  The second tape, created in step B.2, contains seginfo file MACHINE & CPU fields updated to “ALL”, and is labeled “Sample Segments – Generic”.  Both of these Sample Segment tapes are used for this test, the COE Segment Installer test and the COE Segment Installation Server test.  The tapes should be labeled according to the DII COE Documentation Requirements and should also include the test name, test step and the tester's name and date.

Setup/Equipment Required: This test requires a Validation Cell and Candidate Platform configured as specified in the current version of the DII COE Kernel Platform Compliance Program document.  

The Validation Host tape drive must be block size of 20b, and have the device identifier “/dev/rmt/0mn”.  The Validation Host is assumed to have /home1/KPC exported.

The Candidate Platform must have the Validation Host set as untrusted. Unlike the other KPC validation procedures, the Candidate Platform must not have the Validation Host directory "/h/data/global" exported or mounted initially.  

This test procedure will establish the Candidate Platform baseline configuration required for the other tests.  At the end of this test, the candidate platform will have the Validation Host set as untrusted (via Edit Local Hosts), the Validation Host directory "/h/data/global" mounted (via disk Manager) on the same directory on the Candidate Platform.  The Candidate Platform is in a powered down state at the initiation of this test. 

The platform configuration required when acting as a segment installation server is documented in the System Administrator Manual for the appropriate kernel.  The configuration used for that portion of this test includes the following provisions:

/h/data/global will be exported from the Validation Host/Server, and mounted on client.

/home2 will be exported from the Segment Installation Server 

The segments to be served must be loaded on the Segment Installation Server in /home2.  The /home2 directory must be a separate partition.
Several parts of the test are designed to provide for variations and/or vendor specific implementation.  In each case, the vendor enters data to specify the implementation approach used.  The vendor supplied data is indicated by a field marked with left/right double arrows <<data item>>.  The test steps involved and information entered includes:

· The file in which (one or more) default router is identified in steps D.1.3, and indicated by the field <<router file>>.
· A removable archival storage media device name is identified in step B.6, and indicated by the field <<media>>.  This device is currently assumed to be magnetic tape, but other media will be considered on request.
· A removable online storage device for the Candidate Platform must be available to test COE Segment Installer and COE Segment Installation Server functions in steps B, and D.9 through D.11.  In addition, a storage volume that can be re-formatted with a complete loss of date must be available on the Candidate Platform to support Disk Manager testing in steps D.5-D.7.  This storage volume may be a full disk drive (internal or external) or a sub-set partition of a disk, at the vendor's discretion.  The volume must be large enough to contain the test segments created during step D.10.  The storage volume provided for test purposes is designated as /dev/<<volume>> where <<volume>> is a string suitable for use in a 'mount' command.  Where test steps indicate <<volume>>, the vendor-specified string should be substituted.
Required Personnel:  One (1) tester.  The tester must be familiar with POSIX/UNIX application platforms, but need not be familiar with the DII COE.

Step
Operator Action
Expected Result
Observed Result

A
Power-UP and Login



A.1
Power up the Candidate Platform. 
Console prompt appears.
 Circle one:  PASS / FAIL

A.1.1
Optional

At the power up screen enter “boot”.
The DII COE login screen appears.
 Setup

A.1.2
On the Candidate Platform, log in to the sysadmin account using the appropriate sysadmin password.
The menu bar, security classification, and CDE desktop appears.
 Circle one:  PASS / FAIL

A.2
Create mount point for /home1/KPC, and mount from Validation Server.  (“/home1/KPC” contains KPC test data.)



A.2.1
From the CDE Toolbar, select the following: Apps_Mgr > DII_Apps > L:SA_Default > Xterm
An xterm window appears.
Circle one:  PASS / FAIL

A.2.3
Open an xterm, type sysadmin at the login: prompt and press <Enter>/.

Enter the appropriate sysadmin password and press <Enter>.
A Password:  prompt appears in the xterm.

The system returns a system (#) prompt.

 (Step changed per VOR 201299102100.)
Circle one:  PASS / FAIL

A.2.4
Enter the following:


su – root

Enter the appropriate sysadmin password and press <Enter>.

Enter cd / at the system prompt and press <Enter>.

mkdir /home1

mkdir /home1/KPC

cd /h
 
A Password: prompt appears in the xterm.

The system returns a system (#) prompt.

A system prompt is returned after entering each command.

(Step changed per VOR 201299104000.)
 Circle one:  PASS / FAIL

A.2.5
From the pull down menu, at the top of the DII COE screen, set the default router using Network > Edit Local Host 
Edit Local host window appears.
Circle one:  PASS / FAIL

A.2.6
When the Edit Hosts window appears, add the Validation Host as a trusted system (kpchost) by selecting the [ADD] button.
An “Add Machine” window appears.
Circle one:  PASS / FAIL

A.2.7
When the [Add Machine] window appears,  in the machine name field, type:


 kpchost
In the address field, Enter:

<<Validation Host IP Address>> 

Click on the [Trusted Machine] checkbox and click [OK] in the [Add Machine] window to add trusted system.

NOTE: Enter the Validation Host IP address that is posted in the test cell.
The “Add Machine” window disappears and the “Edit Hosts” window re-appears.  The “Edit Hosts” window will show an “A” -(add) and “T” -(trusted) in the column beside the hostname indicating the addition of a new host and that it is trusted.
Circle one:  PASS / FAIL

A.2.8
From the pull down menu, select: Hardware > DiskManager.
The “Disk Manager” window appears.
Circle one:  PASS / FAIL

A.2.9
Click on the [Mount New] button.
The “Mount File system” window appears.
Circle one:  PASS / FAIL

A.2.10
In the “Mount File System” window, enter:

File System: [kpchost:/home1/KPC]
Mount Point: /home1/KPC

Click on the [Mount] button.
The “Permanent Mount?” window appears.
Circle one:  PASS / FAIL

A.2.11
In the “Permanently Mount” dialog box, select “Yes”.
NOTE:  This dialog box does not always appear on the SOLARIS platform.
The “Permanently Mount” dialog box disappears.

kpchost:home1/KPC appears as a mounted filesystem in the “Disk Manager” window.
Circle one:  PASS / FAIL

A.2.12
Select [Exit] to exit the Disk Manager window.
“Disk Manager” window closes.
Circle one:  PASS / FAIL

A.3
Load Developer Toolkit Data



A.3.1
If the Developer's Toolkit  has already been installed during the installation procedure, proceed to step A.3.6.

On the Candidate Platform, open an xterm, login as sysadmin and enter:


cd /h

Xterm returns a system prompt.

(Step changed per VOR 201299105400.)
 Circle one:  PASS / FAIL

A.3.2
Insert DII COE Developer’s Toolkit (DTK) media into drive on Candidate Platform.  Enter:


tar xvp
Untarred files (including libraries and DTK Sample Segments) will be listed on the console as they are loaded into /h/DII_DEV.
 Circle one:  PASS / FAIL

A.3.3
In the xterm,

   ls –l
The results of the “ls” command will show a DII_DEV directory in /h.


Circle one:  PASS / FAIL

A.3.4
If the Developer’s Toolkit media used is tape, rewind:  In the xterm, at the system prompt, enter:

mt rew
The xterm returns a system prompt, and the tape rewinds.


Circle one:  PASS / FAIL

A.3.5
Remove the Developer’s Toolkit media media. 
The media drive is empty.


Circle one:  PASS / FAIL

A.4
Export /h/data/global from the Validation Host.



A.4.1
On the Validation Host, log in to the sysadmin account using the appropriate sysadmin password.
The menu bar, security classification, and CDE desktop appears.
 Circle one:  PASS / FAIL

A.4.1.1
Via the pull down menu, select Hardware > Disk Manager.
The Disk Manager window appears.
Setup

A.4.2
Click on the [EXPORTFS] button.
The “Export/Unexport FileSystem” window appears.
Setup

A.4.3
In the “Export/Unexport File System” window,

Change  options: rw,anon=0.  

Enter  pathname: /h/data/global

Click on the [EXPORT] button.
A dialog box appears asking “Do you want to permanently export the file system /h/data/global?”.
Setup

A.4.4
Answer [YES] to the question, “Do you want to permanently export the file system /h/data/global?”
The dialog box disappears.
Setup

A.4.5
On the Validation Host in the disk manager window, click on the [EXPORTFS] button. 
The “Export/Unexport FileSystem” Window appears.
Setup

A.4.6
On the Validation Host, in the “Export/Unexport FileSystem” window, click on the [CURRENT] button.


The “Disk Manager” window lists currently exported file systems for the validation platform.  

/h/data/global must be listed as exported.
Setup

A.4.7
On the Validation Host, in the “Export/Unexport File System” window:


select [CANCEL]
The “Export/Unexport File System” window disappears.
Setup

A.5
Mount /h/data/global from the Validation Host onto the Candidate Platform.



A.5.1
On the Candidate Platform, select Hardware > Disk Manager
The “Disk Manager” window appears.
Circle one:  PASS / FAIL

A.5.2
On the Candidate Platform, in the “Disk Manager” window, click [MOUNT NEW].

The “MOUNT FILE SYSTEM” window appears. enter:   

kpchost:/h/data/global
The “Disk Manager” window appears and allows you to enter information.
Circle one:  PASS / FAIL

 A.5.3
Click the “popup” button, select /h/data/global as the mount point and click [MOUNT].
A confirmation window will appear asking “Do you want to permanently mount this filesystem?”
Circle one:  PASS / FAIL

A.5.4
The “Do you want to permanently mount?” window will appear.  Click the [YES] button to permanently mount the filesystem.
The “Disk Manager” window will re-appear. 
Circle one:  PASS / FAIL

A.5.5
Click [EXIT] to close the ‘Disk Manager’ window.
The ‘Disk Manager” Window closes
Circle one:  PASS / FAIL

A.6
Y2K Verification Tests



A.6.1
Open  an xterm window on the Validation Host.



A.6.1.1
On the Validation Host, open an xterm, and login as sysadmin.
An xterm window appears.
 Setup

A.6.1.2
From the CDE Toolbar, select the following: Apps_Mgr > DII_Apps > L:SA_Default > Xterm
An xterm window appears.
Setup

A.6.1.3
Login as sysadmin.
A system prompts appears in the xterm.
Setup

A.6.1.4
Enter the following:


su – root 
A system prompt is returned.
 Circle one:  PASS / FAIL

A.6.2
Test 1st Rollover Date: 01 Jan 2000
Use the posix "date" command to set the system time, and observe the date rollover.



A.6.2.1
On the Candidate Platform, in the xterm window, enter the following:


date 123123581999
"Fri Dec 31 23:58:00 GMT 1999" and the system prompt is returned.
 Circle one:  PASS / FAIL

(outdated) 

A.6.2.2
On the Validation Host, in the xterm window, enter the following:


date 123123581999
"Fri Dec 31 23:58:00 GMT 1999" and the system prompt is returned.
 Setup

A.6.2.3
On the Candidate Platform, in the xterm window, enter the following:


date
The system returns the new date and time.
 Circle one:  PASS / FAIL

(outdated) 

A.6.2.4
On the Candidate Platform, repeat entry of the "date" command, and  observe the date and time returned by the system.  Continue until the time and date rolls over to the 01 Jan 2000.
The system time returned increases, until the date rolls over and correctly displays the date rollover as follows:

Sat Jan 1 00:00:00 GMT 2000
Circle one:  PASS / FAIL

(outdated)

A.6.3
Test 2st Rollover Date: 10 Jan 2000
Use the posix "date" command to set the system time, and observe the date rollover.



A.6.3.1
On the Candidate Platform, in the xterm window, enter the following:


date 010923582000
"Sun Jan 9 23:58:00 GMT 2000" and the system prompt is returned.
 Circle one:  PASS / FAIL

(outdated) 

A.6.3.2
On the Validation Host, in the xterm window, enter the following:


date 010923582000
"Sun Jan 9 23:58:00 GMT 2000" and the system prompt is returned.
 Setup

A.6.3.3
On the Candidate Platform, in the xterm window, enter the following:


date
The system returns the new date and time followed by a system prompt.
 Circle one:  PASS / FAIL

(outdated) 

A.6.3.4
On the Candidate Platform, repeat entry of the "date" command, and  observe the date and time returned by the system.  Continue until the time and date rolls over to the 10 Jan 2000.
The system time returned increases, until the date rolls over and correctly displays the date rollover as follows:

Mon Jan 10 00:00:00 GMT 2000
Circle one:  PASS / FAIL

(outdated)

A.6.4
Test 3st Rollover Date: 29 Feb 2000
Use the posix "date" command to set the system time, and observe the date rollover.



A.6.4.1
On the Candidate Platform, in the xterm window, enter the following:


date 022823582000
“Mon Feb 28 23:58:00 GMT 2000  and the system prompt is returned.
 Circle one:  PASS / FAIL

(outdated)

A.6.4.2
On the Validation Host, in the xterm window, enter the following:


date 022823582000
“Mon Feb 28 23:58:00 GMT 2000  and the system prompt is returned.
 Setup

(outdated)

A.6.4.3
On the Candidate Platform, in the xterm window, enter the following:


date
The system returns the new date and time followed by a system prompt.
 Circle one:  PASS / FAIL

(outdated)

A.6.4.4
On the Candidate Platform, repeat entry of the "date" command, and  observe the date and time returned by the system.  Continue until the time and date rolls over to the 29 Feb 2000.
The system time returned increases, until the date rolls over and correctly displays the date rollover as follows:

Tue Feb 29 00:00:00 GMT 2000
Circle one:  PASS / FAIL

(outdated)

A.6.5
Test 4st Rollover Date: 01 Mar 2000

Use the posix "date" command to set the system time, and observe the date rollover.



A.6.5.1
On the Candidate Platform, in the xterm window, enter the following:


date 022923582000
“Tue Feb 29 23:58:00 GMT 2000” and the system prompt is returned.
 Circle one:  PASS / FAIL

(outdated)

A.6.5.2
On the Validation Host, in the xterm window, enter the following:


date 022923582000
“Tue Feb 29 23:58:00 GMT 2000” and the system prompt is returned.
 Setup

A.6.5.3
On the Candidate Platform, in the xterm window, enter the following:


date
The system returns the new date and time followed by a system prompt.
 Circle one:  PASS / FAIL

(outdated)

A.6.5.4
On the Candidate Platform, repeat entry of the "date" command, and  observe the date and time returned by the system.  Continue until the time and date rolls over to the 01 Mar 2000.
The system time returned increases, until the date rolls over and correctly displays the date rollover as follows:

Wed Mar 1 00:00:00 GMT 2000
Circle one:  PASS / FAIL

(outdated)

A.6.6
Test 5th Rollover Date:  10 Oct 2000

Use the posix “date” command to set the system time, and observe the date rollover.



A.6.6.1
On the Candidate Platform, in the xterm window, enter the following:

date 100923582000
Mon Oct 9 23:58:00 GMT 2000 and the system prompt is returned
Circle one:  PASS / FAIL

A.6.6.2
On the Validation Host, in the xterm window, enter the following:

date 100923582000
Mon Oct 9 23:58:00 GMT 2000 and the system prompt is returned
Setup

A.6.6.3
On the Candidate Platform, in the xterm windown, enter the following:

date
The system returns the current date and time followed by the system prompt.
Circle one:  PASS / FAIL

A.6.6.4
On the Candidate Platform, repeat entry of the “date” command, and observe the date and time returned by the system.  Continue until the time and date rolls over to 10 Oct 2000
The system time increases, until the date rollos over and correctly displays the date rollover as follows:

date:  Tue Oct 10 00:00:00 GMT 2000
Circle one:  PASS / FAIL






A.7
Return both platforms to the current date.



A.7.1
On the Candidate Platform, in the xterm window, enter the following:

date <current time date>
The current date and time and a system prompt is returned.
 Circle one:  PASS / FAIL

A.7.2
Confirm that the time has reset to the current time and date.  On the Candidate Platform, in the xterm window, enter the following:


date
The system returns the current time followed by a system prompt.
 Circle one:  PASS / FAIL

A.7.3
On the Validation Host, in the xterm window, enter the following:

date <current time date>
A system prompt is returned.
 Circle one:  PASS / FAIL

A.7.4
Confirm that the time has reset to the current time and date.  On the Validation Host, in the xterm window, enter the following:


date
The system returns the current time followed by a system prompt.
 Circle one:  PASS / FAIL











A.7.5
On the Validation Host, in the xterm window, enter the following:


exit
The root login closes and leaves you at the sysadmin prompt kpccp%.
Circle one:  PASS / FAIL

B
Create a SAMPLE segment tape 

NOTE: The tape created is used in the “COE Segment Installer” and “COE Segment Installation Server” KPC tests.

NOTE:  Disregard warnings regarding non-COE compliant date formats until test data segments are corrected.



B.1
Create “Sample Segment – Vendor” Tape, which contains vendor specific entries in the seginfo file.



B.1.1
On the Candidate Platform, in the xterm window, at the command line prompt (kpccp%) enter:


csh
The command line changes to the C Shell and returns a system admin prompt "kpccp%".

Note: As an alternative the system admin prompt “root@kpccp:” is acceptable.
Circle one:  PASS / FAIL

B.1.2
At the system admin prompt, enter:

chmod 755 /h/DII_DEV/Scripts/MakeTOOLSEnv

/h/DII_DEV/Scripts/MakeTOOLSEnv
A prompt should appear indicating a default directory of /h/DII_DEV.
Circle one:  PASS / FAIL

B.1.3
Confirm the default directory by entering [RETURN] to accept the default in the preceding step.
kpccp% system prompt received.
Circle one:  PASS / FAIL

B.1.4
su to root by typing:


su

and enter root password.
NOTE:  Requires root privilege.
The system returns a command prompt #.
Circle one:  PASS / FAIL

B.1.5
At the system prompt, enter:


Verification results appear in “login”/xterm window and returns the “#” prompt.
Circle one:  PASS / FAIL


cd /h/DII_DEV/SampleSegments [RETURN]

/h/DII_DEV/bin/VerifySeg –p . SampleAcctGrp SampleSW SampleCOTS SampleAgg SampleAggChild SampleSW2 SampleSW.P1 SampleDataSegment SampleDataLocal SampleDataGlobal[RETURN]



(Step changed per VOR 201299124300.)



NOTE: The storage volume provided for test purposes is designated as /dev/<<media>> where <<media>> is a string suitable for use in a ‘mount’ command.

Where test steps below indicate <<media>>, the vendor-specified string should be substituted.
Vendor Applicant specified string representing the mountable <<media>> is:

_______________________

(enter here)

This device designation will be used in later test steps.


B.1.6
Load pre-formatted, empty removable media in the storage device and execute the following command:

/h/DII_DEV/bin/MakeInstall(–t(
/dev/<<media>>(–p(.(`ls`

Note: The –t” is tape specific, and may evolve in the future to use other media.
The following prompt will appear:

“Enter size of tape in Mbytes or type ‘q’ to quit”.


Circle one:  PASS / FAIL

B.1.7
Enter the capacity of the removable storage media loaded in the previous step.  Specify size in units of Megabytes (i.e. 4 for 4 megabytes).
A series of questions will appear about the COE Comp Parent Segment asking:  Do you want to add it to your segment installation list?
Circle one:  PASS / FAIL

B.1.8
Answer [NO] to this question for each segment until “Enter your name for the tape header” appears.
A following prompt will appear:

“Enter your name for the tape header”.
Circle one:  PASS / FAIL

B.1.9
Enter the name: 


KPC Segment Media
The following prompt will appear: 

“Enter a serial number for the Tape Header.”
Circle one:  PASS / FAIL

B.1.10
Enter the serial number:  


1234567890
The following prompt will appear: 

“Enter any desired comment to put in the Tape Header (up to 255 characters)."
Circle one:  PASS / FAIL

B.1.11
Enter the following comment:

  These are KPC Vendor Test Segments


The Candidate Platform will compute compressed segment size for each segment processed, give you an index of what will be put on the tape, tell you how many segments are being processed and ask you to insert tape #1 and press any key to continue. 
Circle one:  PASS / FAIL

B.1.12
Press carriage return.
The Candidate Platform will give you information on records in and out.  Then it will show “DII Install tape completed.”  The system prompt appears.
Circle one:  PASS / FAIL

B.2
Create “Sample Segment – Generic” Tape, where the seginfo file MACHINE & CPU fields are updated to “ALL”.

OPTIONAL SETUP STEP

Skip if Generic Tape is already available.


Export the Reference Sample Segments from the Validation Host.



B.2.1
On the Validation Host, from the pull down menu, select Hardware > Disk Manager.
The Disk Manager window appears.
Setup

B.2.2
In the Disk Manager window click on [EXPORTFS]
The Export/Unexport File Systems Window appears.
Setup

B.2.3
In the “Export/Unexport File Systems” window:

Enter options: rw, anon=0

Enter Pathname: /h/DII_DEV

Select [EXPORT]
A dialog box appears asking “Do you wish to permanently export?”.
Setup

B.2.4
Select [YES] to the “Permanent export” dialog.
The dialog box disappears.
Setup


NFS mount the Reference Sample Segments on the Candidate Platform.



B.2.5
On the Candidate Platform, from the pull down menu, select Hardware > Disk Manager.
The Disk Manager window appears.
Circle one:  PASS / FAIL

B.2.6
Click on the [MOUNT NEW] button. 
The Mount File System window will appear.
Circle one:  PASS / FAIL

B.2.7
When the Mount File System window appears, enter the new storage volume to be mounted:


kpchost:/h/DII_DEV

and enter the mount point,


/mnt
All fields in the Mount File System window display appropriate information.


Circle one:  PASS / FAIL

B.2.8
Click the [MOUNT] button to continue.
The “permanent mount” window will appear.
Circle one:  PASS / FAIL

B.2.9
When the system asks “Do you wish to Permanently Mount the File System,” choose [NO] to continue.
The disk manager window re-appears with the new disk partition mounted.
Circle one:  PASS / FAIL

B.2.10
Click on the “EXIT” button to exit the Disk Manager.
The Disk Manager closes.
Circle one:  PASS / FAIL

B.2.11
On the Candidate Platform, in the xterm window, at the command line root prompt (#) enter:

 mkdir /h/DII_DEV/Generic

 cd /mnt/SampleSegments

 tar cf - .|(cd /h/DII_DEV/Generic; tar xpf -) 
The xterm returns a system prompt after each command.  The contents of “SampleSegments” has been copied to Generic.

(Step changed per VOR V-0002.)
Setup

B.2.12
Type exit <cr> at the root-kpccp prompt.

Type exit <cr> at the # prompt.

Type exit <cr> at the kpccp% prompt.

Type ksh <cr> at the $ prompt.

Type 

/home1/KPC/fixtestdata.sh –t /h/DII_DEV/Generic <cr> at the $ prompt.


System returns the # prompt.

System returns the kpccp% prompt.

System returns the $ prompt.

Tester has now entered the Korn shell.

The  system returns a  $ prompt and prompts the tester to “Enter the desired CPU value:” 

(Step changed per VOR 201299140000.)
Setup

B.2.13
Enter:  ALL
User is prompted to “Enter the desired OPSYS value:”
Setup

B.2.14
Enter:  ALL
A confirmation line appears.
Setup

B.2.15
Hit ‘Enter’.
Completion message appears in xterm.
Setup

B.2.16
Upon successful completion, re-enter command above with a –c to clean the original seginfo files, i.e.:

/home1/KPC/fixtestdata.sh –t /h/DII_DEV/Generic -c
After a completion message, the xterm returns a system prompt.
Setup

B.2.17
Type csh <cr> at the $ prompt.

Type su - root <cr>.

Type the appropriate root password <cr>.

Type cd /h/DII_DEV/Generic <cr>.

Type:  
/h/DII_DEV/bin/VerifySeg –p .

SampleAcctGrp SampleSW SampleCOTS SampleAgg SampleAggChild SampleSW2 SampleSW.P1 SampleDataSegment SampleDataLocal SampleDataGlobal <cr>.
System returns a kpccp% prompt.

System returns a Password: prompt.

System returns a # prompt.

System returns a # prompt.

Verification results appear in xterm window and the system returns the “#”  prompt.

(Step changed per VOR 201299143100.)
Setup


NOTE: The storage volume provided for test purposes is designated as /dev/rmt/0mn for Sun Solaris.

Where test steps below indicate <<media>>, the substitute the Sun vendor-specified string should be substituted.



B.2.18
Load pre-formatted, empty removable media in the storage device and execute the following command:

/h/DII_DEV/bin/MakeInstall(–t(
/dev/<<media>>(–p(.(`ls`

Note: The –t” is tape specific, and may evolve in the future to use other media.
The following prompt will appear:

“Enter size of tape in Mbytes or type ‘q’ to quit”.


Setup

B.2.19
Enter the capacity of the removable storage media loaded in the previous step.  Specify size in units of Megabytes (i.e. 4 for 4 megabytes).
A series of questions will appear about the COE Comp Parent Segment asking:  Do you want to add it to your segment installation list?

(VOR 201299144500 was not implemented because lead tester could not verify its accuracy.)
Setup

B.2.20
Answer [NO] to this question for each segment until “Enter your name for the tape header” appears.
A following prompt will appear:

“Enter your name for the tape header”.
Setup

B.2.21
Enter the name: 

 KPC Segment Media - Generic
The following prompt will appear: 

“Enter a serial number for the Tape Header.”
Setup

B.2.22
Enter the serial number:  


1234567890
The following prompt will appear: 

“Enter any desired comment to put in the Tape Header (up to 255 characters)."
Setup

B.2.23
Enter the following comment:

These are KPC Generic Test Segments


The platform compressed segment size for each segment processed, give you an index of what will be put on the tape, tell you how many segments are being processed and ask you to insert tape #1 and press any key to continue. 
Setup

B.2.24
Press carriage return.
Information on records in and out is displayed.  Then it will show “DII Install tape completed.”  The system prompt appears.
Setup

B.3
Unmount from the Candidate Platform



B.3.1
On the Candidate Platform, in the Disk Manager window select /mnt, and select [UNMOUNT].
The “Permanently Unmount” window will appear.
Circle one:  PASS / FAIL

B.3.2
At Permanently Unmount window, click [YES].
The Permanently Unmount window disappears.
Circle one:  PASS / FAIL

B.3.3
Click on the “EXIT” button to exit the Disk Manager.
The Disk Manager closes.
Circle one:  PASS / FAIL


Unexport from the Validation Host



B.3.4
On the Validation Host, in the Disk Manager window and select [EXPORTFS].
The “Export/Unexport File System” window appears.
Setup

B.3.5
Enter in Pathname: “/h/DII_DEV”, and click the [UNEXPORT] button.
The “Permanently Unexport?” dialog will appear.
Setup


At Permanently Unexport window, click [YES].
In the “Export/Unexport File System” window, /h/DII_DEV no longer shows as being exported.
Setup

B.3.6
Click on the “EXIT” button to exit the Disk Manager.
The Disk Manager closes.
Setup

B.3.7
Click EXIT on the CDE Front Panel.

Click Continue logout.
A Logout Confirmation window appears.

The Logout Confirmation window disappears and the DII COE Login screen appears.

(Step changed per VOR 211299120000.)
Setup

C
Verify access and configuration of default accounts



C.1
Verify access and configuration of the root account. 



C.1.1
On the Candidate Platform, log in to the sysadmin account using the appropriate sysadmin password.

Click EXIT on the CDE Front Panel.

Click Continue logout. 

Type root <cr> in the Name: field.

Type the appropriate root password <cr>.


The menu bar, security classification, and CDE desktop appears

A Logout Confirmation window appears.

The Logout Confirmation window disappears and the DII COE Login screen appears.

Field accepts input and cursor moves to Password: field.

Field accepts input, DII COE Login screen disappears, Root desktop appears.

(Step changed per VOR 211299130000.)
Circle one:  PASS / FAIL

C.1.2
Verify that there is neither a system menu bar nor a security banner.
Neither the system menu bar nor security banner appears.
Circle one:  PASS / FAIL

C.1.3
Verify CDE bar access by clicking on each icon.  The icons include, on the right:

Trash can:

Help Viewer

Application Manager:

Style Manager:

Printer Manager:

On the left:

Mail:

Text Editor:

File Manager:

Calendar:

Clock:
Clicking on each CDE toolbar icon (with the exception of the clock and/or trash can) launches a window with the specified label.
Circle one:  PASS / FAIL

C.1.4
Call up a dtterm window by doing the following:  Click on the up arrow above the Text Editor icon and select “Terminal” from the pop-up menu.
A dtterm window opens with the root prompt (#).
Circle one:  PASS / FAIL

C.1.5
Look at the CDE Toolbar and verify the Profile Selector (human head icon) option is not available.
Profile Selector is not visible in CDE Toolbar.


Circle one:  PASS / FAIL

C.1.6
Click EXIT on the CDE  Front Panel.

Click Continue logout.
A Logout Confirmation window appears.

The Logout Confirmation window disappears and the DII COE Login screen appears.

(Step changed per VOR 211299134900.)
Circle one:  PASS / FAIL

C.2
Verify access and configuration of the Security Admin (secman) account. 



C.2.1
On the Candidate Platform, log in to the sysadmin account using the appropriate sysadmin password.

Click EXIT on the CDE Front Panel.

Click Continue logout.

Type secman <cr> in the Name: field.

Type the appropriate secman password <cr>.


The menu bar, security classification, and CDE desktop appears.

A Logout Confirmation window  appears.

The Logout Confirmation window disappears and the DII COE Login screen appears.

Field accepts input and cursor moves to Password: field.

Field accepts input, DII COE Login screen disappears, secman desktop appears.

(Step changed per VOR 211299140000.)
Circle one:  PASS / FAIL

C.2.2
Verify CDE bar access by clicking on each icon.  The icons include, on the right:

Trash Can:

Help Viewer:

Application Manager:

Style Manager:

Printer Manager:

On the left:

Mail:

Text Editor:

Profile Selector:

File Manager:

Calendar:

Clock:
Clicking on each CDE toolbar icon (with the exception of the clock and/or trash can) launches a window with the specified label.
Circle one:  PASS / FAIL

C.2.3
Verify security banner includes security classification and COE version markings.
The security banner appears with the correct CLASSIFICATION and COE Version. The proper security marking is UNCLASS on a GREEN field.
Circle one:  PASS / FAIL

C.2.4
Verify CDE toolbar access by clicking on the Apps Manager and opening the following top level folders: DeskTop_Tools, DeskTop_Apps, DII_Apps, and DII_Tools.
Apps Manager opens and each folder is accessible.


Circle one:  PASS / FAIL

C.2.5
Click on DII_APPS > L:SSO_Default and Verify the following icons are present:

“..go up”, “Assign Passwords”, “Edit Profiles”, “Profile Selector Config”, “Security Manager”, “Security Mgr Remote”, “Unlock Users”, “Update Security.  Click on each one to verify accessibility.

NOTE:  Audit Log File Manager may also be present and launch 
Verify all icons are present and accessible.
Circle one:  PASS / FAIL

C.2.6
Verify that the user cannot access an xterm window from the following places:

a. In the opened L:SSO_Default folder.

b. Click on the File Manager icon on the CDE toolbar.

c. Once the windows of the two locations open check for xterm and dtterm icons.
Neither the xterm nor the dtterm should be present in either location.
Circle one:  PASS / FAIL

C.2.7
Verify that Profile Selector (a human head icon) is visible and available for selection from the CDE Toolbar.
Profile Selector is visible and accessible.
Circle one:  PASS / FAIL

C.2.8
Click on the Profile Selector icon.  Verify that the L:SSO_Default Profile is the default selection.
L:SSO_Default Profile appears and is listed as the selected profile.
Circle one:  PASS / FAIL

C.2.9
Verify that no other Profiles are available for selection from within the Profile Selector and then click on the [CANCEL] button.
Profile Selector only contains the L:SSO_Default Profile.  Then the profile selector closes.

Note: The Profile Selector may contain “L:SSO Tools”, which is allowed to contain vendor specific platform administration tools.  If L:SSO_Tools is the only profile present, and a KPC waiver supports its use, this step result is “PASS”.
Circle one:  PASS / FAIL

C.2.10
Click EXIT on the CDE Front Panel.

Click Continue logout.
A Logout Confirmation window appears.

The Logout Confirmation window disappears and the DII COE Login screen appears.

(Step changed per VOR 211299143200.)
Circle one:  PASS / FAIL

C.3
Verify access and configuration of the System Admin account.



C.3.1
Type sysadmin <cr> in the Name: field.

Type the appropriate sysadmin password <cr>.
Field accepts input and cursor moves to Password: field.

Field accepts input, DII COE Login screen disappears, sysadmin desktop with CDE toolbar appears.

(Step changed per VOR 211299143500.)
Circle one:  PASS / FAIL

C.3.2
Verify that the security banner is present, accurate, and includes security classification and COE Version markings.
Security banner appears with the correct Classification and COE Version. The proper security marking is UNCLASS on a GREEN field.
Circle one:  PASS / FAIL

C.3.3
Verify CDE bar access by clicking on each icon.  The icons include, on the right:

Trash Can:

Help Viewer:

Application Manager:

Style Manager:

Printer Manager:

On the left:

Mail:

Text Editor:

Profile Selector:

File Manager:

Calendar:

Clock:
Clicking on each CDE toolbar icon (with the exception of the clock and/or the trash can) launches a window with the specified label.
Circle one:  PASS / FAIL

C.3.4
Verify that the system menu bar is present.


The System Menu Bar contains the following options: “SA System”, “Hardware”, “Software”, “Network”, and “Help”.
Circle one:  PASS / FAIL

C.3.5
Click on Apps_ Mgr and verify that the following top level folders exist: DeskTop_Tools, DeskTop_Apps, DII_Apps, and DII_Tools.
Applications Manager window opens and the following icons are present: DeskTop_Tools, DeskTop_Apps, DII_Apps, and DII_Tools
Circle one:  PASS / FAIL

C.3.6
Click on these icons to open both an xterm window and a dtterm window : DII_Apps>L:SA_Default>Xterm.

DII_APPS>L:SA_Default>DTterm  

Verify both windows require  a login.
A login window appears displaying the COE version, the OS version, and a login: prompt.

A dtterm window appears displaying the COE version, the OS version, and a login: prompt.  The dtterm window may also have the Window, Edit, Options and Help menu headings visible and available.

Xterm and Dtterm windows are accessible; both windows require a login .

(Step changed per VOR 211299144600.)
Circle one:  PASS / FAIL

C.3.7
Verify that Profile Selector is available for selection from the CDE Toolbar and that the SA_Default Profile is the default selection.
Profile Selector is available and SA_Default Profile is listed as Selected.
Circle one:  PASS / FAIL

C.3.8
Verify no other Profiles are available for selection from within the Profile Selector.
Only SA_Default default profile is listed.

Note: The Profile Selector may contain “L:SA Tools”, which is allowed to contain vendor specific platform administration tools.  If L:SA_Tools is the only profile present, and a KPC waiver supports its use, this step result is “PASS”.
Circle one:  PASS / FAIL

D
Verify candidate platform configuration and major functionality.
Verifies basic platform configuration baseline and ability to modify the configuration.


D.1
Set up the Default Router



D.1.1
On the Candidate Platform, Make sure you are in an xterm window and logged in as sysadmin.

Type su - root <cr> in the xterm window.

Enter the appropriate root password and <cr>.
The system prompt (kpccp%) appears in the xterm window.

A Password: prompt appears.

The system returns a system (#) prompt

(Step changed per VOR V-0003.)
Circle one:  PASS / FAIL

D.1.2
At the system prompt in the xterm window, enter the following command:

     su - root


netstat –nr
The user is asked to enter the root password.

System displays routing table information, and returns a system prompt.
Circle one:  PASS / FAIL


If the word "default" exists in this routing table, execute steps D.1.2a through D1.2d below, otherwise skip to step D.1.3.



D.1.2a
Enter the following command to delete the “default” entry from the “netstat” command in step D.1.2:


route delete default <<IP_Address>>
The xterm window displays a root prompt (#).
Setup

D.1.2b
To terminate root privilege enter the following command at the system prompt in the xterm window:


exit

To terminate root privilege 
The xterm window displays a system prompt (kpccp%).
Setup

D.1.3
At the system prompt in the xterm window, enter the following command:


ls /etc/<<router file>>

NOTE:  Each UNIX handles default router slightly differently.
Record the type file used:

<<router file>>____________________

If the file “/etc/<<router file>>” exists, the system returns the filename, followed by a system prompt (#).

If the file does not exist, the system will confirm that the file does not exist.
Circle one:  PASS / FAIL


If the file /etc/<<router file> exists, at the system prompt in the xterm window, execute steps D.1.3a through D1.3d below, otherwise skip to step D.1.4.



D.1.3a
Enter the following command:

su - root
The user is asked to enter the root password.
Setup

D.1.3b
Enter the password for root.
The xterm window displays a root prompt prompt.
Setup

D.1.3c
At the system prompt in the xterm window, enter the following command:

rm /etc/<<router file>>
The xterm window displays a root prompt prompt.
Setup

D.1.3d
To terminate root privilege enter the following command at the system prompt in the xterm window:


exit
The xterm window displays a system prompt.
Setup

D.1.4
From the pull down menu, at the top of the DII COE screen, set the default router using Network > Servers  > Set Routes 
Default Router Setup window appears.
Circle one:  PASS / FAIL

D.1.5
In the “Default Router Setup” window, enter the IP address for the Validation Host as the default router and select [OK].
NOTE:  Do not select  “This system is the default router.” option when executing this instruction.
“Default Router was set” appears.
Circle one:  PASS / FAIL

D.1.6
Type su - root <cr> in the xterm window.

Enter the appropriate root password and <cr>.
Type netstat -nr <cr> in the xterm window.
A Password: prompt appears.

The system returns a system (#) prompt.

System displays routing table information in the xterm, and returns a system prompt.  The word “default” appears, and is associated with the Validation Host’s IP address.

(Step changed per VOR V-0004.)
Circle one:  PASS / FAIL

D.2
Set up the Domain Name Server



D.2.1
From an xterm, execute the command:


ls /etc/resolv.conf

If the file "resolv.conf" exists, execute steps D.2.1a through D2.1d below, otherwise skip to step D.2.2.
If the /etc/resolv.conf file exists, the system returns the filename, followed by a system prompt. If the file does not exist,  the system returns:

/etc/resolv/conf: No such file or directory.

(Step changed per VOR 211299151000.)
Setup

D.2.1a
Enter the following command:

su - root
The user is asked to enter the root password.
Setup

D.2.1b
Enter the password for root.
The root prompt is returned.
Setup

D.2.1c
At the system prompt in the xterm window, enter the following command:


rm /etc/resolv.conf
The root prompt is returned
Setup

D.2.1d
To terminate root privilege enter the following command at the system prompt in the xterm window:


exit
The xterm window displays a system prompt.
Setup

D.2.2
Set up the DNS: On the Pull Down Menu, select Network > Servers > Set DNS option on the menu bar. 
The DNS Setup window appears.
Circle one:  PASS / FAIL

D.2.3
In the “DNS Server IP Search Order” field of the DNS Setup window, enter the Validation Host IP address and click the [ADD] button.
In the “DNS Server IP Search Order” field, the Validation Host IP address appears in the IP Search Order block below the data entry field.
Circle one:  PASS / FAIL

D.2.4
In the “Domain Suffix Search Order” field of the DNS Setup window, enter the following:  “kpc.disa.mil”.  Click on “ADD”.
In the “Domain Suffix Search Order” field, “kpc.disa.mil” appears in the Domain Suffix Search Order block below the data entry field.
Circle one:  PASS / FAIL

D.2.5
In the “DNS Setup” window click on “OK”.
A “Setup Complete” window appears displaying “DNS was successfully installed”.
Circle one:  PASS / FAIL

D.2.6
In the “Setup Complete” window, click “OK”.
The “Setup Complete” window and the DNS Setup window both disappear.
Circle one:  PASS / FAIL

D.2.7
At the system admin prompt in the xterm window, enter the following command:


nslookup
The display identifies the Default Server as "kpchost.kpc.disa.mil" with an IP address of <<Validation Host IP Address>>.

System returns an ‘nslookup’ prompt (>) in the xterm window.
Circle one:  PASS / FAIL

D.2.8
Close the nslookup application by entering the following command:


exit
The xterm window displays a system admin prompt.
Circle one:  PASS / FAIL

D.2.9
Verify the /etc/resolv.conf file exists. 

From an xterm, execute the command:


cat /etc/resolv.conf
The following information is displayed:

“nameserver <<Validation Host IP Address>>

Search kpc.disa.mil”
Circle one:  PASS / FAIL

D.3
Configure a new network printer and perform print services.

Remote Printing




Add the network printer hostname (i.e. "kpcnetlp") and IP address to the /etc/hosts file.



D.3.1


From the pull down menu, at the top of the DII COE screen, set the default router using Network > Edit Local Host 
Edit Local host window appears.
Circle one:  PASS / FAIL

D.3.2
When the Edit Hosts window appears, select the [ADD] button.
An “Add Machine” window appears.
Circle one:  PASS / FAIL

D.3.3
When the [Add Machine] window appears,  in the machine name field, type:


             kpcnetlp
In the address field, Enter:

    <<Printer IP Address>> 

Click on [OK] in the [Add Machine] window.
The “Add Machine” window disappears and the “Edit Hosts” window re-appears.  The “Edit Hosts” window will show “kpcnetlp” listed as a new host.
Circle one:  PASS / FAIL

D.3.4
Click on [OK] in the [Edit Hosts] window.
The “Edit Hosts” window disappears
Circle one:  PASS / FAIL

D.3.5
From the pulldown menu bar at the top of the DII COE screen, select SA System > Printer > Printer Domain Config.
A dialog box appears requesting for a printer domain name.
Circle one:  PASS / FAIL

D.3.6
Enter “print.domain” and select [OK].
“Terminate Printer Services” query window appears.
Circle one:  PASS / FAIL

D.3.7
When prompted to “Terminate Printer Services,” respond [YES].
Informational message confirms termination of print services.
Circle one:  PASS / FAIL

D.3.8
Reboot the computer after the domain has been set, and then log back in as sysadmin.
Machine should reboot properly and sysadmin login performed.
Circle one:  PASS / FAIL

D.3.9
Select the SA System > Printer>Printer Administrator from the Pull Down Menu.
Printer Administration window appears.
Circle one:  PASS / FAIL

D.3.10
In the Printer Administration window, select Edit > Add Printer and supply the following information in the appropriate fields:

Printer Name
= kpcnetlp

Host Name
= kpccp

Description 
= KPC Test



    Network



      Printer

LP Server Host Name
= kpcnetlp
LP Printer Name
= kpcnetlp

The appropriate printer specific information for the following fields is entered:

Printer Model/Type

Printer Port Name
All fields in the Printer Administration window have appropriate information.

The printer specific information entered for the following fields is:

Printer Model/Type:

  ________________________

Printer Port Name:

  ________________________
Circle one:  PASS / FAIL

D.3.11
Select [OK] when the above information is complete.


Printer Administrator window will reappear with the new printer queue listed and information specific to that printer is displayed.
Circle one:  PASS / FAIL

D.3.12
In the Printer Administrator window, highlight the new printer and select Control > Set as Default to set the System Default printer.

Click [Close].
Printer Administrator is updated with the selected Default Printer listed in the lower right hand corner of the window, and a Message window appears stating: System Default Printer is kpcnetlp [Close].

The Message window disappears. 

(Step changed per VOR 221299161000.)
Circle one:  PASS / FAIL

D.3.13
To test the printing capability, open the File Manager from the CDE toolbar and select View > Show Hidden Objects. 
Hidden Objects will appear in the file manager window. 
Circle one:  PASS / FAIL

D.3.14
Select any hidden files listed and drag them down to the Printer Icon on the CDE Toolbar.
The Print Selector window will appear with the printer listed in the default position.
Circle one:  PASS / FAIL

D.3.15
Select Network > Edit Local Hosts from the pull down menu.

Verify the IP address for the kpcnet1p entry is 204.34.175.222.

Click [PRINT] to continue.
The EDIT HOSTS table appears.

The desired print job will print to the printer.

(Step changed per VOR V-0005.)
Circle one:  PASS / FAIL

D.4
Set up Trusted/Non-Trusted Systems.



D.4.1
On the Candidate Platform: Enable rlogin



D.4.1.1
Log into the Candidate Platform as sysadmin
CDE desktop and CDE panel is displayed.

(Step removed per VOR 231299092000)
Circle one:  PASS / FAIL



D.4.1.2
Open an xterm via the Application Manager
The xterm window opens, presenting a login prompt.
Circle one:  PASS / FAIL

D.4.1.3
Log into the xterm as sysadmin
System prompt is displayed.
Circle one:  PASS / FAIL

D.4.1.4
su to the root id using:


su - root
A password prompt is displayed.
Circle one:  PASS / FAIL

D.4.1.5
Enter the root id password.
System prompt is displayed.
Circle one:  PASS / FAIL

D.4.1.6
NOTE:  If you are testing, or using, a platform that is running Solaris or Sun OS, skip steps D.4.1.6 through D.4.2.15.

Change to the /etc directory by typing:


cd /etc
System prompt is displayed.

(Step changed per VOR 231299092500.)
Circle one:  PASS / FAIL

D.4.1.7
Open the file “inetd.conf” using the vi editor.


vi inetd.conf
The file is displayed.
Circle one:  PASS / FAIL

D.4.1.8
Switch to command mode using [shift]-: (colon) key combination.
A colon is displayed at the bottom of the screen.
Circle one:  PASS / FAIL

D.4.1.9
Search for the rlogin entry using the search function type:


/rlogin
Cursor moves to the line containing rlogind.
Circle one:  PASS / FAIL

D.4.1.10
Use the [h] key repeatedly to move to the start of the line.
Cursor moves toward the start of the line.
Circle one:  PASS / FAIL

D.4.1.11
NOTE:  If the # symbol is present, continue with this step.  If the # symbl is NOT present, skip this step and continue with step D.4.1.12.

Remove [#] (pound symbol) at the start of the line by pressing [ESC] then ”x” (vi ‘remove character’ command).
The # symbol is deleted.

(Step changed per VOR V-0006.)
Circle one:  PASS / FAIL

D.4.1.12
Leave ‘delete’ mode by pressing the [esc] key.

Circle one:  PASS / FAIL

D.4.1.13
Enter command mode by pressing [shift]-: (colon) key combination.
A colon appears at the bottom of the screen.
Circle one:  PASS / FAIL

D.4.1.14
Write to file and quit vi.

Type:


wq [RETURN]
File name is displayed in quote with information on number of lines total characters, then system prompt returns.
Circle one:  PASS / FAIL

D.4.1.15
Reboot the system by selecting Hardware > Reboot System from the pull down menu.
A window appears confirming that the user wishes to reboot the system.
Circle one:  PASS / FAIL

D.4.2
On the Validation Host:

Enable rlogin



D.4.2.1
Log into the Validation Host as sysadmin
CDE desktop and CDE panel is displayed.
Setup

D.4.2.2
Open an xterm via the Application Manager
The xterm window opens, presenting a login prompt.
Setup

D.4.2.3
Log into the xterm as sysadmin
System prompt is displayed.
Setup

D.4.2.4
su to the root id using:


su - root
A password prompt is displayed.
Setup

D.4.2.5
Enter the root id password.
System prompt is displayed.
Setup

D.4.2.6
Change to the /etc directory by typing:


cd /etc
System prompt is displayed.
Setup

D.4.2.7
Open the file “inetd.conf” using the vi editor.


vi inetd.conf
The file is displayed.
Setup

D.4.2.8
Switch to command mode using [shift]-: (colon) key combination.
A colon is displayed at the bottom of the screen.
Setup

D.4.2.9
Search for the rlogin entry using the search function type:


/rlogin
Cursor moves to the line containing rlogind.
Setup

D.4.2.10
Use the [h] key repeatedly to move to the start of the line.
Cursor moves toward the start of the line.
Setup

D.4.2.11
Remove [#] (pound symbol) at the start of the line by pressing “x” (vi ‘character delete’ command).
The # symbol is deleted.
Setup

D.4.2.12
Leave insert mode by pressing the [esc] key.

Setup

D.4.2.13
Enter command mode by pressing [shift]-: (colon) key combination.
A colon appears at the bottom of the screen.
Setup

D.4.2.14
Write to file and quit vi.

Type:


wq [RETURN]
File name is displayed in quote with information on number of lines total characters, then system prompt returns.
Setup

D.4.2.15
Reboot the system by selecting Hardware > Reboot System from the pull down menu.
A window appears confirming that the user wishes to reboot the system.
Setup

D.4.3
On the Candidate Platform, log in as sysadmin.  From an xterm, execute the command;


ls /.rhosts
If the /etc/.rhosts file exists, the system returns the filename, followed by a system prompt.

If the file does not exist, a system prompt is returned with the following message:

“/etc/.rhosts not found”.
Circle one:  PASS / FAIL


If the file "/.rhosts " exists, execute steps D.4.3a through D.4.3d below, otherwise skip to step D.4.4.



D.4.3a
Enter the following command:

su - root
The user is asked to enter the root password.
Setup

D.4.3b
Enter the password for root.
The root prompt (#) is returned.
Setup

D.4.3c
At the system prompt in the xterm window, enter the following command:


rm /.rhosts
Root prompt (#) is returned.
Setup

D.4.3d
To terminate root privilege enter the following command at the system prompt in the xterm window:


exit
The xterm window displays a C shell prompt (%).
Setup

D.4.4
From an xterm, execute the command: 


ls /etc/hosts.equiv
If the /etc/hosts.equiv file exists, the system returns the filename, followed by a system prompt.

If the file does not exist, a system prompt is returned with the following message:

“/etc/hosts.equiv not found”.
Circle one:  PASS / FAIL


If the file "/etc/hosts.equiv " exists, execute steps D.4.4a through D.4.4d below, otherwise skip to step D.4.5.



D.4.4a
Enter the following command:

su - root
The user is asked to enter the root password.
Setup

D.4.4b
Enter the password for root.
The root prompt is returned.
Setup

D.4.4c
At the system prompt in the xterm window, enter the following command:


rm /etc/hosts.equiv
The root prompt is returned
Setup

D.4.4d
To terminate root privilege enter the following command at the system prompt in the xterm window:


exit
The xterm window displays a system admin prompt.
Setup

D.4.5
Using the pulldown menus at the top of the DII COE screen, select Network > Edit Local Hosts.
The “Edit Hosts” window appears.


Circle one:  PASS / FAIL

D.4.6
When the Edit Hosts window appears, add a non-trusted system (kpchost) by clicking on the [ADD] button.
An “Add Machine” window appears.

(Step removed per VOR V-0007.)
Circle one:  PASS / FAIL

D.4.7
In the “Add Machine” window, enter the Validation Host hostname (i.e. “kpchost”) and IP address and click [OK].

NOTE:  Do not click on the “trusted machine” checkbox.

 After the “Edit Hosts” window returns, close the “Edit Hosts” window by clicking on the [OK] button.
The “Add Machine” dialog box disappears and the “Edit Host” window re-appears.  An “A” indicating the addition of a new machine is in the column next to the kpchost entry. 

The “Edit Host” window closes.
Circle one:  PASS / FAIL

D.4.8
Verify that a user on the Validation Host must enter a password to login to the Candidate Platform.



D.4.8.1
If not already logged on, log on to the Validation Host as “sysadmin.  Open an xterm window and enter the following command:


rlogin kpccp
NOTE: cannot be root before typing rlogin.
In the xterm window the user is prompted for a password for the kpccp rlogin session.
Circle one:  PASS/FAIL

D.4.8.2
On the Validation Host, in the xterm rlogin session, enter the Candidate Platform sysadmin password.
The rlogin xterm returns a candidate platform system prompt, “kpccp%”.


D.4.8.3
On the Validation Host, in the xterm rlogin session, su to root by typing:  

     su
In the xterm window the user is prompted for a root password for the kpccp rlogin session.


D.4.8.4
On the Validation Host, in the xterm rlogin session, enter the Candidate Platform root  password.
The rlogin xterm returns a candidate platform root prompt “#”.


D.4.8.5
On the Validation Host, in the xterm rlogin session, enter “exit” to drop from root to sysadmin to the Validation Host.
On the Validation Host, the rlogin xterm window returns a candidate platform system prompt, “kpccp%”.


D.4.8.6
On the Validation Host, in the xterm window, enter “exit” to return to the Validation Host.
On the Validation Host, the rlogin xterm window returns the message “connection closed” and returns a Validation Host system prompt “kpchost%”.


D.4.8.7
On the Candidate Platform, in the xterm window, confirm the appropriate changes to the /.rhosts file by entering the following command in the xterm window:


cat /.rhosts
The system returns Cannot open /.rhosts: No such file or directory.

(Step changed per VOR V-0008.
Circle one:  PASS / FAIL

D.4.8.8
Confirm appropriate changes to the /etc/hosts.equiv  file. 
Type
cat /etc/hosts.equiv <cr> at the # prompt.
None.

System returns either cat: cannot open /hosts.equiv or a system prompt.

(Step changed per VOR 231299134000.)
Circle one:  PASS / FAIL

D.4.8.9
Confirm the appropriate changes to the /etc/hosts  file by entering the following command in the xterm window:


cat /etc/hosts


The Validation Host appears in the file, as “kpchost”.

The Candidate Platform appears in the file.

The Local Host appears in the file.

The sysadmin prompt is returned.
Circle one:  PASS / FAIL

D.4.9
Click on the DII COE pulldown menus Network > Edit Local Hosts.  In the Edit Hosts window, delete the non-trusted system by selecting the Validation Host (i.e. kpchost) and selecting the [DELETE] button.
The “Delete Machine” confirmation window appears.
Circle one:  PASS / FAIL

D.4.10
In the “Delete Machine” confirmation window select the [YES] button.
The “Delete Machine” confirmation window disappears, and the “Edit Hosts” window re-appears.  A “D” appears beside the “kpchost” entry.
Circle one:  PASS / FAIL

D.4.11
Click [OK] to accept changes.
The “Edit Hosts” window accepts the changes and closes.
Circle one:  PASS / FAIL

D.4.12
On the Candidate Platform, in the xterm window, confirm the appropriate changes to the /.rhosts file by entering the following command in the xterm window:


cat /.rhosts
The system returns Cannot open /.rhosts: No such file or directory.

(Step changed per VOR V-0009.)
Circle one:  PASS / FAIL

D.4.13


On the Candidate Platform, in the xterm window, confirm the appropriate changes to the /etc/hosts.equiv file by entering the following command in the xterm window:

cat /etc/hosts.equiv
The system returns Cannot open /etc/hosts.equiv: No such file or directory.

(Step changed per VOR V-V010.)
Circle one:  PASS / FAIL

D.4.14
Confirm the appropriate changes to the /etc/hosts file by entering the following command in the xterm window:


cat /etc/hosts
Some header info, an entry for kpccp and an entry for Local Host appear in the file.
Circle one:  PASS / FAIL

D.4.15
Add "kpchost" as a trusted system.



D.4.15.1
From the pulldown menus, select "kpchost" via the Network > Edit Local Hosts.
The “Edit Hosts” window appears.
Circle one:  PASS / FAIL

D.4.15.2
In the “Edit Hosts” window, select [Add Machine]. 
An “Add Machine” window appears.
Circle one:  PASS / FAIL

D.4.15.3
In the New Machine Name field enter "kpchost", and in the New Machine Address field, enter the Validation Host IP address. Select the “Trusted Machine” checkbox.  Select [OK].
An “Add Machine” window disappears.
Circle one:  PASS / FAIL

D.4.15.4
In the “Edit Hosts” window, select [OK].
The “Edit Hosts” window disappears.
Circle one:  PASS / FAIL

D.4.16
After the machine has been added, verify that the user on Validation Host logs in to the Candidate Platform without using a password.

On the Validation Host, in an xterm window, ensure you are not root, then enter the following command:


rlogin kpccp
On the Validation Host, the  xterm window returns a Candidate Platform system prompt (kpccp%) without prompting the user to enter a password.  (Validation host has trusted status.)
Circle one:  PASS / FAIL

D.4.17
Enter exit <cr> on the Validation Host to close the rlogin connection.
The xterm window returns:

kpccp% logout

Connection closed.

kpchost%
(Step changed per VOR 231299135000.)
Circle one:  PASS / FAIL

D.4.18
On the Candidate Platform, confirm the appropriate changes to the /.rhosts file by entering the following command in the xterm window:


su – root
User is prompted for the root password.
Circle one:  PASS / FAIL

D.4.19
On the Candidate Platform, enter root password, then the following command:

      cat /.rhosts
Only the Validation Host appears in the file, as “kpchost”.
Circle one:  PASS / FAIL

D.4.20
On the Candidate Platform, enter the following command:

       exit
The sysadmin prompt is returned.
Circle one:  PASS / FAIL

D.4.21
Confirm the appropriate changes to the /etc/hosts.equiv  file by entering the following command in the xterm window:


cat /etc/hosts.equiv
Only the Validation Host appears in the file, as “kpchost”.

The sysadmin prompt is returned.
Circle one:  PASS / FAIL

D.4.22
Confirm the appropriate changes to the /etc/hosts  file by entering the following command in the xterm window:


cat /etc/hosts
Some header info, an entry for the Validation Host, and entry for the Local Host and an entry for kpccp appear in the file.

The sysadmin prompt is returned.
Circle one:  PASS / FAIL

D.4.23
Disable rlogin



D.4.23.1
su to the root id using:


su - root
A password prompt is displayed.
Circle one:  PASS / FAIL

D.4.23.2
Enter the root id password.
System prompt is displayed.
Circle one:  PASS / FAIL

D.4.23.3
Change to the /etc directory by typing:


cd /etc
System prompt is displayed.
Circle one:  PASS / FAIL

D.4.23.4
Open the file inetd.conf using the vi editor.


vi inetd.conf
The file is displayed.
Circle one:  PASS / FAIL

 D.4.23.5
Switch to command mode using [shift]-: (colon) key combination.
A colon is displayed at the bottom of the screen.
Circle one:  PASS / FAIL

 D.4.23.6
Search for the rlogin entry using the search function:


type /rlogin
Cursor moves to the line containing rlogind.
Circle one:  PASS / FAIL

 D.4.23.7
Use the [h] key repeatedly to move to the start of the line.
Cursor moves toward the start of the line.
Circle one:  PASS / FAIL

 D.4.23.8
Insert the [#] (pound symbol) at the start of the line by pressing [ESC] and then the [i] key.  Press the ‘#’ key.
The # symbol is added.
Circle one:  PASS / FAIL

 D.4.23.9
Leave insert mode by pressing the [ESC] key.

Circle one:  PASS / FAIL

D.4.23.10
Enter command mode by pressing [shift]-: (colon) key combination.
A colon appears at the bottom of the screen.
Circle one:  PASS / FAIL

D.4.23.11
Write to file and quit vi.

Type:


wq [RETURN]
File name is displayed in quote with information on number of lines total characters, then system prompt returns.
Circle one:  PASS / FAIL

D.4.23.12
Reboot the system by selecting Hardware > Reboot System from the pull down menu.
A window appears confirming that the user wishes to reboot the system.
Circle one:  PASS / FAIL

D.5
Verify that Disk Manager properly creates and mounts a new disk partition. 

Note:  Verification of a ‘permanent’ mount is completed in Step D.7.



D.5.1
 Type sysadmin <cr> in the Name: field.

Type the appropriate sysadmin password <cr>.
Field accepts input and cursor moves to Password: field.

Field accepts input, DII COE Login screen disappears, CDE desktop toolbar appears.

(Step changed per VOR 231299151900.)
Circle one:  PASS / FAIL

D.5.2
From the pulldown menu at the top of the DII COE screen, select Hardware > Disk Manager to open the Disk Manager window.
The Disk Manager window appears on the screen.


Circle one:  PASS / FAIL

D.5.3
If the storage volume corresponds to a floppy disk, exercise steps D.5.3.a through D.5.3.c below, otherwise, skip to step D.5.4.



D.5.3.a
Insert a floppy disk, and in the “Disk Manager” window,

     Click [INIT FD]
A warning window appears.
Circle one:  PASS / FAIL

D.5.3.b
Click [CONTINUE]

Click [OK].
The WARNING window stays visible until the initialization is complete.  A DONE window appears, stating: FLOPPY INITIALIZATION COMPLETE [OK].

The  DONE window disappears.

(Step changed per VOR 231299152500,)
Circle one:  PASS / FAIL

D.5.4
Click [NEWFS] button.
NEWFS window appears.
Circle one:  PASS / FAIL

D.5.5
 Highlight the <unknown> entry in the Disk Device: field and replace it with:  /vol/dev/rdiskette0/unnamed_floppy and click [OK]. 
 A Warning! window appears stating:  This will destroy all data on the selected device.  Are you sure you want to proceed? [Continue][Cancel] 
(Step changed per VOR 231299154700.)
Circle one:  PASS / FAIL

D.5.6
Click the [CONTINUE] button.
The WARNING! window remains visible until the NEWFS operation is complete.

(Step changed per VOR231299155700.) 
Circle one:  PASS / FAIL

D.5.7
Click on the [MOUNT NEW] button. 
The Mount File System window will appear.
Circle one:  PASS / FAIL

D.5.8
Enter  this information in the Mount File System window:


/dev/<<volume>>

and enter the mount point,


/home3

NOTE:  The device naming convention is OS-specific.  Be sure to enter the exact device name the OS requires (i.e., if you are using Solaris 2.x, use /vol/dev/diskette0/unnamed_floppy).
All fields in the Mount File System window display appropriate information.

(Step changed per VOR 271299083000.)


Circle one:  PASS / FAIL

D.5.9
Click the [MOUNT] button to continue.
The “permanent mount” window will appear.
Circle one:  PASS / FAIL

D.5.10
When the system asks “Do you wish to Permanently Mount the File System,” choose [YES] to continue.
The disk manager window re-appears with the new disk partition mounted.
Circle one:  PASS / FAIL

D.5.11
Click on the “EXIT” button to exit the Disk Manager.
The Disk Manager closes.
Circle one:  PASS / FAIL

D.6
Change the Candidate Platform machine ID (hostname and IP address).



D.6.1
From the pull down menu, select Hardware > Disk Manager.
The Disk Manager window appears.
Circle one:  PASS / FAIL

D.6.2
In the Disk Manager window select /home3, and select [UNMOUNT].
The “Permanently Unmount” window will appear.
Circle one:  PASS / FAIL

D.6.3
At Permanently Unmount window, click [YES].
The Permanently Unmount window disappears.
Circle one:  PASS / FAIL

D.6.4
In the Disk Manager window select [EXIT].
The Disk Manager window disappears.
Circle one:  PASS / FAIL

D.6.5
On the Validation Host, from the pulldown menus, select Network >Edit Local Hosts >Add 

Enter: "kpctest" as the machine name 

and as the machine address, enter an IP address not currently in use in the validation cell.
The ‘Edit Host” window shows “kpctest” as added to the host table.

Enter the IP Address used:

    ___________________________
Setup

D.6.6
On the Validation Host, In the ‘Edit Local Hosts’ window select [OK].
The Edit Local Hosts window disappears.
Setup

D.6.7
On the Candidate Platform, from the pulldown menus at the top of the DII COE screen, select Network > Edit Local Hosts to open the Edit Local Hosts window
‘Edit Hosts’ Window appears
Circle one:  PASS / FAIL

D.6.8
On the Candidate Platform, in the ‘Edit Hosts” window, a list of current  hosts should appear, highlight kpccp and click on [EDIT]
“Edit Current Machine” dialog window appears, asking you to confirm that you want to edit this machine select [YES]
Circle one:  PASS / FAIL

D.6.8.a
“Edit Machine” dialog window appears, in the New Machine Name field, enter kpctest, and in the New Machine Address field, enter the IP address that you created for kpctest in step D.6.5, select [OK]
A ‘Reboot Machine’ dialog box appears, asking if you want to reboot the machine now.
Circle one:  PASS / FAIL

D.6.8.b
Click [YES]
Machine reboots
Circle one:  PASS / FAIL

D.7
Verify that the disk mount and machine ID changes remain in effect after reboot.



D.7.1
Verify the DII COE Login screen displays new machine ID. 

Type sysadmin <cr> in the Name: field. 

Type the appropriate sysadmin password <cr>.
DII COE Login screen displays ‘kpctest’ as machine ID.

Field accepts input and cursor moves to Password: field.

Field accepts input, DII COE Login screen disappears, sysadmin desktop with CDE toolbar appears.

(Step changed per VOR 271299084000.)
Circle one:  PASS / FAIL

D.7.2
Select DII_APPS>L:SA_Default>Xterm.

Type sysadmin <çr> at the login: prompt.

Type the appropriate sysadmin password <cr>.
A login window appears displaying the COE version, the OS version, and a login: prompt.

A Password: prompt appears in the xterm.

A ‘kpctest%’ prompt appears.

(Step changed per VOR 271299085000.)
Circle one:  PASS / FAIL

D.7.3
Verify that the new hostname remains in effect after system shutdown and re-initialization.  At the command prompt in the xterm window, enter the following command:


hostname
The hostname command returns  "kpctest".
Circle one:  PASS / FAIL

D.7.4
Verify that the newly unmounted storage volume remains unmounted after reboot.  From the pulldown menus at the top of the DII COE Screen, select Hardware > Disk Manager to open the Disk Manager Window. 
The volume “/home3” is no longer listed as mounted in the Disk Manager window.


Circle one:  PASS / FAIL

D.8
Return Validation Host and Candidate Platform to a known state.



D.8.1
On the Validation Host, from the pulldown menus, select 

    Network >Edit Local Hosts

    Select: "kpctest" as the machine

and select [Delete].
A “delete machine” confirmation dialog box appears.
Circle one:  PASS / FAIL

D.8.2
In the “delete machine” confirmation dialog box, select [YES].
The “delete machine” confirmation dialog box disappears, and the “kpctest” line in the “Edit Host” window is marked with a “D” in the first column.
Circle one:  PASS / FAIL

D.8.3
On the Validation Host, In the Edit Local Hosts window select [OK].
The Edit Local Hosts window disappears.
Circle one:  PASS / FAIL

D.8.4
On the Candidate Platform, from the pull down menu, select Hardware > Disk Manager.
The Disk Manager window appears.
Circle one:  PASS / FAIL

D.8.5
Click on the [MOUNT NEW] button. 
The Mount File System window will appear.
Circle one:  PASS / FAIL

D.8.6
Enter this information in  the Mount File System window: 


/dev/<<volume>>

and enter the mount point,


/home3

NOTE:  The device naming convention is OS-specific.  Be sure to enter the exact device name the OS requires (i.e., if you are using Solaris 2.x, use /vol/dev/diskette0/unnamed_floppy). 
All fields in the Mount File System window display appropriate information.

(Step changed per VOR 271299103500.)
Circle one:  PASS / FAIL

D.8.7
Click [INIT FD].
Click [CONTINUE].

Click [OK].

Click [NEWFS].

Double-click on the <unknown> entry in the DISK DEVICE: field and type /dev/<<volume.>>.

Click [OK].

Click [CONTINUE].


A WARNING! window appears stating: This option could erase the entire contents of the floppy disk.  Are you sure you want to continue?  (This process will take several minutes) [CONTINUE][CANCEL]
The WARNING! window stays visible until initialization is complete and a DONE window appears, stating:  Floppy Initialization Complete [OK].

The DONE window disappears.

A NEW FILE SYSTEM window appears.

Field accepts input.

The DONE window disappears and a WARNING! window appears stating: This will destroy all data on the selected device.  Are you sure you want to proceed?  {CONTINUE][CANCEL]

The WARNING window stays visible until new file system creation is complete, then it disappears.
Circle one:  PASS / FAIL


Enter this information in the Mount File System window:  /dev/<<volume>>

and enter the mount point,

/home3

NOTE (1):  The device naming convention is OS-specific.  Be sure to enter the exact device name the OS requires (i.e., if you are using Solaris 2.x, and are newfs-ing the device, use /vol/dev/rdiskette0/unnamed_floppy).

NOTE (2):  The device naming convention is OS-specific.  Be sure to enter the exact device name the OS requires (i.e., if you are using Solaris 2.x, and are mounting  the device, use /vol/dev/diskette0/unnamed_floppy).
All fields in the Mount File System window display appropriate information.

(Step changed per VOR 271299103700.)


D.8.8
When the system asks “Do you wish to Permanently Mount the File System,” choose [YES] to continue.
The disk manager window re-appears with the new disk partition mounted.
Circle one:  PASS / FAIL

D.8.9
Click on the “EXIT” button to exit the Disk Manager.
The Disk Manager closes.
Circle one:  PASS / FAIL

D.8.10
On the Candidate Platform, from the pulldown menus at the top of the DII COE screen, select Network > Edit Local Hosts to open the Edit Local Hosts window
‘Edit Hosts’ Window appears
Circle one:  PASS / FAIL

D.8.11
Select ‘kpctest’ from the Edit Hosts window and click on [EDIT].

Select [YES].
The Edit Current Machine? window appears, stating:   [kpctest] is the current machine.  Editing this machine will require that the machine be rebooted for changes to take effect.  Are you sure you want to edit this machine?  [YES] [NO]

The Edit Machine window appears.

(Step changed per V-0012.)
Circle one:  PASS / FAIL

D.8.12
“Edit Machine” dialog window appears, in the New Machine Name field, enter kpccp, and in the New Machine Address field, enter the IP address that you created for kpccp in step D.6.5, select [OK]
A REBOOT MACHINE’ dialog box appears, asking if you want to reboot the machine now.
(Step changed per VOR 271299120000.)
Circle one:  PASS / FAIL

D.8.13b
Click [YES]
Machine reboots
Circle one:  PASS / FAIL

D.8.14
Verify the DII COE Login screen displays new machine ID.   

Type sysadmin <cr> in the Name: field.

Type the appropriate sysadmin password <cr>.


DII COE Login screen displays’kpctest’ as machine ID. 

Field accepts input and cursor moves to Password: field.

Field accepts input, DII COE Login screen disappears, sysadmin desktop with CDE toolbar appears.

(Step changed per VOR 271299140000.)
Circle one:  PASS / FAIL

D.8.15
Select DII_APPS>L:SA_Default>Xterm. 

Type sysadmin <cr> at the login: prompt.

Type the appropriate sysadmin password <cr>.
A login window appears displaying the COE version, the OS version, and a login: prompt. 

A Password: prompt appears in the xterm.

A ‘kpctest%’ prompt appears.

(Step changed per VOR 271299140500.)
Circle one:  PASS / FAIL

D.8.16
Verify that the hostname has changed back to the original name, i.e. “kpccp”.  At the command prompt in the xterm window, enter the following command:


hostname
The hostname command returns the "kpccp".
Circle one:  PASS / FAIL

D.9
Install multiple segments onto the Candidate Platform from local storage device using the Segment Installer.



D.9.1
Using the pulldown menus at the top of the DII COE screen, select Software > Segment Installer.
The “Installer” window appears.
Circle one:  PASS / FAIL

D.9.2
Load the generic tape prepared earlier in this test, into the tape drive.  In the “Installer” window, click on the “Select Source” button.
The “Select Source” window appears.

(Step changed per V-0014.)
Circle one:  PASS / FAIL

D.9.3
In the “Select Source” window click on “LOCAL” in the host field and then click on “DAT” in the device field.  Then click on the “OK” button.
The “Installer” window re-appears with the “Source” field populated.
Circle one:  PASS / FAIL

D.9.4
In the “Installer” window, select the “Read Contents” button.
A “Select Software to Install” field appears in the “Installer window, displaying the Table of Contents from the Candidate Platform’s local storage device.
Circle one:  PASS / FAIL

D.9.5
Select the /home3 entry in the available Disks section of the installer window then highlight the following segments to be installed.  Click [Install] to continue.

SampleCOTS, SampleAcctGrp, SampleAgg, SampleDataSegment, SampleSoftwareSegment, and SampleSW.P1.

NOTE:  Only one of each segment type is selected for installation.

NOTE: Up to three passes may be required to successfully install.
At the end of the installation process, the Installer Window re-appears.  

All of the segments listed at left appear in the top half of the window (i.e. “Currently Installed Segments”), and are shown as being installed in /home3.

In the bottom half of the Installer window (i.e. “Select Software to Install”), all of the segments listed at left have an asterisk in the leftmost column. 

(Step changed per VOR 271299142000.)
Circle one:  PASS / FAIL

D.9.6
In the “Installer” window, from the Pull Down Menu, select Installed>View Installation Log.
The Installation Log indicates that all of the segments listed in previous step were  successfully installed.

Installation Log content appears as shown in Attachment 1.
Circle one:  PASS / FAIL

D.9.7
Click on the EXIT button to close the installer window.
1. Segment Installer closes.
Circle one:  PASS / FAIL

D.10
Installation of multiple segments to the newly created partition on the Candidate Platform (/home3).  Segments are drawn from remote removable storage media on the Validation Host.

NOTE:  The following action is not currently exercised during this step, intend to expand coverage to test when feature is implemented:
COEInstaller – test disk override
2. 


D.10.1
On Validation Host, establish “kpccp” as a trusted platform.



D.10.1.1
On the Validation Host, from the pulldown menus, select 

    Network >Edit Local Hosts
An “Edit Hosts” window appears.
Setup

D.10.1.2
In the “Edit Hosts” window, highlight “kpccp” and select [Edit].
The “Edit Machine” dialog box appears.
Setup

D.10.1.3
In the “Edit Machine” dialog box, select “Trusted Machine” checkbox, and select [OK].
The “Edit Machine” dialog box disappears, and the “kpccp” line in the “Edit Host” window is marked with an “MT” in the first column.
Setup

D.10.1.4
On the Validation Host, In the Edit Hosts window select [OK].
The “Edit Hosts” window disappears.
Setup

D.10.2
Copy contents of segment tape from candidate platform to remote tape drive  “/dev/rmt/0mn” on Validation Host.



D.10.2.1
On the Candidate Platform, at the system prompt in the xterm, enter: 

          mt rew
This rewinds the local tape, and the xterm returns a system prompt.
Circle one:  PASS / FAIL

D.10.2.2
At the system prompt in the xterm, enter: 

     rsh kpchost mt rew
This rewinds the remote (Validation Host) tape, and the xterm returns a system prompt.
Circle one:  PASS / FAIL

D.10.2.3
At the system prompt in the xterm, enter: 

            sh
This creates a Bourne shell, and the xterm returns a ‘$’ prompt.
Circle one:  PASS / FAIL

D.10.2.4
At the $ prompt in the xterm, enter: 

while true

do

 dd if=<device> bs=20b     

  | rsh kpchost dd 

   of=/dev/rmt/0mn

done

where <device> is the string used to designate the candidate platform local tape drive.

Note: for Solaris,

              <device> = /dev/rmt/0mn

      for Compaq,

              <device> = /dev/nrm01
Multiple read/write pairs will occur.  After all of the segments have been written, the following message will begin appear in the xterm:

'read error, no space left on device'

Enter <device> string used:

    ________________________
Circle one:  PASS / FAIL

D.10.2.5
When the ‘read error’ message’ appears, all segments have been written to the remote tape. Hit <ctrl-c> to terminate the loop.
This loop terminates, and the xterm returns a ‘$’ prompt.
Circle one:  PASS / FAIL

D.10.2.6
Type ‘exit’ to terminate the shell.
The shell terminates, and the xterm returns a system prompt.
Circle one:  PASS / FAIL

D.10.2.7
On the Candidate Platform, at the system prompt in an xterm, enter: 

     mt rew
This rewinds the local tape, and the xterm returns a system prompt.
Circle one:  PASS / FAIL

D.10.2.8
On the Candidate Platform, at the system prompt in an xterm, enter: 

     rsh kpchost mt rew
This rewinds the remote tape (Validation Host) tape, and the xterm returns a system prompt.
Setup

D.10.3
Install segments from remote tape drive  (on the Validation Host) to newly created volume on the candidate platform.



D.10.3.1
Using the pulldown menus at the top of the DII COE screen, select Software > Segment Installer.
The Segment Installer window appears.
Circle one:  PASS / FAIL

D.10.3.2
In the “Installer” window, click on the “Select Source” button.
The “Select Source” window appears.
Circle one:  PASS / FAIL

D.10.3.3
In the “Select Source” window click on “REMOTE” in the host field.  Position the cursor in the name field and type in the name 
“kpchost”.
The “Source” field in the “Installer” window is now populated.
Circle one:  PASS / FAIL


NOTE:  As described in the test setup requirements, a removable online storage volume that can be re-formatted with a complete loss of data must be available on the Candidate Platform to support Disk Manager testing. 

The storage volume provided for test purposes is designated as /dev/<<volume>> where <<volume>> is a string suitable for use in a ‘mount’ command.

Where test steps below indicate <<volume>>, the vendor-specified string should be substituted.



D.10.3.4
In the “Select Source” window, locate the the “Device” field,  then click on “other” and position the cursor in the box next to “other” and type in the device name (i.e. “/dev/<<volume>>”).
The “Device” field in the “Installer” window is now populated with the new device name.
Circle one:  PASS / FAIL

D.10.3.5
In the “Select Source” window, click on the “OK” button.
The “Installer” window reappears and shows

HOST:  
kpchost

DEVICE:  /dev/<<volume>>
Circle one:  PASS / FAIL

D.10.3.6
NOTE:  Be sure to insert the removable media into the remote storage device on the Validation Host before attempting this step.

In the “Installer” window, select the “Read Contents” button.
A “Select Software to Install” field appears in the “Installer window, displaying the Table of Contents from the Validation Host’s dat device.
Circle one:  PASS / FAIL

D.10.3.7
Select Hardware > Disk Manager.

Click [INIT FD].

Click [CONTINUE].

Click [OK].

Click [NEWFS].

Double-click on the <unknown> entry in the DISK DEVICE: field and type /dev/<<volume>>.


Disk Manager window appears.

A WARNING! window appears stating:  This option could erase the entire contents of the floppy disk.  Are 

you sure you want to continue? (This process will take several minutes)  [CONTINUE] [CANCEL]

The WARNING! window stays visible until initialization is complete and a DONE window appears, stating:  Floppy Initialization Complete [OK].
The DONE window disappears.

A NEW FILE SYSTEM window appears.

Field accepts input.


Circle one:  PASS / FAIL


Click [OK].

Click [CONTINUE].

Enter this information in the Mount File system window:  /dev/<<volume>>

and enter the mount point,

/home3

NOTE (1):  The device naming convention is OS-specific.  Be sure to enter the exact device name the OS requires (i.e., if you are using Solaris 2.x, and are newfs-ing the device, use /vol/dev/rdiskette0/unnamed_floppy).

NOTE (2):  The device naming convention is OS-specific.  Be sure to enter the exact device name the OS requires (i.e., if you are using Solaris 2.x, and are mounting  the device, use /vol/dev/diskette0/unnamed_floppy).

The DONE window disappears and a WARNING! window appears stating:  This will destroy all data on the selected device.  Are you sure you want to proceed? [CONTINUE][CANCEL].

The WARNING! window stays visible until new file system creation is complete, then it disappears.

All fields in the Mount File System window display appropriate information.





Select the /home3 entry in the Available Disks section of the installer window and then highlight the following segments for installation:

SampleCOTS, SampleAcctGrp, SampleAgg, SampleDataSegment, SampleSoftwareSegment, and SampleSW.P1

Select ”Install”.
Installer indicates that some segments are already installed and prompts the user to confirm that the segment should overwrite the installed version.

(Step changed per VOR 271299151300.)




D.10.3.8
Select “YES” when prompted to confirm segment overwrite.
When overwrite is confirmed, the installation proceeds to completion.

At the end of the installation process, the Installer Window re-appears.  

All of the segments loaded in step D.10.3.7 appear in the top half of the window (i.e. “Currently Installed Segments”), and are shown as being installed in /home3.

In the bottom half of the Installer window (i.e. “Select Software to Install”), all of the segments listed at left have an asterisk in the leftmost column.
Circle one:  PASS / FAIL

D.10.3.9
From the Installed>View the Installation Log pulldown menus, verify that the segment(s) from Step D.10.3.7 were installed successfully.
Installation Log shows that all the segments installed in D.10.3.7 installed successfully except SampleDataSegment.
Installation Log content appears as shown in Attachment 2.
Circle one:  PASS / FAIL

D.10.3.10
Type cd /h <cr> at the xterm/dtterm  prompt. 
Type ls –l <cr> at the xterm/dtterm prompt.
Verify that a link between /h directory and /home3/SampleDataSegment directory exists.

Type cd /h/AcctGrps <cr> at the xterm/dtterm prompt.

Type 1s -1 <cr> at the xterm/dtterm prompt.

Verify that a link between /h/AcctGrps directory and /home3/SampleDataSegment directory exists.

Type cd /h/COTS <cr> at the xterm/dtterm prompt.

Type 1s -1 <cr> at the xterm/dtterm prompt.
A system prompt (#) returns.

The system returns a long  listing of the /h directory.

Links exist for the SampleAgg, SampleAggChild, and SampleSW segments.

A system prompt (#) returns.

The system returns a long listing of the /h/AcctGrps directory.

Link exists for the SampleAcctGrp segment.

A system prompt (#) returns.

The system returns a long listing of the /h/COTS directory.


Circle one:  PASS / FAIL


Verify that a link between /h/COTS directory and /home3/SampleDataSegment directory exists.
Link exists for the SampleCOTS segment.

(Step changed per VOR 281299083000.)


D.10.4
On Validation Host, revert “kpccp” to untrusted status.



D.10.4.1
On the Validation Host, from the pulldown menus, select 

    Network >Edit Local Hosts
An “Edit Hosts” window appears.
Setup

D.10.4.2
In the “Edit Hosts” window, highlight “kpccp” and select [Edit].
The “Edit Machine” dialog box appears.
Setup

D.10.4.3
In the “Edit Machine” dialog box, DE-select “Trusted Machine” checkbox, and select [OK].
The “Edit Machine” dialog box disappears, and the “kpccp” line in the “Edit Host” window is marked with an “M” in the first column.
Setup

D.10.4.4
On the Validation Host, In the Edit Hosts window select [OK].
The “Edit Hosts” window disappears.
Setup

D.11
Return Candidate Platform to the baseline configuration, including de-installation of multiple segments using the Segment Installer.



D.11.1
Using Software > Segment Installer, Highlight and deinstall the following segments:
SampleCOTS, SampleAcctGrp, SampleAgg, SampleDataSegment, SampleSoftwareSegment, and SampleSW.P1

Click on the “De-install” button.
User is prompted to confirm deletion of selected segments.


Circle one:  PASS / FAIL

D.11.2
Answer “YES” to the confirmation message to de-install selected segments.
Selected segments are de-installed.
Circle one:  PASS / FAIL

D.11.3
After De-installation is complete, verify via an xterm/dtterm command line that corresponding links to the segments under /h and the actual segment directory (i.e., /home3) have been removed.

Type:


cd /h   [ENTER],

then type:


ls –l   [ENTER]

Close the xterm/dtterm window after verifying de-installation.
Segment and link have successfully been removed.

(Step changed per V-0016.)
Circle one:  PASS / FAIL

D.11.4
From the pulldown menus at the top of the DII COE screen, select Hardware > Disk Manager to open the Disk Manager window.
The Disk Manager window appears on the screen.
Circle one:  PASS / FAIL

D.11.5
Highlight the newly mounted storage volume mounted on /home3 and click on the [UNMOUNT] button. 
A “Permanently Unmount?” dialog box will appear asking: “Do you wish to Permanently Unmount the File System?”
Circle one:  PASS / FAIL

D.11.6
In the “Permanently Unmount?” dialog box, choose [YES] to continue.
The new storage volume disappears from the Disk Manager window.
Circle one:  PASS / FAIL

D.11.7
Reboot the machine.  From the Pull Down Menu, click on Hardware > Reboot System.
The “REBOOT” confirmation window appears asking “Do you want to shutdown and reboot the computer?”
Circle one:  PASS / FAIL

D.11.8
Click on the [YES] button to REBOOT the computer.
The computer reboots and returns to the DII COE Login Screen.
Circle one:  PASS / FAIL

D.11.9
At the DII COE Login screen, login as sysadmin using the appropriate password.
Sysadmin login is allowed.
Circle one:  PASS / FAIL

D.11.10
Verify that the newly mounted disk partition is no longer mounted after reboot by clicking on HARDWARE > DISK MANAGER
The new disk partition (/home3) is NOT listed as mounted in the Disk Manager window.
Circle one:  PASS / FAIL


Re-Mount  the  new disk partition to /home3

Setup

D.11.11
Using the Disk Manager, click on the [NEWFS] button
NEWFS window appears.
Circle one:  PASS / FAIL

D.11.12
Select Hardware > DISK Manager. 
Click [INIT FD].

Click [CONTINUE].

Click [OK].

Click [NEWFS].

Double-click on the <unknown> entry in the DISK DEVICE: field and type /dev/<<volume>>.

Click [OK].


Disk Manager window appears.

A WARNING! window appears stating:  This option could erase the entire contents of the floppy disk.  Are 

you sure you want to continue? (This process will take several minutes)  [CONTINUE] [CANCEL]

The WARNING! window stays visible until  initialization is complete and a DONE window appears, stating:  Floppy Initialization Complete  [OK].

The DONE window disappears.

A NEW FILE SYSTEM window appears.

Field accepts input.

The DONE window disappears and a WARNING! window appears stating: This will destroy all data on the selected device. Are you sure you want to proceed?  [CONTINUE] [Cancel]


Circle one:  PASS / FAIL



The following notice is displayed: “Warning: This will destroy
all data on the selected device.  Are you sure you
want to proceed?”





Click [CONTINUE].


The WARNING! window stays visible until new file system creation is complete, then it disappears.



NOTE:  The device naming convention is OS-specific.  Be sure to enter the exact device name the OS requires

(i.e.,  if you are using Solaris 2.x, and are newfs-ing the device, use /vol/dev/rdiskette0/unnamed_floppy).
(Step changed per VOR 281299101600.)




D.11.13
Click the [CONTINUE] button.
Disk Manager Window returns.
Circle one:  PASS / FAIL

D.11.14
Click on the [MOUNT NEW] button. 
The Mount File System window will appear.
Circle one:  PASS / FAIL

D.11.15
When the Mount File System window appears, enter the new storage volume to be mounted:


/dev/<<volume>>

and enter the mount point,


/home3

NOTE:  The device naming convention is OS-specific.  Be sure to enter the exact device name the OS requires (i.e. if you are using Solaris 2.x, and are mounting the

device, use /vol/dev/diskette0/unnamed_floppy).
All fields in the Mount File System window display appropriate information.

(Step changed per VOR 281299103600.)


Circle one:  PASS / FAIL

D.11.16
Click the [MOUNT] button to continue.

When the system asks “Do you wish to Permanently Mount the File System,” choose [YES] to continue.
The Mount File System window will appear.  The new disk partition will appear in the Disk Manager window as mounted.
Circle one:  PASS / FAIL

D.12
Export a local file system from the Candidate Platform.



D.12.1
In the Disk Manager window select /home3, then click on [EXPORTFS]
The Export/Unexport File Systems Window appears.
Circle one:  PASS / FAIL

D.12.2
In the “Export/Unexport File Systems” window, change option to:

rw,anon=0
Select [EXPORT]
A dialog box appears asking “Do you wish to permanently export?”.
Circle one:  PASS / FAIL

D.12.3
Select [YES] to the “Permanent export” dialog.
The dialog box disappears.
Circle one:  PASS / FAIL

D.12.4
In the Disk Manager Window, select [EXPORTFS].
The “Export/Unexport File Systems” window appears.  
Circle one:  PASS / FAIL

D.12.5
In the “Export/Unexport File Systems” window, 

Click on [CURRENT].

Verify that the changes made in Steps D.12.2 are retained.

NOTE:  The dialog box may need to be expanded.
The list of exported files systems shows “/home3”.

Note: Suppliers platforms may display additional information.  For instance, Solaris also display “rw,anon=0”.  Display of additional information is acceptable.
Circle one:  PASS / FAIL

D.12.6
In the “Export/Unexport File Systems” window, select [CANCEL].  
The “Export/Unexport File Systems” window closes.
Circle one:  PASS / FAIL

D.12.7
Then click on the [EXIT] button to close the Disk Manager.
The Disk Manager window disappears.
Circle one:  PASS / FAIL

D.12.8
On the Validation Host, NFS mount the file system (i.e. /home3) exported from the candidate platform.



D.12.8.1
From the pull down menu, select: Hardware > DiskManager.
The “Disk Manager” window appears.
Circle one:  PASS / FAIL

D.12.8.2
Click on the [Mount New] button.
The “Mount File system” window appears.
Circle one:  PASS / FAIL

D.12.8.3
In the “Mount File System” window, enter:

File System: [kpccp:/home3]
Mount Point: /home3

Click on the [Mount] button.
The “Permanent Mount?” window appears.


D.12.8.4
In the “Permanently Mount” dialog box, select “Yes”.
NOTE:  This dialog box does not always appear on the SOLARIS platform.
The “Permanently Mount” dialog box disappears.

kpchost:home3 appears as a mounted filesystem in the “Disk Manager” window.
Circle one:  PASS / FAIL

D.12.8.5
Select [EXIT] to exit the Disk Mgr. window.
“Disk Manager” window closes.
Circle one:  PASS / FAIL

D.12.9
On the Validation Host, in an xterm, execute the following commands at the system prompt:

   cd /home3

   ls –al > listing_file
Xterm returns a system prompt after each command.
Circle one:  PASS / FAIL

D.12.10
in an xterm, execute the following command at the system prompt:

  cat listing_file
Text appears as the result of an ‘ls’ command, and returns a system prompt.
Circle one:  PASS / FAIL

D.12.11
in an xterm, execute the following commands at the system prompt:

  rm listing_file

   cd /
Xterm returns a system prompt after each command.
Circle one:  PASS / FAIL


On the Validation Host, permanently unmount /home3.



D.12.12
On the Validation Host, from the pull down menu, select Hardware > Disk Manager.
The Disk Manager window appears.
Circle one:  PASS / FAIL

D.12.13
In the Disk Manager window select /home3, and select [UNMOUNT].
The “Permanently Unmount” window will appear.
Circle one:  PASS / FAIL

D.12.14
At Permanently Unmount window, click [YES].
The “Permanently Unmount” window disappears.

Disk Manager window no longer shows /home3 as mounted.
Circle one:  PASS / FAIL

D.12.15
In the Disk Manager window select [EXIT].
The Disk Manager window disappears.
Circle one:  PASS / FAIL

D.13
Confirm permanent export of file system through Disk Manager.



D.13.1
On the Candidate Platform, from the Hardware > Reboot System pulldown menu,  reboot the system.
The “Reboot” window appears.  Answer [YES] to continue rebooting.
Circle one:  PASS / FAIL

D.13.2
Upon reboot, log in as Sysadmin and verify that the exported file system remains exported by selecting Hardware > Disk Manager.
The “Disk Manager” window appears.
Circle one:  PASS / FAIL

D.13.3
Click the [EXPORTFS] button.  When the “Export/Unexport File Systems” window appears, click the [CURRENT] button.
The exported file system will still be listed in the “Current” dialog box.
Circle one:  PASS / FAIL

D.13.4
In the “Current” dialog box, select [CANCEL].
The “Current” dialog box closes.
Circle one:  PASS / FAIL

D.13.5
On the Candidate Platform, permanently unexport /home3.



D.13.5.1
Select EXPORTFS.

Double-click on the options (-o): field.

Type rw,anon=o.

Double-click on the pathname: field.

Type /home3.
The Export/Unexport File System window appears.  NOTE:  Tester may have to expand the window to see all fields.

The ro entry is highlighted.

Field accepts input.

The / entry is highlighted.

Field accepts input.

(Step changed per VOR 281299113600.)
Circle one:  PASS / FAIL

D.13.5.2
Click the [UNEXPORT] button.
A dialog box appears, asking "Do you want to permanently unexport /home3?".
Circle one:  PASS / FAIL


In the dialog box, click [YES].
The dialog box disappears.  In the “Export/Unexport File System” window, /home3 no longer shows as being exported.
Circle one:  PASS / FAIL

D.13.5.3
Click on the [EXIT] button.
The Disk Manager window closes.
Circle one:  PASS / FAIL

D.14
Load multiple segments into the Validation Host Repository using the Segment Installation Server.



D.14.1
Mount /home2 to support the Validation Host Segment Installation Server.
(Step removed per VOR 281299123700.)


D.14.1.1
On the Validation Host, from the pull down menu, select: Hardware > Disk Manager.
The “Disk Manager” window appears.

(Step removed per VOR 281299123700.)
Setup

D.14.1.2
Select an available file system (i.e. the "mounted on"  field is blank), and click on the [Mount] button.

Note:  If no readily available file systems are showing in the ‘Disk Manager’ window, complete steps a – e
a.  Select [NEWFS] in the ‘Disk Manager’ window

b. Click down arrow beside ‘Disk Device’ for list of available disks and select an unused device then click [OK]

c. Click [CONTINUE]

d.  Click [Mount New] in the ‘Disk Manager Window

e.  Enter the file system that you created in “step b” above
The “Mount File system” window appears.

The ‘New File System Window’ appears.

A ‘Warning Window” appears.

The ‘Warning Window’ disappears

The ‘Mount File System” window appears

(Step removed per VOR 281299123700.)


Setup

D.14.1.3
In the “Mount File System” window, enter:

Mount Point: /home2

Click on the [Mount] button.
The “Permanent Mount?” window appears.

(Step removed per VOR 281299123700.)
Setup

D.14.1.4
In the “Permanently Mount” dialog box, select “Yes”.

The “Permanently Mount” dialog box disappears.

/home2 appears as a mounted filesystem in the “Disk Manager” window.

(Step removed per VOR 281299123700.)
Setup

D.14.1.5
Select [EXIT] to exit the local host window.
“Disk Manager” window closes.

(Step removed per VOR 281299123700.)
Setup

D.14.2
On the Validation Host, from the pulldown menus at the top of the DII COE screen, select Software > Segment Installation Server.
The “Segment Installation Server” window appears.
Circle one:  PASS / FAIL

D.14.3
In the “Segment Installation Server” window, click on the “Select Source” button.
The “Select Source” window appears.
Circle one:  PASS / FAIL

D.14.4
In the “Select Source” window click on “Remote” in the host field.
A name field appears in the “Select Source” window.
Circle one:  PASS / FAIL


Note: The removable archival storage media provided for test purposes is designated as /dev/<<media>> where <<media>> is a string suitable for use in a ‘mount’ command.

Where test steps below indicate <<media>>, the vendor-specified string should be substituted.



D.14.5
Enter: “kpccp”, and select “Other” in the device field.  Specify /dev/<<media>> and click on the “OK” button.
The “Segment Installation Server” window re-appears with the “Source” field populated.
Circle one:  PASS / FAIL

D.14.6
NOTE:  Be sure to insert the “Sample Segment Tape – Vendor” into the Candidate Platform’s local tape device.

In the “Segment Installation Server” window, select the “Read Contents” button.
A “Select Software to Load” field appears in the “Segment Installation Server” window, displaying the Table of Contents from the Segment Installation Server.
Circle one:  PASS / FAIL

D.14.6

Alt
NOTE:  Be sure to insert the “Sample Segment Tape – Generic” into the Candidate Platform’s local tape device.

In the “Segment Installation Server” window, select the “Read Contents” button.
A “Select Software to Load” field appears in the “Segment Installation Server” window, displaying the Table of Contents from the Segment Installation Server.
Circle one:  PASS / FAIL

D.14.7
Select “/home2” as the destination for the load.  

Highlight the following segments (one of each type) to be installed:

SampleCOTS, SampleAcctGrp, SampleAgg, SampleDataSegment, SampleSoftware Segment, and SampleSW.P1.

Click [LOAD] to continue.
The “Segment Installation Server” window returns and all selected segments are shown as installed.

An “*” appears next to each segment that is installed.
Circle one:  PASS / FAIL

D.14.8
In the “Segment Installation Server” window, from the Pull Down Menu, select Installed > View Installation Log.
The Installation Log verifies successful installation of all of the segments selected in the previous step.

In Addition: Installation Log shows one additional: Sample Aggregate child segment.

Installation Log appears as shown in Attachment 3.
Circle one:  PASS / FAIL

D.14.9
Click OK on the “View Installation Log” window, the click on [EXIT] to close the “Segment Installation Server” window.
3. The “View Installation Log” and “Segment Installation Server” windows close.
Circle one:  PASS / FAIL

D.15
[Moved to A] 



D.16
Install the test segments from the Installation Server on Validation Host to the default installation location on the Candidate Platform.



D.16.1
On the Candidate Platform machine, select the Software > Segment Installer pulldown menu.
The Installer window appears.
Circle one:  PASS / FAIL

D.16.2
Click on the [SELECT SOURCE] button.  
The Select Source window appears.
Circle one:  PASS / FAIL

D.16.3
When the Select Source window appears, click on the “Network” toggle and click [OK].
The Installer window re-appears.


D.16.4
Click [READ CONTENTS] button.
Server segments appear as available for Installation.
Circle one:  PASS / FAIL

D.16.5
Highlight the following segments (one of each type) to be installed. 

SampleCOTS, SampleAcctGrp, SampleAgg, SampleDataSegment, SampleSoftware Segment, and SampleSW.P1.

Click [INSTALL] to continue.
The “Segment Installer” window returns and all selected segments are shown as installed.

An “*” appears next to each segment that is installed.
Circle one:  PASS / FAIL

D.16.6
In the “Segment Installer” window, from the Pull Down Menu, select Installed>View Installation Log.
The Installation Log lists the segments as installed.

NOTE:  Installation Log shows one additional: Aggregate child segment.

Installation Log appears as shown in Attachment 4.
Circle one:  PASS / FAIL

D.16.7
In the Segment Installer window, click [EXIT].
The Installer window disappears.
Circle one:  PASS / FAIL

D.16.8
Clear Validation Host Repository.



D.16.8.1
On the Validation Host, Select Software > Segment Installation Server.  
The Segment Installation Server window appears.
Setup

D.16.8.2
In the Segment Installation Server window, highlight all segments listed in “Segments currently loaded on this Network Server” and click [DEINSTALL SOFTWARE].
A confirmation dialog box appears.
Setup

D.16.8.3
Click [YES] to confirm deletion of selected segments.
The “Segments currently loaded on this Network Server” field is empty.
Setup

D.16.8.4
Click [EXIT].
The Segment Installation Server window closes.
Setup

D.16.8.5
Verify the deinstallation of network segments.  On the Candidate Platform, from the pulldown menu, select Software > Segment Installer.
 “Segment Installer” window appears.
Circle one:  PASS / FAIL

D.16.8.6
Click on the [SELECT SOURCE] button and click the NETWORK toggle on the dialog that appears.
Network as the source device.


D.16.8.7
Click [OK]
Select Source window closes.


D.16.8.8
Select the [READ CONTENTS] option.
The Table of Contents that appears in the ‘Select Software to Install’ section no longer list any segments as available.
Circle one:  PASS / FAIL

D.16.8.9
On the Segment Installer window, select the [EXIT].
The ‘Segment Installer’ window disappears.
Circle one:  PASS / FAIL

D.17
Verify that the Candidate Platform Segment Installation Server can be used to install segments on the Validation Host.



D.17.1
Prepare Candidate Platform.



D.17.1.1
On the Candidate Platform, From the pull down menu, select: Hardware > DiskManager.
The “Disk Manager” window appears.
Circle one:  PASS / FAIL

D.17.1.2
Highlight the /h/data/global filesystem.  Click on [UNMOUNT].
A “Permanent Unmount?” dialog box appears.
Circle one:  PASS / FAIL

D.17.1.3
Answer [YES] to the question:

 “Do you want to permanently unmount this filesystem?”
The Disk Manager will re-appear and /h/data/global will no longer be mounted.
Circle one:  PASS / FAIL

D.17.1.4
Highlight the /home3 filesystem.  Click on [UNMOUNT].

Select Hardware > Disk Manager > 

kpccp:/home3 from the Validation Host.

Select UNMOUNT.

Select [Yes].

Select Hardware > Disk Manager > kpccp:/home3 from the Candidate Platform.

Select UNMOUNT.

Select [Yes].


A “Permanent Unmount?” dialog box appears.

Disk Manager window appears and kpccp:/home3 selection is highlighted.

A “Permanent Unmount? [Yes][No]” dialog box appears.

Dialog box disappears.

Disk Manager window appears and kpccp:/home3 selection is highlighted.

A “Permanent Unmount?  [Yes] [No]” dialog box appears.

Dialog box disappears.

(Step changed per VOR V-0017.)


Circle one:  PASS / FAIL

D.17.1.5
Answer [YES] to the question:

 “Do you want to permanently unmount this filesystem?”
The Disk Manager will re-appear and /home3 will no longer be mounted.
Circle one:  PASS / FAIL

D.17.1.6
Click on the [Mount New] button.
The “Mount File system” window appears.
Circle one:  PASS / FAIL

D.17.1.7
In the “Mount File System” window, enter:

File System: [/dev/<<volume>>]
Mount Point: /home2

Click on the [Mount] button.

Note: <<volume>> should be the same identifier used in step D.5.
The “Permanent Mount?” window appears.
Circle one:  PASS / FAIL

D.17.1.8
In the “Permanently Mount” dialog box, select “Yes”.

The “Permanently Mount” dialog box disappears.

/home2 appears as a mounted filesystem in the “Disk Manager” window.
Circle one:  PASS / FAIL

D.17.1.9
Click on the [EXPORTFS] button.
The “Export/Unexport FileSystem” window appears.
Circle one:  PASS / FAIL

D.17.1.10
In the “Export/Unexport File System” window,

Change  options: rw,anon=0.  

Enter  pathname: /home2

Click on the [EXPORT] button.
A dialog box appears asking “Do you want to permanently export the file system /home2?”.
Circle one:  PASS / FAIL

D.17.1.11
Answer [YES] to the question, “Do you want to permanently export the file system /home2”.
The dialog box disappears.
Circle one:  PASS / FAIL

D.17.1.12
Click on the [EXPORTFS] button.
The “Export/Unexport FileSystem” window appears.
Circle one:  PASS / FAIL

D.17.1.13
In the “Export/Unexport File System” window,

Change  options: rw,anon=0.  

Enter  pathname: /h/data/global

Click on the [EXPORT] button.
A dialog box appears asking “Do you want to permanently export the file system /h/data/global?”.
Circle one:  PASS / FAIL

D.17.1.14
Answer [YES] to the question, “Do you want to permanently export the file system /h/data/global”
The dialog box disappears.
Circle one:  PASS / FAIL

D.17.1.15
Select [EXIT] to exit the Disk Manager window.
“Disk Manager” window closes.
Circle one:  PASS / FAIL

D.17.2
Prepare Validation Host.



D.17.2.1
On the Validation Host, From the pull down menu, select: Hardware > DiskManager.
The “Disk Manager” window appears.
Setup

D.17.2.2
In the Disk Manager window select /home2 and select [EXPORTFS].
The “Export/Unexport File System” window appears.
Setup

D.17.2.3
Click the [UNEXPORT] button.
“Do you want to permanently Unexport?” dialog box appears
Setup

D.17.2.4
Select [YES} to permanently unexport
Permanently Unexport box disappears
Setup

D.17.2.5
Highlight the /home2 filesystem.  Click on [UNMOUNT].
A “Permanent Unmount?” dialog box appears.
Setup

D.17.2.6
Answer [YES] to the dialog box.
The Disk Manager will re-appear and /home2 will no longer be mounted.
Setup

D.17.2.7
Select EXPORTFS.

Double-click on the options (-o): field.

Type rw,anon=o.

Double-click on the pathname: field.

Type /h/data/global.
The Export/Unexport File System window appears. NOTE:  Tester may have to expand the window to see all fields.

The ro entry is highlighted.

Field accepts input.

The / entry is highlighted.

Field accepts input.

(Step changed per VOR 281299140000.)
Setup

D.17.2.8
Click the [UNEXPORT] button.
A “Do you want to permanently Unexport?” dialog box appears.
Setup

D.17.2.9
Select [Yes] to permanently unexport.
In the “Export/Unexport File System” window, /h/data/global no longer shows as being exported.
Setup

D.17.2.10
Click on the [Mount New] button.
The “Mount File system” window appears.
Setup

D.17.2.11
In the “Mount File System” window, enter:

File System: kpccp:/h/data/global

Mount Point: /h/data/global
Click on the [Mount] button.
The “Permanent Mount?” window appears.
Setup

D.17.2.12
In the “Permanently Mount” dialog box, select “Yes”.

The “Permanently Mount” dialog box disappears.

/h/data/global appears as a mounted filesystem in the “Disk Manager” window.
Setup

D.17.2.13
Select [EXIT] to exit the Disk Manager window.
“Disk Manager” window closes.
Setup

D.17.3
Clear all segments from the Segment Installation Server repository on the Candidate Platform.



D.17.3.1
On the Candidate Platform, from the pull down menu, select Software > Segment Installation Server.
“Segment Installation Server” window appears.
Circle one:  PASS / FAIL

D.17.3.2
In the “Segment Installation Server” window window, select (highlight) all segments (if any) in the “Segments Currently Loaded on this Network Server” field and select [DEINSTALL SOFTWARE].
A confirmation dialog appears.
Circle one:  PASS / FAIL

D.17.3.3
Select [YES] in the confirmation box.
Deletes all existing segments from the Segment Installation Server (i.e. the repository) on the Candidate Platform.  

“Currently Loaded Segments” field in “Segment Installation Server” window is empty.
Circle one:  PASS / FAIL

D.17.4
Load all sample segments into the Segment Installation Server repository on the Candidate Platform.



D.17.4.1
Insert “Sample Segment Tape - Solaris” tape in Validation Host tape drive.
Tape drive is loaded.
Circle one:  PASS / FAIL

D.17.4.2
On the Candidate Platform, from the pulldown menu, select Software > Segment Installation Server.  
“Segment Installation Server” window.
Circle one:  PASS / FAIL

D.17.4.3
In the “Segment Installation Server” window, click on the “Select Source” button.
The “Select Source” window appears.
Circle one:  PASS / FAIL

D.17.4.4
In the “Select Source” window click on “Remote” in the host field.
A name field appears in the “Select Source” window.
Circle one:  PASS / FAIL

D.17.4.5
Enter: “kpchost”, and select “Other” in the device field.  Specify /dev/rmt/0mn and click on the “OK” button.
The “Segment Installation Server” window re-appears with the “Source” field populated.
Circle one:  PASS / FAIL

D.17.4.6
NOTE:  Verify the Candidate Platform is a ‘trusted’ host in the Validation Host’s Local Hosts table prior to this step.  The Candidate Platform MUST be a ‘trusted’ host in the Validation Host’s Local Hosts table for this step to be successful.

NOTE:  Be sure to insert the “Sample Segment Tape – Solaris” into the Validation Host’s local tape device.

In the “Segment Installation Server” window, select the “Read Contents” button.
A “Select Software to Load” field appears in the “Segment Installation Server” window, displaying the Table of Contents from the Segment Installation Server.

(Step changed per VOR 281299143500.)
Circle one:  PASS / FAIL

D.17.4.7
Select “/home2” as the destination for the load.

Highlight the following segments (one of each type) to be installed:

SampleCOTS, SampleAcctGrp, SampleAgg, SampleDataSegment, SampleSoftware Segment, and SampleSW.P1.

Click [LOAD] to continue.
The “Segment Installation Server” window returns and all selected segments are shown as installed.

An “*” appears next to each segment that is installed.
Circle one:  PASS / FAIL

D.17.4.8
In the “Segment Installation Server” window, from the Pull Down Menu, select Installed>View Installation Log.
The Installation Log verifies successful installation of all of the segments selected in the previous step.

In Addition: Installation Log shows one additional: Sample Aggregate child segment.

Installation Log appears as shown in Attachment 5.
Circle one:  PASS / FAIL

D.17.4.9
Click [OK] on the “View Installation Log” window, the click on [EXIT] to close the “Segment Installation Server” window.
4. The “View Installation Log” and “Segment Installation Server” windows close.
Circle one:  PASS / FAIL

D.17.5
Using Segment Installer on the Validation Host, install all Sample Segments from the Candidate Platform Segment Installation Server.



D.17.5.1
On the Validation Host, from the pull down menu, select Software > Segment Installer.
“Segment Installer” window appears.
Circle one:  PASS / FAIL

D.17.5.2
In “Segment Installer” window, review the installed segments.  Select (highlight) any sample segments that are installed.  Select [DEINSTALL SOFTWARE] to remove them, if necessary.
“Currently Installed Segments” list contains no sample segments.
Circle one:  PASS / FAIL

D.17.5.3
In “Segment Installer” window, select [SELECT SOURCE]
“SELECT SOURCE” window appears.
Circle one:  PASS / FAIL

D.17.5.4
Select [NETWORK] as the source, and click [OK].
 “Segment Installer” window appears with network as the source device.
Circle one:  PASS / FAIL

D.17.5.5
In “Segment Installer” window, select [READ CONTENTS].
“Segment Installer” window reappears with a new window “Select Software to Install”.
Circle one:  PASS / FAIL

D.17.5.6
In “Segment Installer” window, “Select Software to Install” field, select all of the sample segments: 

Sample Aggregate Segment

Sample Account Group Segment

Sample COTS Segment

Sample Data-Segment Segment

Sample Software Segment

SampleSW.P1

and select [INSTALL].
 “Segment Installer” window reappears with the six sample segments listed in the “Software Currently Installed” field.


Circle one:  PASS / FAIL

D.17.5.7
In the pull down menu select Installed > Installation Log.
The Installation Log appears as shown in attachment 6.
Circle one:  PASS / FAIL

D.18
Clear Candidate Platform Repository.



D.18.1
On the Candidate Platform, Select Software > Segment Installation Server.  
The Segment Installation Server window appears.
Circle one:  PASS / FAIL

D.18.2
In the Segment Installation Server window, highlight the all segments listed in “Segments currently loaded on this Network Server” and click [DEINSTALL SOFTWARE].
A confirmation dialog box appears.
Circle one:  PASS / FAIL

D.18.3
Click [YES] to confirm deletion of selected segments.
The “Segments currently loaded on this Network Server” field is empty.
Circle one:  PASS / FAIL

D.18.4
Click [EXIT].
The Segment Installation Server window closes.
Circle one:  PASS / FAIL

D.18.5
Verify the deinstallation of network segment(s) by bringing up the Installer window on the Validation Host. 

On the Validation Host, click on the [SELECT SOURCE] button and click the NETWORK toggle on the screen that appears. 
 “Segment Installer” window appears with network as the source device.
Setup

D.18.6
Next, select the [READ CONTENTS] option.
The Table of Contents that appears in the ‘Select Software to Install’ section no longer list any segments as available.
Circle one:  PASS / FAIL

D.19
Restore Software Installation Servers



D.19.1
Re-establish Filesystems on Validation Host.



D.19.1.1
On the Validation Host, from the pulldown menus, select Hardware > Disk Manager.
Disk Manager window appears.
Setup

D.19.1.2
Highlight the /h/data/global filesystem.  Click on [UNMOUNT].
A “Permanent Unmount?” dialog box appears.
Setup

D.19.1.3
Answer [YES] to the question:

 “Do you want to permanently unmount this filesystem?”
The Disk Manager will re-appear and /h/data/global will no longer be mounted.
Setup

D.19.1.4
On the Disk Manager window, click on [EXPORTFS].
The “Export/Unexport File System” window appears.
Setup

D.19.1.5
In the “Export/Unexport File System” window,

Change  options: rw,anon=0.  

Enter  pathname: /h/data/global

Click on the [EXPORT] button.
A dialog box appears asking “Do you want to permanently export the file system /h/data/global?”.
Setup

D.19.1.6
Answer [YES] to the question, “Do you want to permanently export the file system /h/data/global”
The dialog box disappears.
Setup

D.19.1.7
Select [EXIT] to exit the Disk Manager window.
“Disk Manager” window closes.
Setup

D.19.2
Re-establish Filesystems on Candidate Platform.



D.19.2.1
On the Candidate Platform, from the pulldown menus, select Hardware > Disk Manager.
Disk Manager window appears.
Circle one:  PASS / FAIL

D.19.2.2
Select /home2 via the Disk Manager. Click on [EXPORTFS].
The “Export/unexport File System” window appears.
Circle one:  PASS / FAIL

D.19.2.3
Click the [UNEXPORT] button.

Answer [YES] to the question:

“Do you want to permanently unexport the filesystem /home2?”
The Disk Manager no longer shows the directory, /home2, as being exported.
Circle one:  PASS / FAIL

D.19.2.4
In the Disk Manager window select /home2, and select [UNMOUNT].
The “Permanently Unmount” window will appear.
Circle one:  PASS / FAIL

D.19.2.5
At Permanently Unmount window, click [YES].
The “Permanently Unmount” window disappears.

Disk Manager window no longer shows /home2 as mounted.
Circle one:  PASS / FAIL

D.19.2.6
Click on [EXPORTFS].
The “Export/unexport File System” window appears.
Circle one:  PASS / FAIL

D.19.2.7
For Pathname, enter: /h/data/global. Click the [UNEXPORT] button.
A “permanent unexport?” dialog box appears.
Circle one:  PASS / FAIL

D.19.2.8
Answer [YES] to the dialog box.
A “permanent unexport?” dialog box disappears.
Circle one:  PASS / FAIL

D.19.2.9
Click on the [Mount New] button.
The “Mount File system” window appears.
Circle one:  PASS / FAIL

D.19.2.10
In the “Mount File System” window, enter:

File System: kpchost:/h/data/global

Mount Point: /h/data/global
Click on the [Mount] button.
The “Permanent Mount?” window appears.
Circle one:  PASS / FAIL

D.19.2.11
In the “Permanently Mount” dialog box, select [Yes].

The “Permanently Mount” dialog box disappears.

Kpchost:/h/data/global appears as a mounted filesystem in the “Disk Manager” window.
Circle one:  PASS / FAIL

D.19.2.12
In the Disk Manager window select [EXIT].
The Disk Manager window disappears.
Circle one:  PASS / FAIL

D.20
NIS Setup and NIS Domain name verification.

Set up the Validation Host as an NIS master and set up the Candidate Platform as an NIS client.

NOTE:  NIS must be removed before proceeding.
NOTE:  For systems running NIS (e.g., HP and SGI) and not NIS+, you need to run tsconvert -R first in order to successfully configure NIS. However, the system should generate an Error Message that provides steps necessary to perform this action.
NOTE:  For an HP system, verify that an error message window appears and that it provides the user with the proper instructions to configure NIS.



D.20.1
 Initializing the Validation Host (Master):

On the Validation Host, select Network > Servers > Set NIS > Initialize NIS option from the menu bar.
The NIS Initialize window appears.


Setup

D.20.2
Enter “nisdomain.nis” in the NIS domain name field.  

Select the “Master” radio button.

Enter the secman password in the secman password field, and select “Run in YP compatible mode?” radio button.

Click on the [OK] button.
Task Complete window appears.
Setup

D.20.3
Click [OK] in the “Task Complete Window”.
A dialog box appears asking: “Do you want to reboot the machine now?”
Setup

D.20.4
Answer [YES] to the question, “Do you want to reboot the machine now?”
The dialog box disappears, and the Validation Host reboots.
Setup

D.20.5
On the Candidate Platform, select Apps Manager > DII APPS > SA_Default > xterm  option from the menu bar. Login as sysadmin and su to root.
system returns a # prompt
Circle one:  PASS / FAIL

D.20.5a
At the command prompt enter:

domainname nisdomain.nis
System returns a # prompt
Circle one:  PASS/FAIL

D.20.6
At the command prompt enter:   

 domainname > /etc/defaultdomain
System returns a # prompt.
Circle one:  PASS / FAIL

D.20.7
At the command prompt enter:   

   cp /etc/nsswitch.nis /etc/nsswitch.conf
System returns a # prompt.
Circle one:  PASS / FAIL

D.20.8
At the command prompt enter:   

   vi /etc/nsswitch.conf
The "nsswitch.conf" file is displayed and is available for editing.
Circle one:  PASS / FAIL

D.20.9
scroll down to hosts: line and change line to read:

    hosts:   files   nis   dns

hit <Esc> key, then <shift/colon>

type:  wq  to write out the file and quit.
vi editor closes and system returns a # prompt.
Circle one:  PASS / FAIL

D.20.10
Type  ypinit -c at the # prompt.

Type kpchost.kpc.disa.mil <cr> at the prompt.

Type <cr> at the prompt.

Type y <cr> at the prompt.
The system responds with a request for the tester to add names for NIS/YP servers.

The system returns next host to add:.

The system returns:  The current list of yp servers looks like this:

kpchost.kpc.disa.mil

Is this correct?  [y/n: y]
System returns a # prompt.

(Step changed per VOR 291299092000.)
Circle one:  PASS / FAIL

D.20.11
from the PDM menu, select Hardware>Reboot System.
System reboots and displays a login screen.
Circle one:  PASS / FAIL

D.20.12
Login as sysadmin.
CDE desktop appears.
Circle one:  PASS / FAIL

D.20.13
Verify that the /home3 disk on the Candidate Platform remains mounted and unexported.  

At the pull down menu select Hardware > Disk Manager.
The Disk Manager window appears.

/home3 appears as a mounted filesystem.
Circle one:  PASS / FAIL

D.20.14
In the Disk Manager window, select [EXPORTFS]. 
The Export/Unexport File Systems window appears.


Circle one:  PASS / FAIL

D.20.15
When the Export/Unexport File Systems window appears, click the [CURRENT] button and expand the window.
The /home3 directory is no longer exported.


Circle one:  PASS / FAIL

D.20.16
Click [CANCEL] to close window.
Export/Unexport File Systems window closes.
Circle one:  PASS / FAIL

D.20.17
Click [EXIT] to close Disk Manager window.
Disk Manager window closes.
Circle one:  PASS / FAIL

D.20.18
Log into the DII COE as sysadmin and enter the appropriate sysadmin password.

Select DII_APPS > L:SA_Default > Xterm.

Log in as sysadmin and enter the appropriate sysadmin password.

Type domainname <cr>.
DII COE Login screen disappears and SA_Default desktop appears. 

A login window appears.

The system displays the kpccp% prompt.

The system returns “nisdomain.nis”.

(Step changed per VOR 291299132800.)
Setup

D.20.19
On the Candidate Platform, verify that the domain name has been set.  Open an xterm, and login as sysadmin.  In the xterm window command line, enter:


domainname
System returns the domain name “nisdomain.nis”.
Circle one:  PASS / FAIL

D.21
Remove NIS on the Candidate Platform. 
 


D.21.1
Verify that NIS is running. Enter:

 ps –ef | grep nis
If NIS is running, one or more of the following processes appears. 

       /usr/sbin/rpc.nisd –y

   /usr/sbin/nis_cachemgr

   /usr/sbin/rpc.nispasswdd

   /usr/sbin/ypbind
Circle one:  PASS / FAIL

D.21.2
Verify that NIS is running. Enter:


ypcat hosts

If the ypcat command is not available, enter the following alternate command:

niscat -h hosts.org_dir
The ypcat hosts command returns:

127.0.0.1 localhost    #

204.34.175.194 kpchost    #

204.34.175.195 loghost    #

204.34.175.194 kpchost.kpc.disa.mil

#

204.34.175.195 kpccp    #

204.34.175.195 kpccp.kpc.disa.mil 

#
The niscat –h hosts.org_dir command returns:

# cname name addr comment

localhost localhost 127.0.0.1

kpchost kpchost 204.34.175.194

kpchost loghost 204.34.175.194

kpchost kpchost.kpc.disa.mil 

204.34.175.194

kpccp kpccp 204.34.175.195

kpccp kpccp.kpc.disa.mil

204.34.175.195

(Step changed per VOR 291299133500.)
Circle one:  PASS / FAIL

D.21.3
Remove NIS from the Candidate Platform.  On the Candidate Platform, select APPS Manager > DII APPS > SA_Default>xterm.  Log in as sysadmin, su to root.
System returns a # prompt.
Circle one:  PASS / FAIL

D.21.4
Type rm –r/var/yp/binding/nisdomain.nis <cr> at the command line prompt
System returns a # prompt.

(Step changed per VOR 291299135000.)
Circle one:  PASS / FAIL

D.21.5
At the command line prompt, type:
  rm /etc/defaultdomain
System returns a # prompt.
Circle one:  PASS / FAIL

D.21.6
At the command line prompt, type:
  vi /etc/nsswitch.conf
nsswitch.conf file is displayed and available for editing
Circle one:  PASS / FAIL

D.21.7
Scroll down to "hosts:" line and change line to read:

    hosts:        files  dns

hit <ESC> key, then <shift/colon>

type:  wq  to write ou

t the file and quit.
vi editor closes and system returns a # prompt
Circle one:  PASS / FAIL

D.21.8
from the PDM menu, select    

    Hardware>Reboot System
System reboots and the login screen appears.
Circle one:  PASS / FAIL

D.21.9
Login as sysadmin once system completes rebooting.
CDE desktop appears after login.
Circle one:  PASS / FAIL

D.21.10
Verify via an xterm/dtterm command line prompt that the domain name has been removed by executing the command:


domainname
After rebooting systems, domain name is no longer set (system generates blank return to domainname input).
Circle one:  PASS / FAIL

D.22
Remove NIS on the Validation Host.



D.22.1
Type ps –ef | grep –i NIS <cr> at the command line prompt.


If NIS is running, the following text appears.  No other text is allowed to appear.

   /usr/sbin/rpc.nisd –y

   /usr/sbin/nis_cachemgr

   /usr/sbin/rpc.nispasswdd

(Step changed per VOR 291299163900.)
Setup

D.22.2
Select the Network > Servers > Set NIS > Remove NIS option from the menu bar for both the Candidate Platform and Validation Host.
A dialog box appears asking: “Do you wish to disable and remove NIS?”
Setup

D.22.3
Answer [YES] to the dialog box.
A dialog box appears asking: “Do you wish to save global users?”
Setup

D.22.4
Answer [NO] to the dialog box.
A dialog box appears asking: “NIS has been disabled, Would you like to reboot this machine?”
Setup

D.22.5
Answer [YES] to the dialog box.
The Validation Host and the Candidate Platform both reboot.

(Step changed per VOR 301299100000.)
Setup

D.22.6
On the Validation Host, login as sysadmin once system completes rebooting.
CDE desktop appears.
Setup

D.22.7
Verify via an xterm/dtterm command line prompt that the domain name has been removed by executing the command:


domainname
After rebooting system, domain name is no longer set. (system generates blank return to domainname input).
Setup

D.23
RE-INSTALL NIS



D.23.1
 Initializing the Validation Host:

On the Validation Host, select Network > Servers> Set NIS> Initialize NIS option from the menu bar.
The NIS Initialize window appears.
Setup

D.23.2
Enter “nisdomain.nis” as the NIS domain name.  

Select the “Master” button.

Enter the secman password in the secman password field.

Select the “Run in YP compatible mode?” radio button.

Click on the [OK] button.
The Task Complete window appears.
Setup

D.23.3
Click [OK] in the “Task Complete Window”.
The Task Complete window closes.  A dialog box appears asking: “Do you want to reboot the machine now?”
Setup

D.23.4
Answer [YES] to the dialog box.
Validation Host reboots.
Setup

D.23.5
Initializing the Candidate Platform:

On the Candidate Platform, select Apps Manager > DII APPS > SA_Default > xterm  option from the menu bar. Login as sysadmin and su to root.
System returns a # prompt.
Circle one:  PASS / FAIL

D.23.5a
At the command prompt enter:

 domainname nisdomain.nis
System returns a # prompt.
Circle one:  PASS / FAIL

D.23.6
At the command prompt enter:   

 domainname > /etc/defaultdomain
System returns a # prompt.
Circle one:  PASS / FAIL

D.23.7
At the command prompt enter:   

   cp /etc/nsswitch.nis /etc/nsswitch.conf
System returns a # prompt.
Circle one:  PASS / FAIL

D.23.8
At the command prompt enter:   

   vi /etc/nsswitch.conf
The "nsswitch.conf" file is displayed and is available for editing.
Circle one:  PASS / FAIL

D.23.9
scroll down to hosts: line and change line to read:

    hosts:   files  nis  dns

hit <Esc> key, then <shift/colon>

type:  wq  to write out the file and quit.
vi editor closes and system returns a # prompt.
Circle one:  PASS / FAIL

D.23.10
Type ypinit -c <cr> at the # prompt.

Type kpchost.kpc.disa.mil <cr> at the prompt.

Type <cr> at the prompt.

Type y <cr> at the prompt.

NOTE:  If ypinit –c returns “command not 

found”, type /usr/sbin/ypinit –c <cr> 

at the # prompt.
The system responds with a request for the tester to add names for NIS/YP servers.

The system returns next host to add:.

The system returns:  The current list of yp servers looks like this:

kpchost.kpc.disa.mil

Is this correct?  [y/n: y]
System returns a # prompt.

(Step changed per VOR 301299102000.)
Circle one:  PASS / FAIL

D.23.11
from the PDM menu, select Hardware>Reboot System.
System reboots and displays a login screen.
Circle one:  PASS / FAIL

 E
Accounts and Profiles Function
 


E.1
Set up new local accounts.



E.1.1
Login to the Candidate Platform as secman and start Security Manager through Application Manager > DII_Apps > SSO_Default > Security Manager.
A Security Manager window appears.
Circle one:  PASS / FAIL

E.1.2
In Security Manager, select File > New User.
A New User dialog box appears.
Circle one:  PASS / FAIL

E.1.3
In the New User dialog box, create a local account with sysadmin privileges using the following information:

Login Name
= KPC_Sys

Password
= 123456

User Name      = KPC_Sys

Default Profile
= SA Default

Groups

= COE, Other

Profiles
= L:SA_Default

NOTE:  Other fields are optional.
The data is accepted in the appropriate fields.
Circle one:  PASS / FAIL

E.1.4
Click [OK] when completed.
New User Created.  The “New User” dialog box disappears.
Circle one:  PASS / FAIL

E.1.5
In Security Manager, select File > New User.
A New User dialog box appears.
Circle one:  PASS / FAIL

E.1.6
In the Add  New User dialog box, create a local account with secman privileges using the following information:

Login Name
= KPC_Sec

Password
= 123456

KPC_Sec        = KPC_Sec

Default Profile
= SSO Default

Groups

= COE, Other

Profiles
= L:SSO_Default
All fields in the Add New User window have appropriate information.

All proper options are available.
Circle one:  PASS / FAIL

E.1.7
Click [OK] when completed.
New User Created.  The “New User” dialog box disappears.
Circle one:  PASS / FAIL

E.1.8
Click on the [EXIT] button on the CDE Toolbar to log out as secman.  
A logout confirmation box appears.
Circle one:  PASS / FAIL

E.1.9
Click on [Continue Logout] to confirm logout.
A DII COE Login window appears.
Circle one:  PASS / FAIL

E.1.10
Log in as KPC_Sec, use password:

123456
The DII COE Security Manager screen appears.  

NOTE:  New IDs are expired on first login (on some systems).
Circle one:  PASS / FAIL

E.1.11
Click on Apps_Mgr > DII_Apps > L:SSO_Default.  Verify that specific icons appropriate to an account with secman privileges are visible.  These are:

Assign Passwords, Audit Log File Manager, Edit Profiles, Profile Selector Config, Security Manager, Security Manager Remote, Update Security DB, Unlock Users
All appropriate icons are available.

NOTE:  Audit Log File Manager is SOLARIS specific.
Circle one:  PASS / FAIL

E.1.12
Verify that secman icons launch the appropriate applications.  These are:

Assign Passwords, Audit Log File Manager, Edit Profiles, Profile Selector Config, Security Manager, Security Manager Remote, Update Security DB, Unlock Users
All icons launch specified applications.

NOTE:  Security Manager Remote will error out and is waived for compliance requirements.

NOTE:  Audit Log File Manager is SOLARIS specific.
Circle one:  PASS / FAIL

E.1.13
Log off as KPC_Sec by clicking on the [EXIT] button on the CDE toolbar.
The DII COE Login screen appears.  

(Step changed per VOR 301299104300.)
Circle one:  PASS / FAIL

E.1.14
Log in as KPC_Sys, use password: 
123456
The DII COE System Administrator screen appears.
Circle one:  PASS / FAIL

E.1.15
Click on Apps Manager > DII_Apps > L:SA_Default.  Verify that specific icons appropriate to an account with sysadmin privileges are visible.  These are:

Admin Tool, Create Action, Disk Manager,  DT Term, Segment Installer, Text Editor, Xterm
All appropriate icons are available.

NOTE:  Admin Tool is SOLARIS specific.
Circle one:  PASS / FAIL

E.1.16
Verify that sysadmin icons launch the appropriate applications.  These are:

Admin Tool, Create Action, Disk Manager,  DT Term, Segment Installer, Text Editor, Xterm
All icons launch specified applications.

NOTE:  Admin Tool is SOLARIS specific.
Circle one:  PASS / FAIL

E.2
Setup new global accounts

NOTE:  For systems running NIS (e.g., HP and SGI) and not NIS+, you need to run tsconvert -R first in order for global accounts to work properly.

NOTE: /h/USERS/global must be exported on the Validation Host, running as a NIS master. Mount the same from the NIS master to the NIS Candidate Platform, running as a NIS client.

Setup

E.2.1
On the Candidate Platform, click on Apps Manager > DII_Apps > L:SA_Default > Xterm.  Log in as sysadmin.
System returns a "kpccp%" prompt.
Circle one:  PASS / FAIL

E.2.2
Log on to the Validation Host as sysadmin. 

Using the pulldown menus Network > Servers > Set NIS > Add NIS Client,  enter the Candidate Platforms name, IP Address, root password (1st eight characters of the root password) when the popup box appears.

Click [OK] to continue.
Receive message “Client has been added”.

(Step removed per VOR 301299110000.)


Circle one:  PASS / FAIL

E.2.3
Click on the [EXIT] button.
The confirmation window closes.
Circle one:  PASS / FAIL

E.2.4
On the Validation Host, from the pull down menu, select   Hardware > Disk Manager menu.
Disk Manager window appears.

(Step removed per VOR 301299111000.)
Setup

E.2.5
Highlight /h/USERS/global.  Click the [EXPORTFS] button.
The Export/Unexport window appears.

(Step removed per VOR 301299111000.)
Setup

E.2.6
In the “Export/Unexport” window set:

          Options:  rw,anon=0

    Pathname: /h/USERS/global

Click [EXPORT].
The computer will ask:  “Do you want to permanently export the filesystem /h/USERS/global?”

(Step removed per VOR 301299111000.)
Setup

E.2.7
Click [YES].
The “Export/Unexport File System” window will re-appear.

(Step removed per VOR 301299111000.)
Setup

E.2.8
On the “Export/Unexport File System” window, click [EXIT].
The Disk Manager window appears.

(Step removed per VOR 301299111000.)
Setup

E.2.9
Click on the Disk Manager [EXIT] button
The Disk Manager window disappears.

(Step removed per VOR 301299111000.)
Setup

E.2.10
Log off the Candidate Platform.

Log on to the Candidate Platform as sysadmin.
DII COE Login screen appears.

DII COE Login screen disappears and SA_Default desktop appears.

(Step changed per VOR 301299131000.)
Circle one:  PASS / FAIL

E.2.11
Using the pulldown menu’s, click Hardware > Disk Manager.
The Disk Manager window appears.

(Step removed per VOR 301299131700.)
Circle one:  PASS / FAIL

E.2.12
Click [MOUNT NEW] button from the Disk Manager popup box.
The “Mount File System” window appears.
Circle one:  PASS / FAIL

E.2.13
Input the following for the file system:

kpchost:/h/USERS/global

and for the mount point enter: 


/h/USERS/global


Click [MOUNT]
Dialog box appears asking “Do you want to permanently mount this file system?”

(Step removed per VOR 301299131700.)


Circle one:  PASS / FAIL

E.2.14
Click [YES] in the dialog box.

NOTE:  This should allow the exported directory from the NIS Master to be mounted onto the Candidate Platform, running as a NIS client.
Dialog box closes, and file system is permanently mounted.

(Step removed per VOR 301299131700.)
Circle one:  PASS / FAIL

E.2.15
On the Validation Host, click [EXIT] to close the Disk Manager window.
Disk Manager window closes

(Step removed per VOR 301299131700.)
Setup

E.2.16
Select [EXIT] on the CDE screen to exit the sysadmin account.
CDE login window appears.

(Step removed per VOR 301299131700.)
Setup


Through the Security Manager, create global secman and sysadmin accounts.



E.2.17
On the Validation Host (running as NIS Master), log into secman.
CDE desktop appears.
Setup

E.2.18
Create the Global SecMan account.  Click on the Apps Manager > DII_APPS > L:SSO_Default > Security Manager.  User will need to input the secman password (only the 1st eight characters) to access the Security Manager.

Click on File > New User.

Enter the following info:

Login Name: = KPC_Sec1

Password:   = 654321

User Name:  = KPC_Sec1

Default Profile: = SSO Default

Scope:      = Global

Optional Groups: = COE, Other

Profiles:   = G:SSO_Default

NOTE:  Other fields are optional.
The “New User” dialog box appears.
Circle one:  PASS / FAIL

E.2.19
Click on the [OK] button.
The user is created.  The “EM_Security_Manager” window appears.
Circle one:  PASS / FAIL

E.2.20
Create the Global SysAdm account.

Click on File > New User.

Enter the following info:

Login Name:  = KPC_SA

Password:    = 123456

User Name:   = KPC_SA

Default Profile: = SA Default

Scope:       = Global

Optional Groups: = COE, Other

Profiles:    = G:SA_Default

NOTE:  Other fields are optional.
The “New User” dialog box appears.
Circle one:  PASS / FAIL

E.2.21
Click on the [OK] button.
The user is created.  The “EM_Security_Manager” window appears.
Circle one:  PASS / FAIL

E.2.22
Click on View > Users from the Security Manager Pull Down menus. 


The security manager displays a list of users, that must include:


sysadmin

     secman
Circle one:  PASS / FAIL

E.2.23
Click on the “Local Scope” button and change from local to global scope.
Once the scope is changed to global, the following global users will be displayed:


KPC_SA

            KPC_Sec1

            secman
Circle one:  PASS / FAIL

E.2.24
Log out of secman account by clicking on [EXIT] on the CDE toolbar.
The DII COE Login screen appears.
Circle one:  PASS / FAIL

E.2.25
On the Validation Host (NIS Master), log in as sysadmin.

Setup

E.2.26
Open an xterm by clicking on:

Apps Manager> DII_Apps> L:SA_Default>Xterm
System returns a "kpchost%" prompt.
Setup

E.2.27
At the system prompt, login as sysadmin, and enter the following commands to change the permissions of the directories of the newly created global users to all read/write/execute permission for all:

  su root

  cd /h/USERS/global

  chmod 777 KPC_Sec1
After executing the “chmod” command the system prompt returns.
Setup

E.2.28
Enter:

         ls -1 /h/USERS/global
Global user KPC_Sec appears with the following permissions set.


Drwxrwxrwx

(Step changed per VOR 301299132500.)
Setup

E.2.29
Enter:

  chmod 777 KPC_SA
After executing the “chmod” command the system prompt returns.
Setup

E.2.30
Enter:

     ls -1 /h/USERS/global
Global user KPC_SA appears with the following permissions set.


Drwxrwxrwx

(Step changed per VOR 301299133000.)
Setup

E.3
Verify that new secman account icon, application, and option configurations are correct. 



E.3.1
Log in as KPC_Sec1 on the Candidate Platform.
The DII COE desktop appears with CDE Toolbar at bottom of screen and security classification at the top.
Circle one:  PASS / FAIL

E.3.2
Click on the Apps Manager > DII_APPS > L:SSO_Default.  Verify that specific icons appropriate to an account with secman privileges are visible.  These are:

Assign Passwords, Audit Log File Manager, Edit Profiles, Profile Selector Config, Security Manager, Security Manager Remote, Update Security DB, Unlock Users
All appropriate icons are available.
Circle one:  PASS / FAIL

E.3.3
Verify that secman icons launch the appropriate applications.  These are:

Assign Passwords, Audit Log File Manager, Edit Profiles, Profile Selector Config, Security Manager, Security Manager Remote, Update Security DB, Unlock Users
All icons launch specified applications.
Circle one:  PASS / FAIL

E.3.4
Verify that the secman related options set in E.1.2 are available and perform as expected.  These are:

Security Manager, Edit Profiles, Profile Selector Config, Audit Log File Manager, Assign Passwords, Unlock Users, Security Manager Remote, Update Security DB
All options set in E.1.2 perform as expected.
Circle one:  PASS / FAIL

E.3.5
Logout by clicking on the [EXIT] button
The DII COE login screen appears.
Circle one:  PASS / FAIL

E.4
Verify that new sysadmin account icon, applications, and option configurations are correct.



E.4.1
Log in as KPC_SA on the Candidate Platform.

Circle one:  PASS / FAIL

E.4.2
Click on Apps Manager > DII_APPS > G:SA_Default.  Verify that specific icons appropriate to an account with sysadmin privileges are visible.  These are:

Adm Tool, Create Action, Disk Manager,  DTterm, Segment Installer, Text Edit, Xterm

NOTE:  Adm Tool may be SOLARIS specific. 
All appropriate icons are available.
Circle one:  PASS / FAIL

E.4.3
Click on icons and verify that sysadmin icons launch the appropriate applications.  These are:

Adm Tool, Create Action, Disk Manager,  DTterm, Segment Installer, Text Edit, Xterm
All icons launch specified applications.
Circle one:  PASS / FAIL

E.4.4
Verify that the sysadmin related options set in E.1.2 are available and perform as expected.  These are:

Adm Tool, Create Action, Disk Manager,  DTterm, Segment Installer, Text Edit, Xterm
All options set in E.1.2 perform as expected.
Circle one:  PASS / FAIL

E.4.5
Logout by clicking on the [EXIT] button on the CDE toolbar.
The DII COE login screen appears.
Circle one:  PASS / FAIL

E.5
Test Global User Password Change on the Network.



E.5.1
Log in to the Candidate Platform using the sysadmin account and appropriate sysadmin password.
The menu bar, security classification, and CDE desktop appears.
Circle one:  PASS / FAIL

E.5.2
Select Apps_Mgr from CDE toolbar.
The Application Manager window appears.


E.5.3
Open an xterm by selecting:

Apps_Mgr > DII_APPS > L:SA_Default > xterm 
An xterm window appears.
Circle one:  PASS / FAIL

E.5.4
Log in to KPC_Sec1 by typing:


KPC_Sec1  
A password prompt is returned.
Circle one:  PASS / FAIL

E.5.5
Enter the KPC_Sec1 password.
System prompt is returned.
Circle one:  PASS / FAIL

E.5.6
Enter su – root <cr> at the prompt.

Enter appropriate root password

Enter yppasswd <cr> at the prompt.
Password: prompt appears.

System prompt (#) appears.

The system returns prompt for old password.

(Step changed per VOR 301299133500.)
Circle one:  PASS / FAIL

E.5.7
When prompted for old password, type:


654321

NOTE: 654321 is the global NIS password for the KPC_Sec1 userid.
Returns prompt for new password.
Circle one:  PASS / FAIL

E.5.8
When prompted for new password, type:


abcdef1!
Returns prompt to retype new password.
Circle one:  PASS / FAIL

E.5.9
When reprompted for new password, type:


abcdef1!
System indicates password has been successfully changed.

System prompt appears.
Circle one:  PASS / FAIL

E.5.10
Reopen an xterm by selecting:

Apps_Mgr > DII_Apps > L:SA_Default > Xterm
An xterm window appears with a login prompt.
Circle one:  PASS / FAIL

E.5.11
Log in to KPC_Sec1 by typing:


KPC_Sec1
Password prompt appears.
Circle one:  PASS / FAIL

E.5.12
When prompted for a password, type:


abcdef1!
A system prompt appears.
Circle one:  PASS / FAIL

E.5.13
Telnet to the Validation Host by typing:


telnet kpchost 
A login prompt appears.
Circle one:  PASS / FAIL

E.5.14
Log in as KPC_Sec1
A password prompt appears.
 Circle one:  PASS / FAIL

E.5.15
When prompted for a password, type:


abcdef1!
A system prompt appears.
Circle one:  PASS / FAIL

E.5.16
Exit out of telnet by typing:


exit
Command Line indicates the session has been closed and returns system prompt.
Circle one:  PASS / FAIL

E.5.17
Log off the Candidate Platform using the exit button on the CDE toolbar.
The DII COE login screen appears.
Circle one:  PASS / FAIL

E.6
Delete new KPC_Sec1 and KPC_ SA accounts.



E.6.1
Log on to the Validation Host as secman.

Click on:

Apps Manager > DII_APPS > L:SSO_Default > Security Manager.

NOTE:  User will need to enter the secman password (the 1st eight characters only) to access the security manager application.
A dialog box prompts the user for the secman password.
Cleanup


User enters and verifies secman password.
Security Manager window appears.







E.6.2
On the Security Manager window appears, click on View > Users.
The User Catalog window opens displaying a list of the local users.
Cleanup

E.6.3
Click on  “Scope” button and select “Global Scope”. 
The User Catalog window opens displaying a list of the global users.
Cleanup

E.6.4
For each global user except secman, highlight the user and click on Edit > Delete User from the security manager pulldown menu’s.
A confirmation dialog box appears.
Cleanup

E.6.5
Answer  [YES] when asked “Are you sure you want to delete Global User <<User Name>>?”
The account is deleted and disappears from the user catalog.
Cleanup

E.6.6
Logoff as secman by clicking on the [EXIT] button on the CDE toolbar.
The DII COE login screen appears.
Cleanup

Z
Logout



Z.1
Log onto the Candidate Platform as sysadmin
The menu bar, security classification and CDE desktop appear.
Circle one:  PASS / FAIL

Z.2
From the the CDE Toolbar, select:

Hardware > Disk Manager
The Disk Manager window appears.
Circle one:  PASS / FAIL

Z.3
Highlight the following: 


/home1/KPC

The string /home1/KPC appears highlighted.
Circle one:  PASS / FAIL

Z.4
Click [UNMOUNT].
A confirmation window appears asking “Do you want to permanently unmount this filesystem?”
Circle one:  PASS / FAIL

Z.5
Click [YES].


The Disk Manager will reappear and the selected filesystem will no longer be mounted.
Circle one:  PASS / FAIL

Z.6
Highlight the following:


/home3
The string /home3 appears highlighted.

(Step removed per VOR 301299134000.)
Circle one:  PASS / FAIL

Z.7
Click [UNMOUNT].
A confirmation window appears asking “Do you want to permanently unmount this filesystem?”

(Step removed per VOR 301299134000.)
Circle one:  PASS / FAIL

Z.8
Click [YES].


The Disk Manager will reappear and the selected filesystem will no longer be mounted.

(Step removed per VOR 301299134000.)
Circle one:  PASS / FAIL

Z.9
Select [EXIT] button from CDE.
Logout confirmation window appears.
Circle one:  PASS / FAIL

Z.10
Select [CONTINUE LOGOUT].
System exits and the DII COE login screen appears.
Circle one:  PASS / FAIL

End of Kernel Overview Validation Procedure Update

Attachment 1 – Installation Log as it appears at the conclusion of D.9.6

Installation Log

Unable to find the affected $SEGMENT name 'Sample Account Group Segment' 

specified in SegName file on disk.

  Warning - will install the affected segment.

Successfully converted segment SampleAcctGrp to new format.

  Segment 'SampleAcctGrp' is validated, preparing to install.

Segment (Sample Account Group Segment) successfully installed.

  Successfully converted segment SampleAgg to new format.

  Segment 'SampleAgg' is validated, preparing to install.

Segment (Sample Aggregate Segment) successfully installed.

  Successfully converted segment SampleAggChild to new format.

  Segment 'SampleAggChild' is validated, preparing to install.

Segment (Sample Aggregate Child Segment) successfully installed.

  Successfully converted segment SampleCOTS to new format.

  Segment 'SampleCOTS' is validated, preparing to install.

  No Default FileAttribs Operations Performed On COTS Segment

Segment (Sample COTS Segment) successfully installed.

Unable to find the affected $SEGMENT name 'Sample Software Segment' specified in SegName file on disk.

Warning - will install the affected segment.

(E)----------------------------------------------------------|

[Requires] descriptor error. A pathname '/h/SampleSW' is invalid in segment 'Sample Software Segment' 

  Will install the required segment if that exists in this segment tape.

  Successfully converted segment SampleSW to new format.

  Segment 'SampleSW' is validated, preparing to install.

Segment (Sample Software Segment) successfully installed.

  Successfully converted segment SampleDataSegment to new format.

  Segment 'SampleDataSegment' is validated, preparing to install.

Segment (Sample Data-Segment Segment) successfully installed.

  Successfully converted segment P1 to new format.

  Segment 'P1' is validated, preparing to install.

Segment (SampleSW.P1) successfully installed.

Attachment 2 – Installation Log as it appears at the conclusion of D.10.3.9

Installation Log

Unable to find the affected $SEGMENT name 'Sample Account Group Segment' specified in SegName file on disk.

Warning - will install the affected segment.

Successfully converted segment SampleAgg to new format.

Segment 'SampleAgg' is validated, preparing to install.

Warning - Segment 'Sample Account Group Segment' not found under /h/AcctGrps/SampleAcctGrp to process Icons files.

Warning - Segment 'Sample Account Group Segment' not found under /h/AcctGrps/SampleAcctGrp to process Menus files.

Warning - Segment 'Sample Account Group Segment' not found under /h/AcctGrps/SampleAcctGrp to process Scripts files.

Warning - Segment 'Sample Account Group Segment' not found under /h/AcctGrps/SampleAcctGrp to process SegName files.

Warning - Unable to process FileAttribs Descriptor under /h/AcctGrps/SampleAcctGrp.

Segment (Sample Aggregate Segment) successfully installed.

Unable to find the affected $SEGMENT name 'Sample Account Group Segment' specified in SegName file on disk.

  Warning - will install the affected segment.

  Successfully converted segment SampleAggChild to new format.

  Segment 'SampleAggChild' is validated, preparing to install.

Warning - Segment 'Sample Account Group Segment' not found under /h/AcctGrps/SampleAcctGrp to process Icons files.

Warning - Segment 'Sample Account Group Segment' not found under /h/AcctGrps/SampleAcctGrp to process Menus files.

Warning - Segment 'Sample Account Group Segment' not found under /h/AcctGrps/SampleAcctGrp to process Scripts files.

Warning - Segment 'Sample Account Group Segment' not found under /h/AcctGrps/SampleAcctGrp to process SegName files.

Warning - Unable to process FileAttribs Descriptor under /h/AcctGrps/SampleAcctGrp.

  Segment (Sample Aggregate Child Segment) successfully installed.

  Successfully converted segment SampleAcctGrp to new format.

  Segment 'SampleAcctGrp' is validated, preparing to install.

Segment (Sample Account Group Segment) successfully installed.

  Successfully converted segment SampleCOTS to new format.

  Segment 'SampleCOTS' is validated, preparing to install.

  No Default FileAttribs Operations Performed On COTS Segment

Segment (Sample COTS Segment) successfully installed.

Unable to find the affected $SEGMENT name 'Sample Software Segment' specified in SegName file on disk.

Warning - will install the affected segment.

(E)----------------------------------------------------------|

[Requires] descriptor error. A pathname '/h/SampleSW' is invalid in segment 'Sample Software Segment'

  Will install the required segment if that exists on the server.

  Successfully converted segment SampleSW to new format.

  Segment 'SampleSW' is validated, preparing to install.

Segment (Sample Software Segment) successfully installed.

  Successfully converted segment SampleDataSegment to new format.

  Segment 'SampleDataSegment' is validated, preparing to install.

Segment (Sample Data-Segment Segment) successfully installed.

  Successfully converted segment SampleSW to new format.

  Segment 'SampleSW' is validated, preparing to install.

Segment (Sample Software Segment) successfully installed.

  Successfully converted segment P1 to new format.

  Segment 'P1' is validated, preparing to install.

Segment (SampleSW.P1) successfully installed.

Attachment 3 – Installation Log as it appears at the conclusion of D.14.8

Installation Log

Sample Aggregate Segment 1.0.0.0 successfully loaded on kpchost Network Server.

Sample Aggregate Child Segment 1.0.0.0 successfully loaded on kpchost Network Server.

Sample Account Group Segment 1.0.0.0 successfully loaded on kpchost Network Server.

Sample COTS Segment 1.0.0.0 successfully loaded on kpchost Network Server.

Sample Data-Segment Segment 1.0.0.0 successfully loaded on kpchost Network Server.

Sample Software Segment 1.0.0.0 successfully loaded on kpchost Network Server.

SampleSW.P1 1.0.0.0P1 successfully loaded on kpchost Network Server.

Attachment 4 – Installation Log as it appears at the conclusion of D.16.6

Installation Log

  Unable to find the affected $SEGMENT name 'Sample Account Group Segment' specified in SegName file on disk.

  Warning - will install the affected segment.

  Successfully converted segment SampleAgg to new format.

  Segment 'SampleAgg' is validated, preparing to install.

  Warning - Segment 'Sample Account Group Segment' not found under /h/AcctGrps/SampleAcctGrp to process Icons files.

  Warning - Segment 'Sample Account Group Segment' not found under /h/AcctGrps/SampleAcctGrp to process Menus files.

  Warning - Segment 'Sample Account Group Segment' not found under /h/AcctGrps/SampleAcctGrp to process Scripts files.

  Warning - Segment 'Sample Account Group Segment' not found under /h/AcctGrps/SampleAcctGrp to process SegName files.

  Warning - Unable to process FileAttribs Descriptor under /h/AcctGrps/SampleAcctGrp.

Segment (Sample Aggregate Segment) successfully installed.

  Unable to find the affected $SEGMENT name 'Sample Account Group Segment' specified in SegName file on disk.

  Warning - will install the affected segment.

  Successfully converted segment SampleAggChild to new format.

  Segment 'SampleAggChild' is validated, preparing to install.

  Warning - Segment 'Sample Account Group Segment' not found under /h/AcctGrps/SampleAcctGrp to process Icons files.

  Warning - Segment 'Sample Account Group Segment' not found under /h/AcctGrps/SampleAcctGrp to process Menus files.

  Warning - Segment 'Sample Account Group Segment' not found under /h/AcctGrps/SampleAcctGrp to process Scripts files.

  Warning - Segment 'Sample Account Group Segment' not found under /h/AcctGrps/SampleAcctGrp to process SegName files.

  Warning - Unable to process FileAttribs Descriptor under /h/AcctGrps/SampleAcctGrp.

Segment (Sample Aggregate Child Segment) successfully installed.

  Successfully converted segment SampleAcctGrp to new format.

  Segment 'SampleAcctGrp' is validated, preparing to install.

Segment (Sample Account Group Segment) successfully installed.

  Successfully converted segment SampleCOTS to new format.

  Segment 'SampleCOTS' is validated, preparing to install.

  No Default FileAttribs Operations Performed On COTS Segment

Segment (Sample COTS Segment) successfully installed.

  Unable to find the affected $SEGMENT name 'Sample Software Segment' specified in SegName file on disk.

  Warning - will install the affected segment.

(E)----------------------------------------------------------|

  [Requires] descriptor error. A pathname '/h/SampleSW' is invalid in segment 'Sample Software Segment'

  Will install the required segment if that exists on the server.

  Successfully converted segment SampleSW to new format.

  Segment 'SampleSW' is validated, preparing to install.

Segment (Sample Software Segment) successfully installed.

  Successfully converted segment SampleDataSegment to new format.

  Segment 'SampleDataSegment' is validated, preparing to install.

Segment (Sample Data-Segment Segment) successfully installed.

  Successfully converted segment SampleSW to new format.

  Segment 'SampleSW' is validated, preparing to install.

Segment (Sample Software Segment) successfully installed.

  Successfully converted segment P1 to new format.

  Segment 'P1' is validated, preparing to install.

Segment (SampleSW.P1) successfully installed.

Attachment 5 – Installation Log as it appears at the conclusion of D.17.4.8

Installation Log

Sample Aggregate Segment 1.0.0.0 successfully loaded on kpccp Network Server.

Sample Aggregate Child Segment 1.0.0.0 successfully loaded on kpccp Network Server.

Sample Account Group Segment 1.0.0.0 successfully loaded on kpccp Network Server.

Sample COTS Segment 1.0.0.0 successfully loaded on kpccp Network Server.

Sample Data-Segment Segment 1.0.0.0 successfully loaded on kpccp Network Server.

Sample Software Segment 1.0.0.0 successfully loaded on kpccp Network Server.

SampleSW.P1 1.0.0.0P1 successfully loaded on kpccp Network Server.

Attachment 6 – Installation Log as it appears at the conclusion of D.17.5.7

Installation Log

  Unable to find the affected $SEGMENT name 'Sample Account Group Segment' specified in SegName file on disk.

  Warning - will install the affected segment.

  Successfully converted segment SampleAgg to new format.

  Segment 'SampleAgg' is validated, preparing to install.

  Warning - Segment 'Sample Account Group Segment' not found under /h/AcctGrps/SampleAcctGrp to process Icons files.

  Warning - Segment 'Sample Account Group Segment' not found under /h/AcctGrps/SampleAcctGrp to process Menus files.

  Warning - Segment 'Sample Account Group Segment' not found under /h/AcctGrps/SampleAcctGrp to process Scripts files.

  Warning - Segment 'Sample Account Group Segment' not found under /h/AcctGrps/SampleAcctGrp to process SegName files.

  Warning - Unable to process FileAttribs Descriptor under /h/AcctGrps/SampleAcctGrp.

Segment (Sample Aggregate Segment) successfully installed.

  Unable to find the affected $SEGMENT name 'Sample Account Group Segment' specified in SegName file on disk.

  Warning - will install the affected segment.

  Successfully converted segment SampleAggChild to new format.

  Segment 'SampleAggChild' is validated, preparing to install.

  Warning - Segment 'Sample Account Group Segment' not found under /h/AcctGrps/SampleAcctGrp to process Icons files.

  Warning - Segment 'Sample Account Group Segment' not found under /h/AcctGrps/SampleAcctGrp to process Menus files.

  Warning - Segment 'Sample Account Group Segment' not found under /h/AcctGrps/SampleAcctGrp to process Scripts files.

  Warning - Segment 'Sample Account Group Segment' not found under /h/AcctGrps/SampleAcctGrp to process SegName files.

  Warning - Unable to process FileAttribs Descriptor under /h/AcctGrps/SampleAcctGrp.

Segment (Sample Aggregate Child Segment) successfully installed.

  Successfully converted segment SampleAcctGrp to new format.

  Segment 'SampleAcctGrp' is validated, preparing to install.

Segment (Sample Account Group Segment) successfully installed.

  Successfully converted segment SampleCOTS to new format.

  Segment 'SampleCOTS' is validated, preparing to install.

  No Default FileAttribs Operations Performed On COTS Segment

Segment (Sample COTS Segment) successfully installed.

  Unable to find the affected $SEGMENT name 'Sample Software Segment' specified in SegName file on disk.

  Warning - will install the affected segment.

  Will install the required segment if that exists on the server.

  Successfully converted segment SampleSW to new format.

  Segment 'SampleSW' is validated, preparing to install.

Segment (Sample Software Segment) successfully installed.

  Successfully converted segment SampleDataSegment to new format.

  Segment 'SampleDataSegment' is validated, preparing to install.

Segment (Sample Data-Segment Segment) successfully installed.

  Successfully converted segment SampleSW to new format.

  Segment 'SampleSW' is validated, preparing to install.

Segment (Sample Software Segment) successfully installed.

  Successfully converted segment P1 to new format.

  Segment 'P1' is validated, preparing to install.

Segment (SampleSW.P1) successfully installed.

Attachment 7 – Listing of "fixtestdata.sh" script invoked in steps B.2.12 and B.2.16.

# more fixtestdata.sh

#!/bin/ksh

#

##############################################################

# Script:       fixtestdata.sh

#

# Written by:   Ken Miller -- Compaq Federal Systems Eng.

#

# Date:         August 1999

#

# Description:  Prompts user for CPU & OPSYS values and

#               then finds all SegInfo files starting in

#               the current directory and replacing

#               the currently defined "Sun" values for

#               the prompted values.

#

# Arguments:    -d Do not prompt but instead use the uname

#               default values.

#               -v Verbose mode

#

##############################################################

#

doDefault=0

doUndo=0

doClean=0

doVerbose=0

while getopts :dt:vuc c

do   case $c in

        d)              doDefault=1;;

        t)              theTree=$OPTARG;;

        :)              print -u2 "$0: -$OPTARG requires a directory path"

                        exit 2;;

        u)              doUndo=1;;

        c)              doClean=1;;

        v)              doVerbose=1;;

        \?)             print -u2 "$0: unknown argument $i"

                        print -u2 "USAGE: $0 [ -d ] [ -v ] [ -t <path> ]"

                        print -u2 "     -d        Use default uname values"

                        print -u2 "     -v        Use verbose messages"

                        print -u2 "     -t <path> Starting tree (. is default)"

                        print -u2 "     -u        Undo the last execution"

                        print -u2 "     -c        Cleanup .orig[12] files"

                        exit 2;;

     esac

done

shift OPTIND-1

[[ "$theTree" = "" ]] && theTree="."

if [ ! -d "$theTree" ]

then

        echo "Can't access '$theTree'!"

        exit 2

fi

if [ "$doUndo" = 1 ]

then

        for i in `find $theTree -name SegInfo`

        do

                if [ ! -r $i.orig1 ]

                then

                        echo "$0: '$i.orig1' cannot be found."

                else

        [[ $doVerbose = 1 ]] && echo Restoring $i

                        /bin/mv $i.orig1 $i

                        /bin/rm -f $i.orig2

                fi

        done

        echo "$0: All SegInfo files returned to their original state"

        exit

fi

if [ "$doClean" = 1 ]

then

        for i in `find $theTree -name SegInfo`

        do

                [[ $doVerbose = 1 ]] && echo "Removing $i.orig[12]"

                /bin/rm -f $i.orig[12]

        done

        echo "$0: All SegInfo.orig[12] files have been removed"

        exit

fi

theCPU="$MACHINE_CPU"

theOPSYS="$MACHINE_OS"

if [ "$doDefault" != 1 -o "$theCPU" = "" -o "$theOPSYS" = "" ]

then

        while [ "$theCPU" = "" -o "$doDefault" = "0" ]

        do

                echo "Enter the desired CPU value [$theCPU]? \c"

                typeset -u x

                read x

                [[ "$x" = "" ]] && x=$theCPU

                theCPU=$x

                doDefault=1

        done

        doDefault=0

        while [ "$theOPSYS" = "" -o "$doDefault" = "0" ]

        do

                echo "\n\nEnter the desired OPSYS value [$theOPSYS]? \c"

                typeset -u x

                read x

                [[ "$x" = "" ]] && x=$theOPSYS

                theOPSYS=$x

                doDefault=1

        done

fi

echo "Changing all SegInfo files in $theTree tree to CPU:$theCPU and OPSYS:$theOPSYS..."

echo "\n\nHit [ENTER] to continue, <ctrl-c> to CANCEL \c"

read x

echo "\nWorking..."

for i in `find $theTree -name SegInfo`

do

        [[ $doVerbose = 1 ]] && echo $i

        if [ -r $i.orig1 ]

        then

                echo "$0: Error!  $i.orig1 already present!"

                echo "  If you really mean to do this, run with -c first."

                exit 2

        fi

        mv $i $i.orig1

        sed "s/^\$CPU:SPARC/\$CPU:$theCPU/;s/^\$OPSYS:SOL/\$OPSYS:$theOPSYS/" \

                $i.orig1 >$i

        if [ $theOPSYS = "OSF1" ]

        then

                mv $i $i.orig2

                sed "s/DEC/OSF1/" $i.orig2 >$i

        fi

        [[ $doVerbose = 1 ]] && diff $i.orig1 $i && echo "\n"

done

echo "$0: Completed!"

# 

Kernel Overview VP






 Page 1
Rev. Date:  25 June 98
Kernel Overview Validation Procedure Update




Page 1 of 143


DII COE 3.3.0.0 / Rev. Date:  23 May 2000


