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Test Purpose/Scope: This Kernel Overview test provides a high level test of the full range of fundamental Kernel Platform functionality.  Each of the other Kernel Platform Compliance (KPC) tests provides a deeper (i.e. more thorough) test of a specific narrower range of Kernel Platform function.

This test also assures that the Graphical User Interface (GUI) presented to the user for basic system operation is consistent across all compliant POSIX-based COE platforms.  This test assures that the operations invoked and exercised have identical results that are consistent across all compliant Posix-based Common Operating Environment (COE) platforms.

Description: This test procedure exercises the following basic icon functions:

A. sysadmin login - Verify sysadmin login, Profile Selector, Change Password Tool, command line accessibility, and icon accessibility

B. Adm Tool - Invokes the native operating system's administration tool.

C. Change Machine ID (with DNS) - Allows the System Administrator to change the machine name or Internet Protocol (IP) address of the workstation.

D. Create Action - Allows the System Administrator to create a desktop action.

E. Disk Manager - Allows the System Administrator to perform file system management tasks, including mounting and exporting file system partitions, formatting hard drives and hard drive partitions, displaying available hard disk space, and initializing diskettes.

F. Edit Local Hosts - Allows the System Administrator to manage the local host table, which lists the computers that can be accessed from the local workstation.

G. Network Installation Server and Segment Installer - Allows the System Administrator to load software segments onto a machine and make them available for other computers to install. Allows the System Administrator to install and/or remove software segments on the local workstation.

H. Set Routes - Allows the System Administrator to configure the workstation to connect to the wide area network through a default router.

I. Set System Time - Allows the System Administrator to set or change the value of the system time.

J. Text Editor - Invokes a text editor application.

K. Terminal Window - Opens a Terminal window for the System Administrator to perform tasks that require the use of a command line.

L. Reboot System - Allows the System Administrator to reboot the machine.

M. Shutdown System - Allows the System Administrator to prepare the machine for powering down.

N. secman login - Verify secman login, Profile Selector, Change Password Tool, command line accessibility, and icon accessibility

O. APM Client - Invokes the Account and Profile Manager client application. The APM Client administers user accounts, groups, profiles, and hosts.

P. APM Server Reload - Shuts down and restarts the APM local server process

Q. APM Server Stop - Shuts down the APM local server process.

R. APM Server Start - Restarts the APM local server process if the Security Administrator has shut it down. The APM local server communicates with the APM client and the APM master server to perform administrative operations.

S. Assign Passwords - Allows the Security Administrator to assign passwords to user accounts. This operation requires root access to the system.

T. Audit Log File Manager - Allows the Security Administrator to manage the audit log files, which record user login and logout information.

U. Edit APM Configuration - Invokes a graphical tool that allows the Security Administrator to edit the APM configuration settings.

V. Set Local Authentication Key – Uses the keyman account to set the local authentication key for the Candidate Platform and inform the Validation Host of the key.

W. Merge Host - Copies and synchronizes APM account and profile information from an APM host server to the APM master server. This operation adds an APM host to the APM administrative domain.

X. Profile Selector Configuration - Configures settings for the Profile Selector application.

Y. Remove Host - Removes a merged host from the APM administrative domain.

Z. Public Key Manager – Exports the host’s public key to a text file or imports the public key of a remote host.

AZ. Logout.
Overall Test Result:  The overall PASS/FAIL result for this test is determined as follows:  The overall test result is "PASS" if and only if all steps marked as PASS/FAIL steps in the Observed Result column, have a test step "PASS" result.

Test Step Results:  For each step with a "Circle One:  PASS/FAIL" in the Observed Result column, the tester compares the directly observed Candidate Platform behavior with the "PASS" criteria.  Unless other PASS criteria are noted in the test step, the test step result is "PASS" if and only if the Candidate Platform presents all of the behaviors and conditions described in the Expected Result column for that test step.  The test step result is "FAIL" if the Candidate Platform fails to satisfy any of the PASS criteria.

If the test step result is "PASS", the tester will circle "PASS" and note the actual behaviors and conditions presented in the Observed Result column.  If the observed result precisely matches the expected result, the Observed Result column for the step may contain the statement "as expected.”

If the test step result is "FAIL", the tester will circle "FAIL" in the Observed Result column and note the actual behaviors and conditions presented in the Observed Result column.  Additional documentation detailing the reasons for the test step failure is included in the Validation Test Report.

Note 1:  Due to the complexity of any Candidate Platform, it is impossible to completely specify all aspects of their operation in the space provided.  Many of the expected Candidate Platform behaviors for any test step are implicitly assumed based on industry practice, commercial testing or prior testing, and may not be explicitly described in the Expected Result column.  DISA reserves the right to consider implicit as well as explicit PASS/FAIL criteria which could adversely affect the ability of the Candidate Platform to satisfy DoD mission requirements when used as a component of the DII.

If implicit PASS/FAIL criteria are involved in a "FAIL" determination, the tester will circle "FAIL" in the Observed Result column and note the objectionable behavior in the Observed Result column at the point of observation during the test.  Additional documentation detailing the full rationale for the "FAIL" determination is to be included in the Validation Test Report.

Note 2:  Test steps that are "grayed out" (i.e., the entire table row is set to a gray background) are to be considered as waived by DISA for this test version only.  Grayed out test steps are not to be executed nor is observed behavior to be recorded.  These test steps may be returned to the overall test at a future date and are retained for information purposes only.  PASS/FAIL criteria identified in these test steps will not be used in the determination of the overall test result.

Note 3:  Lower case “s” in brackets [s] denotes a blank space; lower case “r” in brackets [r] denotes a carriage return; lower case “s” and “r” together in brackets [s] [r] denotes a blank space and carriage return.

Test Data/Media Required:  The following segments are required to execute this test:

1. OnlineDocs Segment Version 4.2.0.0.

Setup/Equipment Required:  This test requires a Validation Host and Candidate Platform configured as specified in the current version of the COE Setup Procedures for Kernel Platform Compliance (KPC) Validation Cell for Kernel V4.2.0.6 (Red Hat Linux 7.2) document.

Required Personnel:  One (1) tester.  The tester must be familiar with POSIX/Linux application platforms, but need not be familiar with the Common Operating Environment (COE).

Change History:

20 March 2002
Removed DRAFT status.  Deleted Term DII from narrative text but not test steps.




Step H.4.7 – In OA, replaced “Segment” with “Network”.




Step H.4.8 – Added step H.4.9, OA reads “Enter APM Authentication Key”; ER reads “Asterisks appear in the text box’.




Step X.1.21 – Corrected Note to read:  “SA Default may not be listed; if not, skip to step X.1.24”.

15-November-02
Edited by JITC for use with Red Hat Linux 7.2.

End of Preamble

Start of Validation Procedure

	
	Operator Action
	Expected Result
	Observed Result

	A
	Verify sysadmin Login, Profile Selector, Change Password Tool, Command Line Accessibility, and Icon Accessibility

	Prior to performing this test procedure, the tester should rebuild the test cell to remove any residual from previous tests.

	A.1
	Verify sysadmin Login
	

	A.1.1
	Perform the following steps on the Candidate Platform (kpccp).

Verify the COE LOGIN screen appears.
	The COE LOGIN screen appears with the DoD security-warning message and the Please enter your user name text box.
	Circle one:  PASS / FAIL



	A.1.2
	Log in as the System Administrator by typing sysadmin in the Login: text box and press Enter key.
	The password screen appears with the Password: text box.
	Circle one:  PASS / FAIL



	A.1.3
	Type the password for the sysadmin account in the Password: text box and press Enter key. 
	A dialog box appears indicating that the password needs to be changed.
	Circle one:  PASS / FAIL



	A.1.4
	Enter the current sysadmin password.
	A text box window appears with a New password text box.
	Circle one:  PASS / FAIL



	A.1.5
	Enter the new sysadmin password.  Press Enter key.

Record the new password.
	The text box changed to Retype the new password:  Press Enter key.
	Circle one:  PASS / FAIL

Password: _____________



	A.1.6
	Re-enter the new password.  Press Enter key
	An “OK” Message box appears stating, “COE login processing is complete.”
Note:  A “Start Here” window appears on top of the Message box.  Click the upper right hand corner of the “Start Here” window to expose the COE Message box.
	Circle one:  PASS / FAIL



	A.1.7
	Click OK in the COE Message box.
	The Message box disappears.
	Circle one:  PASS / FAIL



	A.2
	Verify sysadmin Profile Selector Functionality
	

	A.2.1
	Perform the following steps on the Candidate Platform (kpccp).

On the Control Panel, click the Left Footprint icon > Favorites > Profile Selector (the head with a question mark icon).
	The Profile Selector window opens with SA Default listed in the Selected Profiles panel.
	Circle one:  PASS / FAIL



	A.2.2
	Click Cancel.
	The Profile Selector window closes.
	Circle one:  PASS / FAIL



	A.3
	Verify sysadmin Change Password Tool Functionality
	

	A.3.1
	Perform the following steps on the Candidate Platform (kpccp).

On the Control Panel, click the Left Footprint icon > Favorites > Change Password Tool. 
	The Change your password dialog box opens.
	Circle one:  PASS / FAIL



	A.3.2
	Enter an incorrect sysadmin password in the Old Password: text box.
	Asterisks appear in the text box.
	Circle one:  PASS / FAIL

	A.3.3
	Enter a valid new password in the New Password: and Password Confirm: text boxes.
	Asterisks appear in the text boxes.
	Circle one:  PASS / FAIL

	A.3.4
	Click Submit.
	A Status Summary dialog box appears indicating the validation by sysadmin failed.
	Circle one:  PASS / FAIL



	A.3.5
	Click OK.
	The Status Summary dialog box closes
	Circle one:  PASS / FAIL



	A.3.6
	On the Control Panel, click the Left Footprint icon > Favorites > Change Password Tool.
	The Change your password dialog box opens.
	Circle one:  PASS / FAIL



	A.3.7
	Enter the correct sysadmin password in the Old Password text box.
	Asterisks appear in the text box.
	Circle one:  PASS / FAIL



	A.3.8
	Enter a new password in the New Password and Password Confirm text boxes.

NOTE: This password change cannot be undone. All test personnel should be informed of the new password.
	Asterisks appear in the text boxes.
	Circle one:  PASS / FAIL

New Password: ______________

	A.3.9
	Click Submit.
	A Status Summary dialog box appears indicating minimum password life has not expired.
	Circle one:  PASS / FAIL



	A.3.10
	Click OK.
	The Status Summary dialog box closes.
	Circle one:  PASS / FAIL



	A.3.11
	On the Control Panel, click the Left Footprint icon >  Log out.
	A Really log out? dialog box appears.
	Circle one:  PASS / FAIL



	A.3.12
	Click the “Logout” radio button
	The “Logout” radio button is selected.
	Circle one:  PASS / FAIL

	A.3.13
	Click the “Yes” button.
	The dialog box closes and the COE LOGIN window opens.
	Circle one:  PASS / FAIL



	A.3.14
	Login as sysadmin using the old password.
	An “OK” Message box appears stating, “COE login processing is complete.”
Note:  A “Start Here” window appears on top of the Message box.  Click the upper right hand corner of the “Start Here” window to expose the COE Message box.
	Circle one:  PASS / FAIL



	A.1.7
	Click OK in the COE Message box.
	The Message box closes.
	Circle one:  PASS / FAIL



	A.4
	Verify Command Line Access
	

	A.4.1
	Perform the following steps on the Candidate Platform (kpccp).

On the Control Panel, single-click the Terminal icon.
NOTE: This method is OS specific. Use the relevant method on the OS being tested and note it in the Observed Result column.

NOTE: This method should be used in all following test steps for the operator action “Open a Terminal window”.
	A Terminal window appears with a command line prompt.
	Circle one:  PASS / FAIL



	A.4.2
	At the command prompt type

id
NOTE: This command is OS specific. Use the relevant command on the OS being tested and note it in the Observed Results column.
	The system returns

uid=100(sysadmin) gid=1(other)
NOTE: This result is OS specific. The result should indicate the user is sysadmin.
	Circle one:  PASS / FAIL



	A.4.3
	At the command prompt type

pwd 

NOTE: This command is OS specific. Use the relevant command on the OS being tested and note it in the Observed Results column.
	The system returns

/h/USERS/local/sysadmin/Scripts 

NOTE: This result is OS specific. The result should indicate the above path.
	Circle one:  PASS / FAIL



	A.4.4
	At the command prompt type

exit
	The Terminal window disappears.
	Circle one:  PASS / FAIL



	A.5
	Verify Icon Access
	

	A.5.1
	Perform the following steps on the Candidate Platform (kpccp).

On the Control Panel, click the Left Footprint icon > Favorites > DII_APPS > SysAdm.

NOTE: This method is OS specific. Use the relevant method on the OS being tested and note it in the Observed Results column.
	Set_System_Time, Disk Manager, Set_Routes, Change_Machine_ID, Edit_Local_Hosts, Terminal, Text_Edit, Shutdown_System, Set_DNS, Adm_Tool, Reboot_System are listed in the menu.
	Circle one:  PASS / FAIL



	B
	Verify Admin Tool Functionality

	B.1
	Open the Admin Tool
	

	B.1.1
	Click Adm_Tool.
	Input Dialog box appears requesting the Password for root.
	Circle one:  PASS / FAIL



	B.1.2
	Enter root’s password in the dialog box
	Asterisks appear in the dialog box
	Circle one:  PASS / FAIL



	B.1.3
	Click “OK”
	The “Red Hat User Manager” window opens
	Circle one:  PASS / FAIL

	B.1.3
	On the menu bar, Click Action > Exit.
	The “Red Hat User Manager” window closes.
	Circle one:  PASS / FAIL



	C
	Change Machine ID Functionality 

	C.1
	Change the Machine Name and IP Address Of the Workstation
	

	C.1.1
	Perform the following steps on the Candidate Platform (kpccp).

On the Control Panel, click the Left Footprint icon > Favorites > DII_Apps > SysAdm > Change_Machine_ID.
	The Change Machine Id window appears.
	Circle one:  PASS / FAIL



	C.1.2
	In the New Machine Name text box, enter

nohost

NOTE: If the /etc/resolv.conf file is installed on the system, the Change Machine ID tool checks the system's host name against the information in the Domain Name Service (DNS). If the System Administrator attempts to use the Change Machine ID tool to change the host name to one that is not found in the DNS, the machine ID will not be changed.
	nohost appears in the New Machine Name text box.
	Circle one:  PASS / FAIL



	C.1.3
	In the New Machine Address text box enter

10.0.0.1
	10.0.0.1 appears in the New Machine Address text box.
	Circle one:  PASS / FAIL



	C.1.4
	Click Ok.
	An Input dialog box appears asking for the master APM authentication key.
	Circle one:  PASS / FAIL



	C.1.5
	Enter the master APM authentication key.
	Asterisks appear in the text box.
	Circle one:  PASS / FAIL



	C.1.6
	Click OK.
	A Error dialog box appears with the message:

Could not change host ID!

Unable to verify hostname and ip address with DNS.
	Circle one:  PASS / FAIL



	C.1.7
	Click OK.
	The Error dialog box closes.
	Circle one:  PASS / FAIL



	C.1.8
	In the New Machine Name text box enter

kpctest
	kpctest appears in the New Machine Name text box.
	Circle one:  PASS / FAIL



	C.1.9
	In the New Machine Address text box enter

204.34.175.193
	204.34.175.193 appears in the New Machine Address text box.
	Circle one:  PASS / FAIL



	C.1.10
	Click Ok.
	An Input dialog box appears asking for the master APM authentication key.
	Circle one:  PASS / FAIL



	C.1.11
	Enter the master APM authentication key.
	Asterisks appear in the text box.
	Circle one:  PASS / FAIL



	C.1.12
	Click OK.
	A Success dialog box appears with the message:

Operation completed successfully.

Reboot system now?
	Circle one:  PASS / FAIL



	C.1.13
	Click Yes.
	The workstation reboots and the DII COE LOGIN screen appears.
	Circle one:  PASS / FAIL



	C.2
	Verify ID Change
	

	C.2.1
	Perform the following steps on the Candidate Platform (kpccp).

Login as sysadmin by typing sysadmin in the Login: text box and press the Enter Key.
	The password window opens with the Password: text box.
	Circle one:  PASS / FAIL



	C.2.2
	Type the password for the sysadmin account in the Password: text box and press Enter Key.
	An “OK” Message box appears stating, “COE login processing is complete.”

Note: A Start Here window opens on top of the Message box.  Click the upper right hand corner of the Start Here window to close the Start Here Window and expose the COE Message box.
	Circle one:  PASS / FAIL

	C.2.3
	Click OK in the COE Message box.
	The Message box closes
	Circle one:  PASS / FAIL

	C.2.4
	Open a Terminal window by clicking the terminal window icon on the control panel 
	A Terminal window appears with a command line prompt.
	Circle one:  PASS / FAIL



	C.2.5
	At the command prompt type

cat /etc/hosts
	The contents of the /hosts file appear.
	Circle one:  PASS / FAIL



	C.2.6
	Verify that the following line appears in the listing:

204.34.175.193 kpctest loghost 
	A line containing the specified information is present. 

The additional text “kpccp.kpc.disa.mil” may also be present.

NOTE: Change Machine ID does not change aliases (i.e. kpccp.kpc.disa.mil).
	Circle one:  PASS / FAIL

kpccp.kpc.disa.mil is not present

	C.2.7
	Close the terminal window by clicking on the X in the upper right hand corner of the window.
	The Terminal window closes.
	Circle one:  PASS / FAIL

	C.3
	Restore the Machine Name and IP Address Of the Workstation
	

	C.3.1
	Perform the following steps on the Candidate Platform (kpccp).

On the Control Panel, click the Left Footprint icon > Favorites > Profile Selector.
	The Profile Selector window appears with SA Default listed in the Available Profiles panel.
	Circle one:  PASS / FAIL



	C.3.2
	Double-click SA Default.
	Profile SA Default moves to the Selected Profiles panel.
	Circle one:  PASS / FAIL



	C.3.3
	Click OK.
	The Profile Selector Results window appears indicating that SA Default has been successfully assumed.
	Circle one:  PASS / FAIL



	C.3.4
	Click Done.
	The Profile Selector Results window and Profile Selector windows close.
	Circle one:  PASS / FAIL



	C.3.5
	On the Control Panel, click the Left Footprint icon > Favorites > DII_Apps > SysAdm > Change_Machine_ID.
	The Change Machine Id window appears.
	Circle one:  PASS / FAIL

	C.3.6
	In the New Machine Name text box, enter

kpccp
	kpccp appears in the New Machine Name text box.
	Circle one:  PASS / FAIL



	C.3.7
	In the New Machine Address text box enter

204.34.175.195
	204.34.175.195 appears in the New Machine Address text box.
	Circle one:  PASS / FAIL



	C.3.9
	Click Ok.
	An Input dialog box appears asking for the master APM authentication key.
	Circle one:  PASS / FAIL



	C.3.10
	Enter the Master APM Authentication key.
	Asterisks appear in the text box.
	Circle one:  PASS / FAIL



	C.3.11
	Click OK.
	A Success dialog box appears with the message:

Operation completed successfully.

Reboot system now?
	Circle one:  PASS / FAIL



	C.3.12
	Click Yes.
	The workstation reboots and the DII COE LOGIN screen appears.
	Circle one:  PASS / FAIL



	D
	Create Action

	D.1
	Create A Desktop Action
	

	D.1.1
	Perform the following steps on the Candidate Platform (kpccp).

Right-click on the control panel

NOTE: This method is OS specific. Use the relevant method on the OS being tested and note it in the Observed Results column.
	The menu appears.
	Circle one:  PASS / FAIL

	D.1.2
	Select Panel > Add to panel > Launcher from menu > Applications > gedit.

NOTE: This method is OS specific. Use the relevant method on the OS being tested and note it in the Observed Results column.
	A gedit icon appears on the control panel.
	Circle one:  PASS / FAIL

	D.1.3
	Click the gedit icon.
	The gedit window opens.
	Circle one:  PASS / FAIL



	D.1.4
	Using the editor tools, open the file /etc/hosts
	The file contents display the following in (read-only mode)

#Do not remove the following line, or various programs

#that require network functionality will fail.

204.34.175.195 kpccp  loghost

127.0.0.1  kpccp localhost.localdomain localhost
	Circle one:  PASS / FAIL

	D.1.5
	Close the file using the “Close” icon.
	The file contents disappear. 
	Circle one:  PASS / FAIL



	D.1.6
	Close gedit by clicking the “X” in the upper right-hand corner of the editor window
	The gedit window closes.
	Circle one:  PASS / FAIL



	D.2
	Verify the New Desktop Action
	

	D.2.1
	Verify that an icon named Test Action is present in the File Manager – Scripts window.
	The Test Action icon is present.
	Circle one:  PASS / FAIL



	D.2.2
	Click the gedit icon.
	The gedit window opens.
	Circle one:  PASS / FAIL



	D.2.3
	Using the editor tools, open the file /etc/hosts
	The file contents display the following in (read-only mode)

#Do not remove the following line, or various programs

#that require network functionality will fail.

204.34.175.196 kpccp  loghost

127.0.0.1  kpccp localhost.localdomain localhost
	Circle one:  PASS / FAIL

	D.2.4
	Click the “X” in the upper right hand corner of the gedit window.
	The gedit window closes
	Circle one:  PASS / FAIL

	D.3
	Remove the New Desktop Action
	

	D.3.1
	Perform the following steps on the Candidate Platform (kpccp).

Right-click the gedit icon on the control panel.
	A drop-down menu appears.
	Circle one:  PASS / FAIL



	D.3.2
	Select Remove from panel.
	The gedit icon disappears.
	Circle one:  PASS / FAIL



	E
	Terminal Window

	E.1
	Setup
	

	E.1.1
	Perform the following steps on the Candidate Platform (kpccp).

Double-click Terminal icon on the control panel. 
	A Terminal window appears with a login prompt.
	Circle one:  PASS / FAIL



	E.1.2
	At the command prompt type

id
NOTE: This command is OS specific. Use the relevant command on the OS being tested and note it in the Observed Results column.
	The system returns

uid=100(sysadmin) gid=1(other)
NOTE: This result is OS specific. The result should indicate the user is sysadmin.
	Circle one:  PASS / FAIL



	E.1.3
	At the command prompt type

pwd
NOTE: This command is OS specific. Use the relevant command on the OS being tested and note it in the Observed Result column.
	The system returns

/h/USERS/local/sysadmin/Scripts 

NOTE: This result is OS specific. The result should indicate the above path.
	Circle one:  PASS / FAIL



	E.1.4
	At the command prompt type

exit
	The Terminal window disappears.
	Circle one:  PASS / FAIL



	F
	Disk Manager

	F.1
	Verify That the Candidate Platform Can Share (Export) A Directory
	

	F.1.1
	Perform the following steps on the Candidate Platform (kpccp).

Login as sysadmin by typing sysadmin in the Login: text box and press the Enter Key.
	The password window opens with the Password: text box.
	Circle one:  PASS / FAIL



	F.1.2
	Type the password for the sysadmin account in the Password: text box and press Enter Key.
	An “OK” Message box appears stating, “COE login processing is complete.”

Note: A Start Here window opens on top of the Message box.  Click the upper right hand corner of the Start Here window to close the Start Here Window and expose the COE Message box.
	Circle one:  PASS / FAIL

	F.1.3
	Click OK in the COE Message box.
	The Message box closes
	Circle one:  PASS / FAIL

	F.1.4
	Open a Terminal window by clicking the terminal window on the control panel.
	A Terminal window appears with a command line prompt.
	Circle one:  PASS / FAIL



	F.1.2
	At the command prompt type 

su -
	The Password prompt appears.
	Circle one:  PASS / FAIL



	F.1.3
	At the Password prompt type the root password.
	The command prompt returns.
	Circle one:  PASS / FAIL



	F.1.4
	At the command prompt type

csh
	The command prompt returns.
	Circle one:  PASS / FAIL



	F.1.5
	At the command prompt type

mkdir /kpchost.home2
	The command prompt returns.
	Circle one:  PASS / FAIL



	F.1.6
	At the command prompt type

cd /home2
	The command prompt returns.
	Circle one:  PASS / FAIL



	F.1.7
	At the command prompt type

echo > kpccp
	The command prompt returns.
	Circle one:  PASS / FAIL



	F.1.8
	Perform the following steps on the Validation Host (kpchost). 

Login as sysadmin by typing sysadmin in the Login: text box and press the Enter Key.
	The password window opens with the Password: text box.
	Circle one:  PASS / FAIL



	F.1.9
	Type the password for the sysadmin account in the Password: text box and press Enter Key.
	An “OK” Message box appears stating “COE login processing is complete.”

Note: A Start Here window opens on top of the Message box.  Click the upper right hand corner of the Start Here window to close the Start Here Window and expose the COE Message box.
	Circle one:  PASS / FAIL

	F.1.10
	Click OK in the COE Message box.
	The Message box closes
	Circle one:  PASS / FAIL

	F.1.11
	Open a Terminal window by clicking the terminal window icon on the control panel.
	A Terminal window appears with a command line prompt.
	Circle one:  PASS / FAIL



	F.1.12
	At the command prompt type 

su -
	The Password prompt appears.
	Circle one:  PASS / FAIL



	F.1.13
	At the Password prompt type the root password.
	The command prompt returns.
	Circle one:  PASS / FAIL



	F.1.14
	At the command prompt type

csh
	The command prompt returns.
	Circle one:  PASS / FAIL



	F.1.15
	At the command prompt type

mkdir /kpccp.home2
	The command prompt returns.
	Circle one:  PASS / FAIL



	F.1.16
	At the command prompt type

cd /home2
	The command prompt returns.
	Circle one:  PASS / FAIL



	F.1.17
	At the command prompt type

echo > kpchost
	The command prompt returns.
	Circle one:  PASS / FAIL



	F.2
	Share and Mount Candidate Platform’s /home2
	

	F.2.1
	Perform the following steps on the Candidate Platform (kpccp).

On the Control Panel, click the Left Footprint icon > Favorites > DII_Apps > SysAdm > Disk_Manager.
	The Disk Manager window appears.
	Circle one:  PASS / FAIL



	F.2.2
	Select the row containing /home2 in the Mounted On column.
	The row is highlighted.
	Circle one:  PASS / FAIL



	F.2.3
	Click Export…
	The Export/Unexport File Systems dialog box appears.
	Circle one:  PASS / FAIL



	F.2.4
	In the options text box enter 

rw=kpchost.kpc.disa.mil
	rw=kpchost.kpc.disa.mil appears in the text box.
	Circle one:  PASS / FAIL



	F.2.5
	Click Export.
	A Confirmation dialog box appears asking if the directory should be exported permanently. 
	Circle one:  PASS / FAIL



	F.2.6
	Click Yes.
	The dialog boxes disappear.
	Circle one:  PASS / FAIL



	F.2.7
	Perform the following steps on the Validation Host (kpchost).

On the Control Panel, click the Left Footprint icon > Favorites > DII_Apps > SysAdm > Disk_Manager.
	The Disk Manager window opens
	Circle one:  PASS / FAIL



	F.2.8
	Click Mount…
	The Mount File System dialog box appears.
	Circle one:  PASS / FAIL



	F.2.9
	In the FILE SYSTEM text box enter

kpccp:/home2
	kpccp:/home2 appears in the text box.
	Circle one:  PASS / FAIL



	F.2.10
	In the MOUNT POINT text box enter

/kpccp.home2
	/kpccp.home2 appears in the text box.
	Circle one:  PASS / FAIL



	F.2.12
	Click Mount…
	A Confirmation dialog box appears asking if the directory should be mounted permanently. 
	Circle one:  PASS / FAIL



	F.2.13
	Click Yes.
	The dialog boxes close and a row for kpccp:/home2 appears in the Disk Manager window.
	Circle one:  PASS / FAIL



	F.2.14
	At the command prompt in the Terminal window, type

cd /kpccp.home2
	The command prompt returns.
	Circle one:  PASS / FAIL



	F.2.15
	At the command prompt type

ls
	The file kpccp appears in the listing.
	Circle one:  PASS / FAIL



	F.2.16
	At the command prompt type 

cd /
	The command prompt returns.
	Circle one:  PASS / FAIL



	F.2.17
	In the Disk Manager window, select the row containing /kpccp.home2 in the Mounted On column.
	The row is highlighted.
	Circle one:  PASS / FAIL



	F.2.18
	Click Unmou…
	A Confirmation dialog box appears asking if the directory should be unmounted permanently.
	Circle one:  PASS / FAIL



	F.2.19
	Click Yes.
	The dialog box disappears and the row for /kpccp.home2 disappears from the Disk Manager window.
	Circle one:  PASS / FAIL



	F.2.20
	Perform the following steps on the Candidate Platform (kpccp).

In the Disk Manager window, select the row containing /home2 in the Mounted On column.
	The row is highlighted.
	Circle one:  PASS / FAIL



	F.2.21
	Click Export…
	The Export/Unexport File Systems dialog box appears.
	Circle one:  PASS / FAIL



	F.2.22
	Click Unexport.
	A dialog box appears asking if the directory should be unexported permanently.
	Circle one:  PASS / FAIL



	F.2.23
	Click Yes.
	The dialog boxes disappear.
	Circle one:  PASS / FAIL



	F.3
	Share and Mount Validation Host’s /home2
	

	F.3.1
	Perform the following steps on the Validation Host (kpchost).

In the Disk Manager window, select the row containing /home2 in the Mounted On column.
	The row is highlighted.
	Circle one:  PASS / FAIL



	F.3.2
	Click Export…
	The Export/Unexport File Systems dialog box appears.
	Circle one:  PASS / FAIL



	F.3.3
	In the options text box, enter 

rw=kpccp.kpc.disa.mil
	rw=kpccp.kpc.disa.mil appears in the text box.
	Circle one:  PASS / FAIL



	F.3.4
	Click Export.
	A Confirmation dialog box appears asking if the directory should be exported permanently. 
	Circle one:  PASS / FAIL



	F.3.5
	Click Yes.
	The dialog boxes disappear.
	Circle one:  PASS / FAIL



	F.3.6
	Perform the following steps on the Candidate Platform (kpccp).

Click Mount…
	The Mount File System dialog box appears.
	Circle one:  PASS / FAIL



	F.3.7
	In the FILE SYSTEM text box, enter

kpchost:/home2
	kpchost:/home2 appears in the text box.
	Circle one:  PASS / FAIL



	F.3.8
	In the MOUNT POINT text box enter

/kpchost.home2
	/kpchost.home2 appears in the text box.
	Circle one:  PASS / FAIL



	F.3.9
	Click Mount.
	A Confirmation dialog box appears asking if the directory should be mounted permanently. 
	Circle one:  PASS / FAIL



	F.3.10
	Click Yes.
	The dialog boxes disappear and a row for kpchost:/home2 appears in the Disk Manager window.
	Circle one:  PASS / FAIL



	F.3.11
	At the command prompt in the  Terminal window, type

cd /kpchost.home2
	The command prompt returns.
	Circle one:  PASS / FAIL



	F.3.12
	At the command prompt type

ls
	The file kpchost appears in the listing.
	Circle one:  PASS / FAIL



	F.3.13
	At the command prompt type 

cd /
	The command prompt returns.
	Circle one:  PASS / FAIL



	F.3.14
	In the Disk Manager window, select the row containing /kpchost.home2 in the Mounted On column.
	The row is highlighted.
	Circle one:  PASS / FAIL



	F.3.15
	Click Unmo…
	A Confirmation dialog box appears asking if the directory should be unmounted permanently.
	Circle one:  PASS / FAIL



	F.3.16
	Click Yes.
	The dialog box disappears and the row for /kpchost.home2 disappears from the Disk Manager window.
	Circle one:  PASS / FAIL



	F.3.17
	Perform the following steps on the Validation Host (kpchost).

In the Disk Manager window, select the row containing /home2 in the Mounted On column.
	The row is highlighted.
	Circle one:  PASS / FAIL



	F.3.18
	Click Export FS.
	The Export/Unexport File Systems dialog box appears.
	Circle one:  PASS / FAIL



	F.3.19
	Click Unexport.
	A dialog box appears asking if the directory should be unexported permanently.
	Circle one:  PASS / FAIL



	F.3.20
	Click Yes.
	The dialog boxes disappear.
	Circle one:  PASS / FAIL



	F.3.21
	Log out of the Validation Host (kpchost).

On the Control Panel, click the Left Footprint icon > Log out.


	A Logout Confirmation window appears.
	Circle one:  PASS / FAIL

	F.3.22
	Click Yes
	System exits and the DII COE LOGIN screen appears.
	Circle one:  PASS / FAIL



	F.4
	Format and mount disk partition
	

	F.4.1
	Perform the following steps on the Candidate Platform (kpccp).

In the Disk Manager window, highlight the row with /test.
	The row with /test is highlighted.
	Circle one:  PASS / FAIL



	F.4.2
	Click Unmount.
	A Confirmation dialog box appears asking if the directory should be unmounted permanently.
	Circle one:  PASS / FAIL



	F.4.3
	Click Yes.
	The dialog box disappears and the row for /test disappears from the Disk Manager window.
	Circle one:  PASS / FAIL



	F.4.4
	In the Disk Manager window, click New FS.


	The New File System dialog box appears.
	Circle one:  PASS / FAIL



	F.4.5
	In the DISK DEVICE text box, enter

/dev/dsk/c0t0d0s7

NOTE: This step is platform specific. Enter the device name for the test partition created during Validation Cell setup here and in the following steps.
	/dev/dsk/c0t0d0s7 is displayed.
	Circle one:  PASS / FAIL



	F.4.6
	Click OK.
	A Please wait message box is displayed while the partition is formatted.  The message box disappears and the Disk Manager window reappears.

NOTE: The message box may disappear quickly.
	Circle one:  PASS / FAIL



	F.4.7
	Click Mount New.
	The Mount File System dialog box is displayed.
	Circle one:  PASS / FAIL

	F.4.8
	In the FILE SYSTEM text box enter /dev/dsk/c0t0d0s7
	/dev/dsk/c0t0d0s7 appears in the textbox
	Circle one:  PASS / FAIL

	F.4.9
	In the MOUNT POINT text box enter

/home3
	/home3 appears in the text box.
	Circle one:  PASS / FAIL



	F.4.10
	Click MOUNT.
	The dialog box appears with the following message:
Mount the File System Permanently? 
	Circle one:  PASS / FAIL



	F.4.11
	Click Yes.
	/dev/dsk/c0t0d0s7 shows /home3 in Mounted On column.  
	 Circle one:  PASS / FAIL

	F.4.12
	Highlight the row with /home3 in the Mounted On column.
	The row with /home3 is highlighted.
	Circle one:  PASS / FAIL

	F.4.13
	Click Unmount.
	A Confirmation dialog box appears asking if the directory should be unmounted permanently.
	 Circle one:  PASS / FAIL

	F.4.14
	Click Yes.
	The dialog box disappears and the row for /home3 disappears from the Disk Manager window.
	 Circle one:  PASS / FAIL

	F.4.15
	Click Exit in the Disk Manager window.
	The Disk Manager window disappears.
	Circle one:  PASS / FAIL



	G
	Edit Local Hosts

	G.1
	Add A New Host
	

	G.1.1
	Perform the following steps on the Candidate Platform (kpccp).

On the Control Panel, click the Left Footprint icon > Favorites > DII_Apps > SysAdm > Edit_Local_Hosts.
	The Edit Hosts window appears.
	Circle one:  PASS / FAIL



	G.1.2
	Click Add.
	The Add Machine window appears.
	Circle one:  PASS / FAIL



	G.1.3
	In the MACHINE NAME text box, enter

newmachine
	newmachine appears in the MACHINE NAME text box.
	Circle one:  PASS / FAIL



	G.1.4
	In the MACHINE ADDRESS text box enter

169.254.0.100
	169.254.0.100 appears in the MACHINE ADDRESS text box.
	Circle one:  PASS / FAIL



	G.1.5
	Click OK.
	The Add Machine window disappears and newmachine shows up in the Edit Hosts window.
	Circle one:  PASS / FAIL



	G.1.6
	At the command prompt in the Terminal window type

cat /etc/hosts
	The contents of the /hosts file are displayed.
	Circle one:  PASS / FAIL



	G.1.7
	Verify that an entry exists for 

169.254.0.100 newmachine
	The line exists.
	Circle one:  PASS / FAIL



	G.2
	Delete A Host
	

	G.2.1
	Perform the following steps on the Candidate Platform (kpccp).

Select newmachine in the Edit Hosts window.
	The line containing newmachine is highlighted.
	Circle one:  PASS / FAIL

	G.2.2
	Click Delete.
	A Confirmation Required dialog box appears with the following message

Are you sure you want to remove host 169.254.0.100?
	Circle one:  PASS / FAIL

	G.2.3
	Click Yes.
	The Confirmation Required dialog box disappears and newmachine is removed from the Edit Hosts window.
	Circle one:  PASS / FAIL

	G.2.4
	At the command prompt in the Terminal window type

cat /etc/hosts
	The contents of the hosts file are displayed.
	Circle one:  PASS / FAIL

	G.2.5
	Verify that the entry for 

169.254.0.100 newmachine 

has been removed.
	The line does not exist.
	Circle one:  PASS / FAIL

	G.2.6
	Click Close in the Edit Hosts window.
	The Edit Hosts window closes.
	Circle one:  PASS / FAIL



	H
	Network Installation Server and Segment Installer

	H.1
	Load Segment To Candidate Platform
	

	H.1.1
	Perform the following steps on the Candidate Platform (kpccp).

Insert the OnlineDocs (ONDOC) v 4.2.0.0 tape into the tape drive or, if using the KPC Test Data CD, insert the CD into the cdrom drive.
	The tape/CD is inserted.
	Circle one:  PASS / FAIL

	H.1.2
	Double-click Network Installation Server in the Application Manager – SysAdm window.
	The Segment Installation Server window appears.
	Circle one:  PASS / FAIL

	H.1.3
	If a tape is used, click Read Contents,


or,

if the KPC Test Data CD is used, proceed as follows:

Click Select Source,

Click CD-ROM,

Double-click “seg” in the Directories column,

Double-click ONDOC.tar in the Files column,
Click Read Contents.
	The Segment Installation Server window disappears while message boxes appear informing that the system is Checking media and that Read Content is in progress.

The Segment Installation Server window reappears with OnlineDocs listed under Select Software To Load.
	Circle one:  PASS / FAIL

	H.1.4
	Select OnlineDocs.
	OnlineDocs is highlighted.
	Circle one:  PASS / FAIL



	H.1.5
	Click Release Notes.
	A RELEASE NOTES window opens with Release Notes text.
	Circle one:  PASS / FAIL



	H.1.6
	Click OK.
	The RELEASE NOTES window disappears.
	Circle one:  PASS / FAIL



	H.1.7
	Click Requires.
	A REQUIRES SEGMENTS window opens listing segments required before installing OnlineDocs.
	Circle one:  PASS / FAIL



	H.1.8
	Click OK.
	The REQUIRES SEGMENTS window disappears.
	Circle one:  PASS / FAIL



	H.1.9
	Click Conflicts.
	An INFORMATIONAL MESSAGE dialog box opens informing that the Conflicts descriptor is not available.
	Circle one:  PASS / FAIL



	H.1.10
	Click OK.
	The dialog box disappears.
	Circle one:  PASS / FAIL



	H.1.11
	In the Available Disks panel select the row containing /home2.
	The row is highlighted.
	Circle one:  PASS / FAIL



	H.1.12
	Click Load.
	An ENTER A PASSWORD dialog box appears. 
	Circle one:  PASS / FAIL



	H.1.13
	Enter the APM Authentication key in the text box.
	Asterisks appear in the text box.
	Circle one:  PASS / FAIL



	H.1.14
	Click OK.
	Control returns to the Segment Installation Server window.

OnlineDocs[ALL] appears in the list under Segments Currently Loaded On This Network Server.
	Circle one:  PASS / FAIL

	H.1.15
	Select Installed > View Installation Log.
	An Install Log window appears indicating OnlineDocs was successfully loaded on the kpccp Network Server.
	Circle one:  PASS / FAIL



	H.1.16
	Click OK.
	The Install Log window disappears.
	Circle one:  PASS / FAIL



	H.2
	Install the Loaded Segment On the Candidate Platform
	

	H.2.1
	Perform the following steps on the Candidate Platform (kpccp).

Double-click Segment Installer in the Application Manager – SysAdm window.
	The  Installer window appears.
	Circle one:  PASS / FAIL

	H.2.2
	Click Select Source.
	The Select Source dialog box appears.
	Circle one:  PASS / FAIL



	H.2.3
	Select LOCAL in the Host panel and NETWORK in the Device panel.
	The LOCAL and NETWORK radio buttons are highlighted.
	Circle one:  PASS / FAIL



	H.2.4
	Click OK.
	The Select Source dialog box disappears.
	Circle one:  PASS / FAIL



	H.2.5
	Click Read Contents.
	The Installer window shows OnlineDocs listed under Select Software To Install.
	Circle one:  PASS / FAIL



	H.2.6
	Select OnlineDocs.
	OnlineDocs is highlighted.
	Circle one:  PASS / FAIL



	H.2.7
	Click Install.
	An ENTER A PASSWORD dialog box appears.
	Circle one:  PASS / FAIL



	H.2.8
	Enter the APM Authentication key in the text box.
	Asterisks appear in the text box.
	Circle one:  PASS / FAIL



	H.2.9
	Click OK.
	The dialog box disappears. 

The Installer window shows OnlineDocs listed under Currently Installed Segments.
	Circle one:  PASS / FAIL

	H.3
	Verify Installation
	

	H.3.1
	NOTE: Perform the following steps on the Candidate Platform (kpccp).

Select Installed > View Installation Log.
	An Install Log window appears indicating OnlineDocs was successfully installed.
	Circle one:  PASS / FAIL

	H.3.2
	Click OK.
	The Install Log window disappears.
	Circle one:  PASS / FAIL



	H.4
	Test Segment De-installation
	

	H.4.1
	NOTE: Perform the following steps on the Candidate Platform (kpccp).

In the list under Currently Installed Segments, select OnlineDocs.
	OnlineDocs is highlighted.
	Circle one:  PASS / FAIL

	H.4.2
	Click Deinstall Software.
	A RESPOND TO THE QUESTION dialog box appears to verify that you really want to remove the segment.
	Circle one:  PASS / FAIL

	H.4.3
	Click No.
	The Installer window reappears with OnlineDocs still listed in the Currently Installed Segments panel.
	Circle one:  PASS / FAIL



	H.4.4
	Click Deinstall Software.
	A RESPOND TO THE QUESTION dialog box appears to verify that you really want to remove the segment.
	Circle one:  PASS / FAIL



	H.4.5
	Click Yes.


	The Installer window appears.
	Circle one:  PASS / FAIL

	H.4.6
	Click Exit.
	The Installer window disappears.
	Circle one:  PASS / FAIL



	H.4.7
	In the Network Installation Server window select OnlineDocs[ALL] under Segments Currently Loaded On This Network Server.
	OnlineDocs[ALL] is highlighted.
	Circle one:  PASS / FAIL

	H.4.8
	Click Deinstall Software.


	A RESPOND TO THE QUESTION dialog box appears to verify that you really want to remove the segment.
	Circle one:  PASS / FAIL

	H.4.9
	Enter the Master APM Authentication Key
	Asterisks appear in the text box.
	Circle one: PASS / FAIL

	H.4.10
	Click OK.
	The text box closes.
	Circle one:  PASS / FAIL

	H.4.11
	Click Exit.
	The Segment Installation Server window disappears.
	Circle one:  PASS / FAIL



	H.4.12
	Eject the tape or CD.
	The tape or CD ejects.
	Circle one:  PASS / FAIL



	I
	Set Routes

	I.1
	Setup
	

	I.1.1
	Perform the following steps on the Candidate Platform (kpccp).

At the command prompt in the Terminal window, type
netstat -nr
	Network routing information is displayed.
	Circle one:  PASS / FAIL

	I.1.2
	Verify that there is not a line containing default.
	There is no default listed.
	Circle one:  PASS / FAIL



	I.1.3
	On the Control Panel, click the Left Footprint icon > Favorites > DII_Apps > SysAdm > Set_Routes
	The Default Router Setup window appears.
	Circle one:  PASS / FAIL



	I.1.4
	In the Default Router IP Address text box, enter

204.34.175.194
	204.34.175.194 appears in the text box.
	Circle one:  PASS / FAIL



	I.1.5
	Click OK.
	A Done dialog box appears informing that the operation completed successfully.  
	Circle one:  PASS / FAIL



	I.1.6
	Click OK.
	The dialog box and the Default Router Setup window disappear.
	Circle one:  PASS / FAIL



	I.1.7
	At the command prompt type

netstat -nr
	Network routing information is displayed.
	Circle one:  PASS / FAIL



	I.1.8
	Verify that a line containing the Flag “UH” is listed.
	“UH” is listed with the IP address 204.34.175.194.
	Circle one:  PASS / FAIL



	J
	Set System Time

	J.1
	Setup
	

	J.1.4
	On the Control Panel, click the Left Footprint icon > Favorites > DII_Apps > SysAdm > Set_System_Time
NOTE: The System Time window displays the local time as if the system time is GMT. Thus, the GMT offset from the current local time will shift the hour representation. In the steps below, time entered into the System Time window will be interpreted, as GMT while the OW Clock display will be system time.

NOTE: The steps below may cause the screen lock to engage. If so, enter the sysadmin password and continue.
	A System Time window appears with a date time group (DTG) in the form ddhhmmZ MON YYYY, where:

dd represents the day of the month.

hh represents the hour (in GMT).

mm represents the minute.

Z is a constant (for Zulu time).

MON represents the three-letter month abbreviation.

YYYY represents the four-digit year.

The time displayed should be the same as the clock display shifted by the GMT offset.
	Circle one:  PASS / FAIL

	J.1.5


	In the Enter DTG text box change the third and fourth digits (hour) to a different value.
	The value appears in the text box.
	Circle one:  PASS / FAIL



	J.1.6
	Click OK.
	A Done dialog box appears indicating that the operation has completed successfully. 
	Circle one:  PASS / FAIL



	J.1.7
	Click OK.
	The dialog box and the System Time window disappear.
	Circle one:  PASS / FAIL



	J.1.8
	Verify the clock on the lower right of the control panel displays the new time
	The clock displays the new time.
	Circle one:  PASS / FAIL



	J.1.9
	On the Control Panel, click the Left Footprint icon > Favorites > DII_Apps > SysAdm > Set_System_Time.
	A System Time window appears.
	Circle one:  PASS / FAIL



	J.1.10
	Enter the current local time in the Enter DTG text box.
	The value appears in the text box.
	Circle one:  PASS / FAIL



	J.1.11
	Click OK.
	A Done dialog box appears indicating that the operation has completed successfully.
	Circle one:  PASS / FAIL



	J.1.13
	Click OK.
	The dialog box and the System Time window disappear. 
	Circle one:  PASS / FAIL



	J.1.14
	Open the clock window and verify that the clock window displays the current time.
	The clock window displays the current time.
	Circle one:  PASS / FAIL



	J.1.15
	Close the clock window.
	The clock window disappears.
	Circle one:  PASS / FAIL



	K
	Text Editor

	K.1
	Use the Text Editor To Create A Test File
	

	K.1.1
	Perform the following steps on the Candidate Platform (kpccp).

Double-click gedit icon in the control panel.
	The gedit window opens.
	Circle one:  PASS / FAIL

	K.1.2
	In the text window, enter the following text:

This text is test text.
	This text appears in the text window.
	Circle one:  PASS / FAIL



	K.1.3
	Select File > Save
	A Text Editor - Save As dialog box appears.
	Circle one:  PASS / FAIL



	K.1.4
	Enter TestText in the file name text box at the bottom of the Save As…
	TestText appears in the text box.
	Circle one:  PASS / FAIL



	K.1.5
	Click OK.
	The Text Editor - Save As dialog box closes.
	Circle one:  PASS / FAIL



	K.2
	Verify Existence Of Test File
	

	K.2.1
	Perform the following steps on the Candidate Platform (kpccp).

On the Control Panel, click the Left Footprint icon > Applications > Nautilus
NOTE: This method is OS specific. Use the relevant method on the OS being tested and note it in the Observed Results column.
	The Nautilus File Manager - Scripts window appears.
	Circle one:  PASS / FAIL

	K.2.3
	Verify that an icon named TestText is present in the File Manager – Scripts window.
	The TestText icon is present.
	Circle one:  PASS / FAIL



	K.2.4
	Double-click TestText.
	A Text Editor – Test Text window appears displaying the text:

This text is test text.
	Circle one:  PASS / FAIL



	K.2.5
	Click the Back Arrow below the menu bar.
	The Nautilus File manager window returns to previous display.
	Circle one:  PASS / FAIL

	K.3
	Delete the Test File
	

	K.3.1
	Perform the following steps on the Candidate Platform (kpccp).

In the Nautilus File Manager - Scripts window, right-click TestText and select Move to Trash.

NOTE: This method is OS specific. Use the relevant method on the OS being tested and note it in the Observed Results column.
	The Test Text icon disappears.
	Circle one:  PASS / FAIL

	K.3.2
	Close the File Manager – Scripts window by clicking the “X” in the upper right-hand corner of the window.
	The File Manager - Scripts window closes.
	Circle one:  PASS / FAIL



	L
	Terminal Window

	L.1
	Setup
	

	L.1.1
	Perform the following steps on the Candidate Platform (kpccp).

Click the Terminal icon on the control panel.
	A terminal prompt appears.
	Circle one:  PASS / FAIL

	L.1.2
	At the command prompt type

id
NOTE: This command is OS specific. Use the relevant command on the OS being tested and note it in the Observed Results column.
	The system returns

uid=100(sysadmin) gid=1(other)
NOTE: This result is OS specific. The result should indicate the user is sysadmin.
	Circle one:  PASS / FAIL

	L.1.3
	At the command prompt type

pwd 

NOTE: This command is OS specific. Use the relevant command on the OS being tested and note it in the Observed Results column.
	The system returns

/h/USERS/local/sysadmin/Scripts 

NOTE: This result is OS specific. The result should indicate the above path.
	Circle one:  PASS / FAIL

	L.1.4
	At the command prompt type

exit
	The login window disappears.
	Circle one:  PASS / FAIL



	M
	Reboot System

	M.1
	Verify System Can Be Rebooted
	

	M.1.1
	Perform the following steps on the Candidate Platform (kpccp).

On the Control Panel, click the Left Footprint icon > Favorites > DII_Apps > SysAdm > Reboot_System
	A Reboot dialog box appears with the question:

Reboot machine?
	Circle one:  PASS / FAIL

	M.1.2
	Click No.
	The dialog box disappears.
	Circle one:  PASS / FAIL



	M.1.3
	On the Control Panel, click the Left Footprint icon > Favorites > DII_Apps > SysAdm > Reboot_System
	A Reboot dialog box appears with the question:

Reboot machine?
	Circle one:  PASS / FAIL



	M.1.4
	Click Yes.
	The workstation reboots and the DII COE LOGIN screen appears.
	Circle one:  PASS / FAIL



	N
	Shutdown System

	N.1
	Verify the System Shuts Down
	

	N.1.1
	Perform the following steps on the Candidate Platform (kpccp).

Login as sysadmin by typing sysadmin in the Login: text box and press the Enter Key.
	The password window opens with the Password: text box.
	Circle one:  PASS / FAIL



	N.1.2
	Type the password for the sysadmin account in the Password: text box and press Enter Key.
	An “OK” Message box appears stating “COE login processing is complete.”

Note: A Start Here window opens on top of the Message box.  Click the upper right hand corner of the Start Here window to close the Start Here Window and expose the COE Message box.
	Circle one:  PASS / FAIL

	N.1.3
	Click OK in the COE Message box.
	The Message box closes
	Circle one:  PASS / FAIL

	N.1.4
	On the Control Panel, click the Left Footprint icon > Favorites > DII_Apps > SysAdm > Shutdown_System
	A Shut down dialog box appears.
	Circle one:  PASS / FAIL



	N.1.5
	Click No.
	The Shut down dialog box disappears.
	Circle one:  PASS / FAIL



	N.1.6
	On the Control Panel, click the Left Footprint icon > Favorites > DII_Apps > SysAdm > Shutdown_System.
	A Shut down dialog box appears.
	Circle one:  PASS / FAIL



	N.1.7
	Click Yes.
	The system shuts down. 
	Circle one:  PASS / FAIL



	O
	Verify secman Login, Profile Selector, Change Password Tool, Command Line Accessibility, and Icon Accessibility

	O.1
	Verify secman Login
	

	O.1.1
	Perform the following steps on the Candidate Platform (kpccp).

Log in as the Security Administrator by typing secman in the Login: text box and press the  Enter key.
	The password screen appears with the Password: text box.
	Circle one:  PASS / FAIL



	O.1.2
	Type the password for the secman account in the Password: text box and press Enter key. 
	A dialog box appears indicating that the password needs to be changed.
	Circle one:  PASS / FAIL



	O.1.3
	Enter the current secman password.
	A text box window appears with a New password text box.
	Circle one:  PASS / FAIL



	O.1.4
	Enter the new secman password.  Press Enter key.

Record the new password.
	The text box changed to Retype the new password:  Press Enter key.
	Circle one:  PASS / FAIL

Password: _____________



	O.1.5
	Re-enter the new password.  Press Enter key
	An “OK” Message box appears stating, “COE login processing is complete.”
Note:  A “Start Here” window appears on top of the Message box.  Click the upper right hand corner of the “Start Here” window to expose the COE Message box.
	Circle one:  PASS / FAIL



	O.1.6
	Click OK in the COE Message box.
	The Message box closes
	Circle one:  PASS / FAIL

	O.2
	Verify secman Profile Selector Functionality
	

	O.2.1
	Perform the following steps on the Candidate Platform (kpccp).

On the Control Panel, click the Left Footprint icon > Favorites > Profile Selector (the head with a question mark icon).
	The Profile Selector window opens with SA Default listed in the Selected Profiles panel.
	Circle one:  PASS / FAIL



	O.2.2
	Click Cancel.
	The Profile Selector window closes.
	Circle one:  PASS / FAIL



	O.3
	Verify secman Change Password Tool Functionality
	

	O.3.1
	Perform the following steps on the Candidate Platform (kpccp).

On the Control Panel, click the Left Footprint icon > Favorites > Change Password Tool.
	The Change your password window appears
	Circle one:  PASS / FAIL



	O.3.2
	Click Cancel.
	The Change your password window disappears.
	Circle one:  PASS / FAIL



	O.4
	Verify Command Line Access
	

	O.4.1
	Open a Terminal window by clicking the terminal window icon on the control panel.
	A Terminal window appears with a command line prompt.
	Circle one:  PASS / FAIL



	O.4.2
	At the command prompt type

id
NOTE: This command is OS specific. Use the relevant command on the OS being tested and note it in the Observed Results column.
	The system returns

uid=101(secman) gid=36(admin) groups=36(admin)
NOTE: This result is OS specific. The result should indicate the user is secman.
	Circle one:  PASS / FAIL



	O.4.3
	At the command prompt type

pwd 

NOTE: This command is OS specific. Use the relevant command on the OS being tested and note it in the Observed Results column.
	The system returns

/h/USERS/local/secman/Scripts 

NOTE: This result is OS specific. The result should indicate the above path.
	Circle one:  PASS / FAIL



	O.4.4
	At the command prompt type

exit
	The Terminal window disappears.
	Circle one:  PASS / FAIL



	O.5
	Verify Icon Access
	

	O.5.1
	Perform the following steps on the Candidate Platform (kpccp).

On the Control Panel, click the Left Footprint icon > Favorites > DII_Apps > SecAdm  

NOTE: This method is OS specific. Use the relevant method on the OS being tested and note it in the Observed Results column.
	The Application Manager – SecAdm menu appears with the following items listed:  APM_Server_Stop, Remove_Host, APM_Server_Reload, Merge_Host, Assign_Passwords, Profile_Selector_Config, APM_Key_Server, APM_Server_Start, APM_Client, Audit_Log_File_Manager, Edit_APM_Configuration
	Circle one:  PASS / FAIL



	P
	APM Client

	P.1
	Create A New Account, Profile, and Group On the Candidate Platform
	

	P.1.1
	Perform the following steps on the Candidate Platform (kpccp).

On the Control Panel, click the Left Footprint icon > Favorites > DII_Apps > SecAdm  > APM Client
	An Input dialog box appears asking for the APM master authentication key.
	Circle one:  PASS / FAIL



	P.1.2
	Enter the APM master authentication key.
	Asterisks appear in the text box.
	Circle one:  PASS / FAIL



	P.1.3
	Click OK.
	The Account and Profile Manager dialog box appears.
	Circle one:  PASS / FAIL



	P.1.4
	Select File > New Account.
	A Create Account window appears.
	Circle one:  PASS / FAIL



	P.1.5
	Enter the following values:

Login: AcctCon

Password: temp

Password Confirm: temp
Template: secman 

Home server: EACH HOST
Manage as: Local
	Each item is filled in.
	Circle one:  PASS / FAIL



	P.1.8
	Click Submit.
	A Status Summary dialog box appears indicating the new user has been added.
	Circle one:  PASS / FAIL



	P.1.9
	Click OK.
	The Status Summary dialog box disappears.
	Circle one:  PASS / FAIL



	P.1.10
	Click Profiles.
	The Profiles tab is displayed.
	Circle one:  PASS / FAIL



	P.1.11
	Select File > New Profile.
	A Create Profile window appears.
	Circle one:  PASS / FAIL



	P.1.12
	In the Profile Name text box, enter 

ProCon.
	ProCon appears in the text box.
	Circle one:  PASS / FAIL



	P.1.13
	Select SSO Default from the Profile Template drop-down list.
	SSO Default is selected.
	Circle one:  PASS/ FAIL



	P.1.14
	Click Features.
	The Features tab is displayed.
	Circle one:  PASS / FAIL



	P.1.15
	Select LINUX Security Administration 4.2.0.5 from the Segments box.
	Sol Security Administration 4.2.0.5 is highlighted.
	Circle one:  PASS / FAIL



	P.1.16
	In the Features box, deselect the following items
Security Administration-APM Client

Security Administration-APM Server Start

Security Administration-Assign Passwords.
	These items are no longer checked.
	Circle one:  PASS / FAIL



	P.1.17
	Click Submit.
	A Status Summary dialog box appears indicating the new profile has been added.
	Circle one:  PASS / FAIL



	P.1.18
	Click OK.
	The Status Summary dialog box disappears.
	Circle one:  PASS / FAIL



	P.1.19
	Click Groups.
	The Groups tab is displayed.
	Circle one:  PASS / FAIL



	P.1.20
	Select File > New Group.
	A Create Group window appears.
	Circle one:  PASS / FAIL



	P.1.21
	In the Group name text box, enter 

GrpCon.
	GrpCon appears in the text box.
	Circle one:  PASS / FAIL



	P.1.22
	Select admin from the Template drop-down list.
	admin is selected.
	Circle one:  PASS / FAIL



	P.1.23
	Click Accounts.
	The Accounts tab is displayed.
	Circle one:  PASS / FAIL



	P.1.24
	Double-click SSO in the Assigned Accounts panel.
	SSO moves to the Available Accounts panel.
	Circle one:  PASS / FAIL



	P.1.25
	Click Hosts.
	The Hosts tab is displayed.
	Circle one:  PASS / FAIL



	P.1.26
	Verify kpccp appears in the Assigned Hosts panel.
	kpccp appears in the Assigned Hosts panel.
	Circle one:  PASS / FAIL



	P.1.27
	Click Submit.
	A Status Summary dialog box appears indicating GrpCon has been added.
	Circle one:  PASS / FAIL



	P.1.28
	Click OK.
	The Status Summary dialog box disappears.
	Circle one:  PASS / FAIL



	P.1.29
	Click File > Exit.
	An Exit confirmation dialog box appears.
	Circle one:  PASS / FAIL



	P.1.30
	Click Yes.
	The Account and Profile Manager dialog box disappears.
	Circle one:  PASS / FAIL



	P.2
	Create A New Account, Profile, and Group On the Validation Host
	

	P.2.1
	Perform the following steps on the Validation Hast (kpchost)

Log in as the Security Administrator by typing secman in the Login: text box and press the Enter key.
	The password screen appears with the Password: text box.
	Circle one:  PASS / FAIL



	P.2.2
	Type the password for the secman account in the Password: text box and press Enter key. 
	A dialog box appears indicating that the password needs to be changed.
	Circle one:  PASS / FAIL



	P.2.3
	Enter the current secman password.
	A text box window appears with a New password text box.
	Circle one:  PASS / FAIL



	P.2.4
	Enter the new secman password.  Press Enter key.

Record the new password.
	The text box changed to Retype the new password:.  Press Enter key.
	Circle one:  PASS / FAIL

Password: _____________



	P.2.5
	Re-enter the new password.  Press Enter key
	An “OK” Message box appears stating, “COE login processing is complete.”
Note:  A “Start Here” window appears on top of the Message box.  Click the upper right hand corner of the “Start Here” window to expose the COE Message box.
	Circle one:  PASS / FAIL



	P.2.6
	Click OK in the COE Message box.
	The Message box closes
	Circle one:  PASS / FAIL

	P.2.7
	On the Control Panel, click the Left Footprint icon > Favorites > DII_Apps > SecAdm  > APM Client
	An Input dialog box appears asking for the master APM authentication key
	Setup



	P.2.8
	Enter the master APM authentication key.
	Asterisks appear in the text box.
	Setup



	P.2.9
	Click OK.
	The Account and Profile Manager dialog box appears.
	Setup



	P.2.10
	Select File > New Account.
	A Create Account window appears.
	Setup



	P.2.11
	Enter the following values:

Login: AcctCon

Password: temp

Password Confirm: temp
Template: sysadmin 

Home server: EACH HOST
Manage as: Local
	Each item is filled in.
	Setup



	P.2.8
	Click Submit.
	A Status Summary dialog box appears indicating the new user has been added.
	Setup 



	P.2.9
	Click OK.
	The Status Summary dialog box disappears.
	Setup



	P.2.10
	Click Profiles.
	The Profiles tab is displayed.
	Setup



	P.2.11
	Select File > New Profile.
	A Create Profile window appears.
	Setup



	P.2.12
	In the Profile Name text box, enter 

ProCon.
	ProCon appears in the text box.
	Setup



	P.2.13
	Select SA Default from the Profile Template drop-down list.
	SA Default is selected.
	Setup



	P.2.14
	Click Features.
	The Features tab is displayed.
	Setup



	P.2.15
	Select LINUX System Administration 4.2.0.5 from the Segments box.
	Sol System Administration 4.2.0.5 is highlighted.
	Setup



	P.2.16
	In the Features box, deselect the following items:
System Administration-Change Machine ID

System Administration-Disk Manager

System Administration-Edit Local Hosts.
	These items are no longer checked.
	Setup



	P.2.17
	Click Submit.
	A Status Summary dialog box appears indicating the new profile has been added.
	Setup 



	P.2.18
	Click OK.
	The Status Summary dialog box disappears.
	Setup 



	P.2.19
	Click Groups.
	The Groups tab is displayed.
	Setup 



	P.2.20
	Select File > New Group.
	A Create Group window appears.
	Setup

 

	P.2.21
	In the Group Name text box, enter 

GrpCon.
	GrpCon appears in the text box.
	Setup 



	P.2.22
	Select other from the Template drop-down list.
	other is selected.
	Setup 



	P.2.23
	Click Accounts.
	The Accounts tab is displayed.
	Setup 



	P.2.24
	Double-click SA in the Assigned Accounts panel.
	SA moves to the Available Accounts panel.
	Setup 



	P.2.25
	Click Hosts.
	The Hosts tab is displayed.
	Setup 



	P.2.26
	Verify kpchost appears in the Assigned Hosts panel.
	kpchost appears in the Assigned Hosts panel.
	Setup 



	P.2.27
	Click Submit.
	A Status Summary dialog box appears indicating the new group has been added.
	Setup 



	P.2.28
	Click OK.
	The Status Summary dialog box disappears.
	Setup 



	P.2.29
	Click File > Exit.
	An Exit Confirmation dialog box appears.
	Setup 



	P.2.30
	Click Yes.
	The Account and Profile Manager dialog box disappears.
	Setup 



	Q
	APM Server Reload

	Q.1
	Setup
	

	Q.1.1
	Perform the following steps on the Candidate Platform (kpccp).

On the Control Panel, click the Left Footprint icon > Favorites > DII_Apps > SecAdm  > APM Server Reload.
	An INFORMATIONAL MESSAGE box appears: APM Server reloaded successfully.
	Circle one:  PASS / FAIL



	Q.1.2
	Click OK.
	The INFORMATIONAL MESSAGE box disappears.
	Circle one:  PASS / FAIL



	R
	APM Server Stop

	R.1
	Setup
	

	R.1.1
	Perform the following steps on the Candidate Platform (kpccp).

On the Control Panel, click the Left Footprint icon > Favorites > DII_Apps > SecAdm  > APM Server Stop.
	An INFORMATIONAL MESSAGE box appears: APM Server successfully stopped.
	Circle one:  PASS / FAIL



	R.1.2
	Click OK.
	The INFORMATIONAL MESSAGE box disappears.
	Circle one:  PASS / FAIL



	R.1.3
	Perform the following steps on the Candidate Platform (kpccp).

On the Control Panel, click the Left Footprint icon > Favorites > DII_Apps > SecAdm  > APM Server Stop.
	An INFORMATIONAL MESSAGE box appears: APM Server already stopped.
	Circle one:  PASS / FAIL



	R.1.4
	Click OK.
	The INFORMATIONAL MESSAGE box disappears.
	Circle one:  PASS / FAIL



	S
	APM Server Start

	S.1
	Setup
	

	S.1.1
	Perform the following steps on the Candidate Platform (kpccp).
On the Control Panel, click the Left Footprint icon > Favorites > DII_Apps > SecAdm  > APM Server Start
	An INFORMATIONAL MESSAGE box appears: APM Server started successfully.
	Circle one:  PASS / FAIL



	S.1.2
	Click OK.
	The INFORMATIONAL MESSAGE box disappears.
	Circle one:  PASS / FAIL



	S.1.3
	On the Control Panel, click the Left Footprint icon > Favorites > DII_Apps > SecAdm  > APM Server Start.
	An INFORMATIONAL MESSAGE box appears: APM Server is already running!
	Circle one:  PASS / FAIL



	S.1.4
	Click OK.
	The INFORMATIONAL MESSAGE box disappears. 
	Circle one:  PASS / FAIL



	T
	Assign Passwords

	T.1
	Setup
	

	T.1.1
	Perform the following steps on the Candidate Platform (kpccp).

On the Control Panel, click the Left Footprint icon > Favorites > DII_Apps > SecAdm  > Assign passwords.
	The Assign passwords dialog box appears.
	Circle one:  PASS / FAIL



	T.1.2
	Click Cancel.
	The Assign passwords dialog box disappears.
	Circle one:  PASS / FAIL



	U
	Audit Log File Manager

	U.1
	Setup
	

	U.1.1
	Perform the following steps on the Candidate Platform (kpccp).

On the Control Panel, click the Left Footprint icon > Favorites > DII_Apps > SecAdm  > Audit Log File Manager.
	The Audit Log File Manager dialog box appears.
	Circle one:  PASS / FAIL

	U.1.2
	Click Cancel.
	The Audit Log File Manager dialog box disappears.
	Circle one:  PASS / FAIL



	V
	Edit APM Configuration

	V.1
	Setup
	

	V.1.1
	Perform the following steps on the Candidate Platform (kpccp).

On the Control Panel, click the Left Footprint icon > Favorites > DII_Apps > SecAdm  > Edit APM Configuration.
	The Edit APM Configuration window appears.
	Circle one:  PASS / FAIL



	V.1.2
	In the Master Host text box, enter

kpchost
	kpchost appears in the text box.
	Circle one:  PASS / FAIL



	V.1.3
	Click Submit.
	A Done dialog box appears indicating: Operation completed successfully.
	Circle one:  PASS / FAIL



	V.1.4
	Click OK.
	The dialog box and the Edit APM Configuration window disappear.
	Circle one:  PASS / FAIL



	V.1.5
	On the Control Panel, click the Left Footprint icon > Log out 
	A Logout Confirmation window appears.
	Circle one:  PASS / FAIL

	V.1.6
	Select Yes.
	System exits and the DII COE LOGIN screen appears.
	Circle one:  PASS / FAIL



	W
	Set Local Authentication Key

	W.1
	Set Key on Candidate Platform
	

	W.1.1
	Perform the following steps on the Candidate Platform (kpccp).

Log in as keyman by typing keyman in the Login: text box and press the  Enter key.
	The password screen appears with the Password: text box.
	Circle one:  PASS / FAIL



	W.1.2
	Type the password for the keyman account in the Password: text box and press Enter key. 
	A dialog box appears indicating that the password needs to be changed.
	Circle one:  PASS / FAIL



	W.1.3
	Enter the current keyman password.
	A text box window appears with a New password text box.
	Circle one:  PASS / FAIL



	W.1.4
	Enter the new keyman password.  Press Enter key.

Record the new password.
	The text box changed to Retype the new password:  Press Enter key.
	Circle one:  PASS / FAIL

Password: _____________



	W.1.5
	Re-enter the new password.  Press Enter key
	An “OK” Message box appears stating, “COE login processing is complete.”
Note:  A “Start Here” window appears on top of the Message box.  Click the upper right hand corner of the “Start Here” window to expose the COE Message box.
	Circle one:  PASS / FAIL



	W.1.6
	Click OK in the COE Message box.
	The Message box closes
	Circle one:  PASS / FAIL

	W.1.7
	On the Control Panel, click the Left Footprint icon > Favorites > DII_Apps > APM > Authentication_Manager.
	The Authentication Manager window appears.
	Circle one:  PASS / FAIL



	W.1.8
	Enter the Local APM authentication key.


	Asterisks appear in the textbox.
	Circle one:  PASS / FAIL



	W.1.9
	Click Set Key.


	A Message dialog box appears stating that the local key is set.
	Circle one:  PASS / FAIL



	W.1.10
	Click OK.


	The dialog box disappears.
	Circle one:  PASS / FAIL



	W.1.11
	Click Close.
	The Authentication Manager window closes.
	Circle one:  PASS / FAIL



	W.1.12
	On the Control Panel, click the Left Footprint icon > Log out.


	A Logout Confirmation window appears.
	Circle one:  PASS / FAIL

	W.1.13
	Click Yes
	System exits and the DII COE LOGIN screen appears.
	Circle one:  PASS / FAIL



	W.2
	Set Key on Validation Host
	

	W.2.1
	Perform the following steps on the Validation Host (kpchost)

Log in as keyman by typing keyman in the Login: text box and press the Enter key.
	The password screen appears with the Password: text box.
	Setup

	W.2.2
	Type the password for the keyman account in the Password: text box and press Enter key. 
	A dialog box appears indicating that the password needs to be changed.
	Setup

	W.2.3
	Enter the current keyman password.
	A text box window appears with a New password text box.
	Setup

	W.2.4
	Enter the new keyman password.  Press Enter key.

Record the new password.
	The text box changed to Retype the new password:  Press Enter key.
	Setup

	W.2.5
	Re-enter the new password.  Press Enter key
	An “OK” Message box appears stating, “COE login processing is complete.”
Note:  A “Start Here” window appears on top of the Message box.  Click the upper right hand corner of the “Start Here” window to expose the COE Message box.
	Setup

	W.2.6
	Click OK in the COE Message box.
	The Message box closes
	Setup

	W.2.7
	On the Control Panel, click the Left Footprint icon > Favorites > DII_Apps > APM > Authentication_Manager.
	The Authentication Manager window appears.
	Setup


	W.2.8
	Enter the Local APM authentication key.


	Asterisks appear in the textbox.
	Setup


	W.2.9
	Click Set Client’s Local Key.


	The Hosts List window appears.
	Setup 

	W.2.10
	In the Additional Host text box type kpccp.


	kpccp appears in the text box.
	Setup 

	W.2.11
	Click Add Host.
	The Set Key For New Host dialog box appears.
	Setup

	W.2.12
	In the New auth key and Re-enter auth key text boxes type the local authentication key for kpccp.
	Asterisks appear in the textboxes.
	Setup

	W.2.13
	Click Submit.


	A Message dialog box appears stating that the Authentication keys are set.
	Setup 



	W.2.14
	Click OK.


	The Message dialog box disappears.
	Setup



	W.2.15
	Click Close.

	The Hosts List window disappears.
	Setup



	W.2.16
	Click Close.

	The Authentication Manager window disappears.
	Setup



	W.2.17
	On the Control Panel, click the Left Footprint icon >.Log out


	A Logout Confirmation window appears.
	Setup

	W.2.18
	Select Yes.
	System exits and the DII COE LOGIN screen appears.
	Setup 

	X
	Merge Host

	X.1
	Run Merge On the Candidate Platform
	

	X.1.1
	Perform the following steps on the Candidate Platform (kpccp).

Login as secman by typing secman in the Login: text box and press the Enter Key.
	The password window opens with the Password: text box.
	Setup



	X.1.2
	Type the password for the secman account in the Password: text box and press Enter Key.
	An “OK” Message box appears stating, “COE login processing is complete.”

Note: A Start Here window opens on top of the Message box.  Click the upper right hand corner of the Start Here window to close the Start Here Window and expose the COE Message box.
	Setup

	X.1.3
	Click OK in the COE Message box.
	The Message box closes
	Setup

	X.1.4
	On the Control Panel, click the Left Footprint icon > Favorites > DII_Apps > APM > Merge_Host.
	The MergeHost Tool dialog box appears with kpccp listed as the hostname of the New APM Domain Host and kpchost listed as the hostname of the Master APM Server.
	Setup



	X.1.5
	Click OK.
	An Input dialog box appears asking for the Master APM authentication key.
	Circle one:  PASS / FAIL



	X.1.6
	Enter the master APM authentication key.
	Asterisks appear in the text box.
	Circle one:  PASS / FAIL



	X.1.7
	Click OK.
	A User Conflicts window opens.

.
	Circle one:  PASS / FAIL



	X.1.8
	Click use master.
	The red text noting the conflicts turns to black.
	Circle one:  PASS / FAIL



	X.1.9
	Click Reset.
	The conflict is again indicated by red text.
	Circle one:  PASS / FAIL



	X.1.10
	Click use new.
	The red text noting the conflicts turns to black.
	Circle one:  PASS / FAIL



	X.1.11
	Click Apply.
	A check is displayed next to AcctCon and secman is highlighted in the left panel.
	Circle one:  PASS / FAIL



	X.1.12
	Click use new.
	The red text noting the conflicts turns to black.
	Circle one:  PASS / FAIL



	X.1.13
	Click Apply.
	A check is displayed next to secman and sysadmin is highlighted in the left pane.
	Circle one:  PASS / FAIL



	X.1.14
	Click use master.
	The red text noting the conflicts turns to black.
	Circle one:  PASS / FAIL



	X.1.15
	Click Apply.
	A check is displayed next to sysadmin and the right pane shows No more user conflicts.
	Circle one:  PASS / FAIL



	X.1.16
	Click OK.
	A Group Conflicts window appears.

GrpCon is highlighted in the left panel.
	Circle one:  PASS / FAIL



	X.1.17
	Click use new.
	The red text noting the conflicts turns to black.
	Circle one:  PASS / FAIL



	X.1.18
	Click Apply.
	A check is displayed next to GrpCon and admin is highlighted in the left pane.
	Circle one:  PASS / FAIL



	X.1.19
	Click use new.
	The red text noting the conflicts turns to black.
	Circle one:  PASS / FAIL



	X.1.20
	Click Apply.
	A check is displayed next to admin and other is highlighted in the left panel.
	Circle one:  PASS / FAIL



	X.1.21
	Click use new.
	The red text noting the conflicts turns to black.
	Circle one:  PASS / FAIL



	X.1.22
	Click Apply.
	A check is displayed next to other and the right pane shows No more group conflicts.
	Circle one:  PASS / FAIL



	X.1.23
	Click OK.
	A Profile Conflicts window appears. ProCon is highlighted in the left panel.
	Circle one:  PASS / FAIL



	X.1.24
	Click use master.
	The red text noting the conflicts turns to black.
	Circle one:  PASS / FAIL



	X.1.25
	Click Apply.
	A check is displayed next to ProCon and SA Default is highlighted in the left panel.

Note: SA Default may not be listed; if not, skip to step X.1.24.
	Circle one:  PASS / FAIL



	X.1.26
	Click use new.
	The red text noting the conflicts turns to black.
	Circle one:  PASS / FAIL



	X.1.27
	Click Apply.
	A check is displayed next to SA Default and the right pane shows No more profile conflicts.
	Circle one:  PASS / FAIL



	X.1.28
	Click OK.
	A MergeHost Confirmation window appears with the following message:

Send commands to the Master APM Server now?
	Circle one:  PASS / FAIL



	X.1.29
	Click OK.
	The MergeHost Status dialog box displays Finished.
	Circle one:  PASS / FAIL



	X.1.30
	Click OK.
	The MergeHost Status dialog box disappears.
	Circle one:  PASS / FAIL



	X.2
	Cleanup 
	

	X.2.1
	Perform the following steps on the Candidate Platform (kpccp).

On the Control Panel, click the Left Footprint icon > Favorites > DII_Apps > SecAdm > APM_Client.
	An Input dialog box appears asking for the APM master authentication key.
	Cleanup

	X.2.2
	Enter the master APM authentication key.
	Asterisks appear in the text box.
	Cleanup

	X.2.3
	Click OK.
	The Account and Profile Manager dialog box appears.
	Cleanup

	X.2.4
	Select user AcctCon.
	User AcctCon is highlighted.
	Cleanup

	X.2.5
	Select Edit > Delete.
	A Confirm window prompts for confirmation.
	Cleanup

	X.2.6
	Click Yes.
	A Status Summary window appears indicating the Account was successfully deleted.
	Cleanup

	X.2.7
	Click OK.
	Control returns to the Account and Profile Manager dialog box. The entry for AcctCon has been removed from the Accounts tab.
	Cleanup

	X.2.8
	Click Profiles.
	The Profiles tab is displayed.
	Cleanup

	X.2.9
	Select ProCon.
	ProCon is highlighted.
	Cleanup

	X.2.10
	Select Edit > Delete.
	A Confirm window prompts for confirmation.
	Cleanup

	X.2.11
	Click Yes.
	A Status Summary window appears indicating the Profile was successfully deleted.
	Cleanup

	X.2.12
	Click OK.
	Control returns to the Account and Profile Manager dialog box. The entry for ProCon has been removed from the Profiles tab.
	Cleanup

	X.2.13
	Click Groups.
	The Groups tab is displayed.
	Cleanup

	X.2.14
	Select GrpCon.
	GrpCon is highlighted.
	Cleanup

	X.2.15
	Select Edit > Delete.
	A Confirm window prompts for confirmation.
	Cleanup

	X.2.16
	Click Yes.
	A Status Summary window appears indicating the Profile was successfully deleted.
	Cleanup

	X.2.17
	Click OK.
	Control returns to the Account and Profile Manager dialog box. The entry for GrpCon has been removed from the Groups tab.
	Cleanup

	X.2.18
	Select File > Exit.
	An Exit confirmation window appears.
	Cleanup

	X.2.19
	Click Yes.
	The Account and Profile Manager dialog box disappears.
	Cleanup

	X.2.24
	Open a Terminal window by clicking the terminal window icon on the control panel.
	A Terminal window appears with a command line prompt.
	Cleanup

	X.2.25
	At the command prompt type 

su -
	The Password prompt appears.
	Cleanup

	X.2.26
	At the Password prompt type the root password.
	The command prompt returns.
	Cleanup

	X.2.27
	At the command prompt type

csh
	The command prompt returns.
	Cleanup

	X.2.28
	In the Terminal window, type 
cd /h/COE/Comp/APM/bin
	The command prompt returns.
	Cleanup

	X.2.29
	In the Terminal window, type 
./APM_BecomeOwnMaster
	The command prompt returns.
	Cleanup

	X.2.30
	Perform the following steps on the Validation Host (kpchost)

Login as secman by typing secman in the Login: text box and press the Enter Key.
	The password window opens with the Password: text box.
	Cleanup

	X.2.31
	Type the password for the secman account in the Password: text box and press Enter Key.
	An “OK” Message box appears stating, “COE login processing is complete.”

Note: A Start Here window opens on top of the Message box.  Click the upper right hand corner of the Start Here window to close the Start Here Window and expose the COE Message box.
	Cleanup

	X.2.32
	Click OK in the COE Message box.
	The Message box closes
	Cleanup

	X.2.33
	On the Control Panel, click the Left Footprint icon > Favorites > DII_Apps > SecAdm >Remove_Host
	The Remove Hosts window appears
	Cleanup

	X.2.34
	Double-click kpccp in the Keep panel.
	kpccp moves to the Remove panel.
	Cleanup



	X.2.35
	Click Submit.
	An INFORMATIONAL MESSAGE dialog box appears indicating: APM Server reloaded successfully.
	Cleanup



	X.2.36
	Click OK.
	A Completed dialog box appears indicating that kpccp has been removed.
	Cleanup



	X.2.37
	Click OK.
	The dialog box and Remove Hosts window disappear.
	Cleanup



	X.2.38
	Log out of the Validation Host (kpchost).
	The DII COE LOGIN screen appears.
	Cleanup



	X.2.39
	Perform the following steps on the Validation Host (kpchost)

Login as keyman by typing keyman in the Login: text box and press the Enter Key.
	The password window opens with the Password: text box.
	Setup 

	X.2.40
	Type the password for the keyman account in the Password: text box and press Enter Key.
	An “OK” Message box appears stating, “COE login processing is complete.”

Note: A Start Here window opens on top of the Message box.  Click the upper right hand corner of the Start Here window to close the Start Here Window and expose the COE Message box.
	Setup

	X.2.41
	Click OK in the COE Message box.
	The Message box closes
	Setup

	X.2.42
	On the Control Panel, click the Left Footprint icon > Favorites > DII_Apps > APM > Authentication_Manager.
	The Authentication Manager window appears.
	Setup 

	X.2.43
	Enter the master authentication key in the Key text box.
	Asterisks appear in the text box.
	Cleanup



	X.2.44
	Click Set Client’s Local Key.
	The Hosts List window appears.
	Cleanup



	X.2.45
	Select kpccp.
	kpccp is highlighted.
	Cleanup



	X.2.46
	Select Delete Host.
	A Confirm dialog box appears with the following message:

Delete the local authentication keys of these hosts?

kpccp
	Cleanup

	X.2.47
	Click Yes.
	The dialog box disappears.
	Cleanup



	X.2.48
	Click Close in the Hosts List window.
	The Hosts List window disappears.
	Cleanup



	X.2.49
	Click Close in the Authentication Manager window.
	The Authentication Manager window disappears.
	Cleanup

	X.2.50
	Log out of the Validation Host (kpchost).

On the Control Panel, click the Left Footprint icon > Log Out > Yes
	The DII COE LOGIN screen appears.
	Cleanup



	Y
	Profile Selector Config

	Y.1
	Setup
	

	Y.1.1
	Perform the following steps on the Candidate Platform (kpccp).

On the Control Panel, click the Left Footprint icon > Favorites > Profile Selector
	The Profile Selector Configuration dialog box appears.
	Circle one:  PASS / FAIL

	Y.1.2
	Click Cancel.
	The Profile Selector Configuration dialog box disappears.
	Circle one:  PASS / FAIL



	Z
	Remove Host

	Z.1
	Setup
	

	Z.1.1
	Perform the following steps on the Candidate Platform (kpccp).

On the Control Panel, click the Left Footprint icon > Favorites > DII_Apps > SecAdm > Remove_Host
	The Remove Hosts dialog box appears.
	Circle one:  PASS / FAIL

	Z.1.2
	Click Cancel.
	The Remove Hosts dialog box disappears.


	Circle one:  PASS / FAIL

	Z.1.3
	Log out of the Candidate Platform (kpccp)

On the Control Panel, click the Left Footprint icon > Log Out > Yes 
	System exits and the DII COE LOGIN screen appears.
	Circle one:  PASS / FAIL

	AA
	Public Key Manager

	AA.1
	Setup
	

	AA.1.1
	Perform the following steps on the Candidate Platform

Login as keyman by typing keyman in the Login: text box and press the Enter Key.
	The password window opens with the Password: text box.
	Setup 

	AA.1.2
	Type the password for the keyman account in the Password: text box and press Enter Key.
	An “OK” Message box appears stating, “COE login processing is complete.”

Note: A Start Here window opens on top of the Message box.  Click the upper right hand corner of the Start Here window to close the Start Here Window and expose the COE Message box.
	Setup

	AA.1.3
	Click OK in the COE Message box.
	The Message box closes
	Setup

	AA.1.4
	On the Control Panel, click the Left Footprint icon > Favorites > DII_Apps > APM > Public_Key_Manager
	The Public Key Manager window appears.
	Circle one:  PASS / FAIL



	AA.1.5
	Click Cancel.
	The Public Key Manager window disappears.
	Circle one:  PASS / FAIL

	ZZ
	Logout

	ZZ.1
	Verify Logout
	

	ZZ.1.1
	Log out of the Validation Host (kpchost).

On the Control Panel, click the Left Footprint icon > Log Out > Yes 
	System exits and the DII COE LOGIN screen appears
	Circle one:  PASS / FAIL


End of Validation Procedure

Kernel Overview VP
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