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1. Scope

1.1 Identification

This document provides instructions on using the Kernel Platform Compliance (KPC) Template Version 1.0.0.1.  

1.2 System Overview

The KPC Validation Host provides services and test data to client systems under test in the KPC Program. The KPC Validation Host contains an operating system (Solaris 7) with the DII COE Kernel, DII COE Developer’s ToolKit, KPC Test Data, and Netscape software installed.

1.3 Document Overview

This document provides the necessary steps to edit KPC Test Procedures using the KPC Template.  The following topics are covered in this document:

· KPC Test Document Structure

· Using the KPC Template Toolbar

· Miscellaneous Functions

· Attaching the KPC Template to a Test Document

· Creating a New Test Document

· Importing an Existing Test Document

· Document Editing Guidelines


2. Referenced Documents

None.

3. KPC Test Document Structure

This section provides a general overview of the KPC test document structure.

NOTE: Tables are not drawn to scale.

3.1 Preamble

Every KPC test procedure begins with a preamble. The preamble describes the purpose, scope, and requirements of the test. The preamble consists of the following sections:

· Test Title

· A table describing the candidate platform, date, tester, test time, test site, and overall test result. The Estimated Runtime is filled in. All other spaces in this table are left blank until the test is submitted.

· A table describing the configuration validated in the test. All spaces in this table are left blank until the test is submitted.

· Test Purpose/Scope

· Description

· Overall Test Result

· Test Step Results

· Test Data/Media Required

· Setup/Equipment Required

· Required Personnel

All of the fields, except for Test Purpose/Scope, Description, Test Data/Media Required, and Setup/Equipment Required, are identical for all test procedures.

3.2 Test Table

The test table follows the preamble and contains all test steps required for the tester to perform. The first row of the test table consists of the test table header, which includes the following four columns:


Operator Action
Expected Result
Observed Result

The first column contains the test step number. The Operator Action column lists the action that the tester will need to perform for each step. The Expected Result column indicates the result that is required in order for each step to pass. The Observed Result column typically contains the text "Circle one:  PASS / FAIL," where the tester indicates whether each step passed or failed the requirements.

The steps within a test table are organized as follows:

1. Each organized set of test steps begins with a test table section row. This row spans two columns, where the first column contains a step letter and the second column contains a description of the procedure performed by all the steps in the section. All text is formatted using boldface type. An example test table section row is given below:

C
Verify that the Client Reads Information from the Server

2. Test steps are further organized into subsections, each of which is headed by a test table subsection row. This row spans three columns, where the first column contains a two-level alphanumeric step number, the second column contains a description of the procedure performed by all the steps in the section, and the third column is blank. All text is formatted using boldface type. An example test table subsection row is given below:

C.1
Open and Initialize the Client Application


3. Each test step is given in a test table step row. This row spans four columns and includes the three-level alphanumeric step number, operator action, expected result, and observed result. An example test table step row is given below:

C.1.1
At the prompt, type:

ls
A directory listing appears.
Circle one:  PASS / FAIL

A typical test section consists of one test table section row, one or more test table subsection rows, and all the test table step rows necessary for the tester to perform the required test.

4. Using the KPC Template

The procedures in this section describe how to use the KPC Template for editing KPC test documentation.

4.1 Using the KPC Template Toolbar

The KPC Template toolbar appears when a test document is attached to the KPC Template. The buttons in the KPC Template toolbar are listed in Figure 1.
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Figure 1. KPC Template Toolbar

A description of each button's function is given below.

4.1.1 Paragraph Functions

A. Text Table Style - Set the paragraph style to "COE Text Table". Use this style when editing and/or formatting text within a test procedure step.

B. Normal Style - Set the paragraph style to "Normal". This is the default paragraph style.

C. Body Text Style - Set the paragraph style to "COE Body Text". Use this style when editing and/or formatting text within the test preamble.

4.1.2 View Functions

D. Toggle View - Toggle the document view between "Normal" and "Page Layout". The "Normal" view includes a margin that indicates the style used for each paragraph.

4.1.3 Font Functions

E. Courier New 12 - Set the font style to "COE CN12". This style guarantees that the text remains displayed with the font Courier New, size 12, regardless of the paragraph format.

This text is displayed with the COE CN12 style.
F. Courier New 12 Bold - Set the font style to "COE CN12B". This style guarantees that the text remains displayed with the font Courier New, size 12, boldface, regardless of the paragraph format.

This text is displayed with the COE CN12B style.
G. Times New Roman 12 - Set the font style to "COE TNR12". This style guarantees that the text remains displayed with the font Times New Roman, size 12, regardless of the paragraph format.

This text is displayed with the COE TNR12 style.

H. Times New Roman 12 Bold - Set the font style to "COE TNR12B". This style guarantees that the text remains displayed with the font Times New Roman, size 12, boldface, regardless of the paragraph format.

This text is displayed with the COE TNR12B style.

4.1.4 List Functions

I. Numbered List - Create a numbered list. To change the properties of the list, select Format -> Bullets and Numbering.

J. Bulleted List - Create a bulleted list. To change the properties of the list, select Format -> Bullets and Numbering.

K. Number Up - Increase the starting list letter or number index by one. For example, the list letter index "S" becomes "T" and the list number index "2" becomes "3".

L. Number Down - Decrease the starting list letter or number index by one. For example, the list letter index "S" becomes "R" and the list number index "2" becomes "1".

M. Skip Number - Remove the index from the current list item and continue numbering with the next list item.

4.1.5 Table Functions

N. Create Test Table Heading - Create the test table heading, which includes an empty first column and the columns "Operator Action", "Expected Result", and "Observed Result".

O. Reset Column Widths (Single Row) - Resize all columns in the current test table row to proper widths. The first column must contain text. This function also sets the current row so that the first test step in the section or subsection stays on the same page as the test section heading.

P. Reset Column Widths (Entire Table) - Resize all columns in the entire table to proper widths. The first column in every row (except for the test table header) must contain text. This function also sets each row so that the first test step in each section or subsection stays on the same page as the test section heading.

Q. Renumber Test - Renumber all test steps within the test section. For example, if the cursor is on the "B" heading row, all subsequent steps are numbered with "B.1", "B.1.1", etc. depending on the structure of the test. When using this function, the current row must be a top-level test heading row (such as A, B, etc.) and each test table section row must contain text in the first cell. This function also sets each row so that the first test step in each section or subsection stays on the same page as the test section heading.

R. Fill First Column - Remove all step numbers and fill the first column of the every row (except for the test table header) with "??". This function is intended to provide each cell with text in order for the "Renumber Test" and "Reset Column Widths" functions to work.

S. Format Table - Format the current table so that every cell has a 3/4-pt. border and no row is allowed to split across pages. This function is recommended after creating an initial test table.

T. Insert Pass/Fail - Insert the text "Circle one:  PASS / FAIL" in the last column of the current row. If the current row is not a test step, then the text in the last column is removed.

4.1.6 Shading Functions

U. No Shading - Remove shading from all selected table cells.

V. Shade 5% - Shade all selected table cells to 5% density. Shaded cells indicate test steps that are not executed during normal operation.

4.1.7 Continuity Functions

W. Do Not Allow Row to Break Across Pages - Keep the entire contents of the table row on the same page. This function is recommended to keep all table rows from splitting across pages.

X. Allow Row to Break Across Pages - Allow the contents of the table row to split across  pages. This function is not recommended for any table row.

Y. Do Not Keep With Next or Keep Lines Together – Do not force the current selection to stay on the same page with the next paragraph or table row if the page splits.

Z. Keep With Next and Keep Lines Together - Force the current selection to stay on the same page with the next paragraph or table row if the page splits.

4.1.8 Document Functions

1. Page Setup - Format the entire document to include proper margins and "landscape" page orientation.

2. Insert Header and Footer - Insert a standard test document header and footer. After using this function, the header and footer must be modified to reflect the current test procedure.

3. Insert Test Preamble - Insert a standard test document preamble. This function is recommended when creating a new test procedure. After using this function, the preamble must be modified to reflect the current test procedure.

4. Insert Test Procedures - Insert a sample test table, complete with the test table heading and example steps. This function is recommended when creating a new test procedure. After using this function, the test table must be modified to reflect the current test procedure.

4.1.9 Miscellaneous Function

Check Document Properties - Determine if the document meets minimum version requirements. This function will determine and report invalid document properties, such as the document being stored in a file format different from Word 97.

4.2 Attaching the KPC Template to a Test Document

WARNING: To prevent unintentional text changes, it is highly recommended that the automatic capitalization of words be disabled. Select Tools > AutoCorrect... and deselect the following options:

· Correct TWo INitial CApitals

· Capitalize first letter of sentences

· Capitalize names of days

· Correct accidental usage of cAPS LOCK key

Before the KPC Template can be used, it must be attached to a document. Perform the steps below to attach the KPC Template to a new or existing test document.

1. Open the document in Word 97.

2. Select Tools -> Templates and Add-Ins.... The Templates and Add-ins window appears.

3. In the Document template text box, type the path where the KPC Template is stored on disk. If necessary, click on the Attach... button and locate the KPC Template path.

4. Select the Automatically update document styles checkbox.

5. Click on the OK button. The KPC toolbar appears in the Word window.

NOTE: If the KPC toolbar does not appear, select View -> Toolbars -> COE_Test.

6. Select Tools -> Templates and Add-Ins.... The Templates and Add-ins window appears.

7. Deselect the Automatically update document styles checkbox.

8. Click on the OK button.

The KPC Template is now ready for use.

4.3 Creating a New Test Document

WARNING: To prevent unintentional text changes, it is highly recommended that the automatic capitalization of words be disabled. Select Tools > AutoCorrect... and deselect the following options:

· Correct TWo INitial CApitals

· Capitalize first letter of sentences

· Capitalize names of days

· Correct accidental usage of cAPS LOCK key

To create a new test document in Word 97, perform the following steps:

1. Select File -> New.... The New window appears.

2. Attach the KPC Template to the new document. For more information, refer to Section 4.2, Attaching the KPC Template to a Test Document.

3. In the KPC Template toolbar, click on the Page Setup button (labeled 1 in Figure 1). The page orientation is set to "Landscape" and all page margins are properly set.

4. In the KPC Template toolbar, click on the Insert Header and Footer button (labeled 2 in Figure 1). The header and footer are inserted into the document.

5. Modify the following fields in the document header and footer to reflect the test procedure:

· Test Title

· Version

· Date (dd Month 20yy)

NOTE: The header and footer is the same on all pages.

6. Close the header and footer view and position the cursor to the beginning of the document.

7. In the KPC Template toolbar, click on the Insert Test Preamble button (labeled 3 in Figure 1). The test preamble is inserted into the document.

8. Modify the following fields in the test preamble to reflect the test procedure:

· Test Purpose/Scope

· Description

· Test Data/Media Required

· Setup/Equipment Required

9. Position the cursor to the end of the document.

10. In the KPC Template toolbar, click on the Insert Test Procedures button (labeled 4 in Figure 1). The test table is inserted into the document.

11. Modify the test table to reflect the test procedure.

At this point, the test document is ready for further editing.

4.4 Importing an Existing Test Document

WARNING: To prevent unintentional text changes, it is highly recommended that the automatic capitalization of words be disabled. Select Tools > AutoCorrect... and deselect the following options:

· Correct TWo INitial CApitals

· Capitalize first letter of sentences

· Capitalize names of days

· Correct accidental usage of cAPS LOCK key

The procedure in this section describes how to import an existing test document and format it for use with the KPC template. Follow the steps below to format an existing document:

1. Open the document in Word 97.

2. With the document open, turn off revision tracking and accept all changes made theretofore:

a) Select Tools -> Track Changes -> Highlight Changes.... The Highlight Changes window appears.

b) Deselect the following options:

· Track changes while editing

· Highlight changes on screen

· Highlight changes in printed document

c) Click on the OK button. The Highlight Changes window closes.

d) Select Tools -> Track Changes -> Accept or Reject Changes.... The Accept or Reject Changes window appears.

e) Unless it is grayed out, click on the Accept All button. A confirmation window appears.

f) Click on the Yes button. The confirmation window closes.

g) Click on the OK button. The Accept or Reject Changes window closes and all the option buttons are grayed out.

3. Attach the KPC Template to the new document. For more information, refer to Section 4.2, Attaching the KPC Template to a Test Document.

4. Position the cursor to the beginning of the document.

5. Format all characters in the document:

a) Select Edit -> Replace.... The Find and Replace window appears.

b) In the Find what: text box, type the following characters:

^?

c) In the Replace panel, select Format -> Font.... The Find Font window appears.

NOTE: If the Replace panel is not shown, click on the More button. The Replace panel appears.

d) In the Font panel, select Courier New.

e) Click on the OK button. The Find Font window disappears and the text Format: Font: Courier New appears underneath the Find what: text box.

f) In the Replace with: text box, type the following characters:

^&

g) In the Replace panel, select Format -> Style.... The Replace Style window appears.

h) In the Replace With Style panel, select COE CN12.

i) Click on the OK button. The Replace Style window disappears and the text Format: Style: COE CN12 appears underneath the Find what: text box.

j) Click on the Replace All button. Every character with the Courier New font is replaced with the COE CN12 style. A confirmation dialog box appears after all characters are replaced.

k) Click on the OK button. The confirmation dialog box closes.

l) Click inside the Find what: text box, but leave the field as is.

m) In the Replace panel, select Format -> Font.... The Find Font window appears.

n) In the Font panel, select Times New Roman.

o) Click on the OK button. The Find Font window disappears and the text Format: Font: Times New Roman appears underneath the Find what: text box.

p) Click inside the Replace with: text box, but leave the field as is.

q) In the Replace panel, select Format -> Font.... The Find Font window appears.

r) In the Font panel, select Times New Roman.

s) In the Size panel, select 12.

t) Click on the OK button. The Find Font window disappears and the text Format: Font: Times New Roman, 12 pt appears underneath the Replace with: text box.

u) Click on the Replace All button. Every character with the Times New Roman font is replaced with a font of size 12. A confirmation dialog box appears after all characters are replaced.

v) Click on the OK button. The confirmation dialog box closes.

w) Click on the Cancel button. The Find and Replace window closes.

6. Save and close the document.

7. Select Tools -> Templates and Add-Ins.... The Templates and Add-ins window appears.

8. Click on the Organizer... button. The Organizer window appears.

9. In the left-hand panel, click on the Close File button. The button label changes to Open File.

10. In the left-hand panel, click on the Open File button. The Open window appears.

11. Change the Files of type: field to Word Documents (*.doc).

12. Navigate through the system and locate the file name of the document.

13. Click on the Open button. All of the current styles in the document appear in the left-hand Styles panel.

14. Delete all existing styles except for the following:

· All styles beginning with COE

· Default Paragraph Font

· Heading 1 through Heading 9

· Normal

15. In the left-hand panel, click on the Close File button. A confirmation dialog box appears.

16. Click on the Yes button to accept all changes.

17. Close the Organizer window.

18. Reopen the document in Word 97.

19. If the document’s steps have not yet been split so that each one is in a separate table row, do that process now. If the document’s steps have already been split, or after completing that process, save the document and continue with step 20.

20. Ensure that all individual test procedure tables are combined into a single table:

a) Click inside the first table and select Table -> Select Table.

b) Scroll down until the cursor reaches a table that is not selected.

c) Join this table with the previous one by deleting the space between until they join.

d) Click inside the combined table and select Table -> Select Table.

e) Scroll down until the cursor reaches a table that is not selected.

f) Join this table with the previous one by deleting the space between the tables until they join.

g) Continue with substeps d) through f) until all individual test procedure tables form a single table.

21. In the KPC Template toolbar, click on the Toggle View button (labeled D in Figure 1) several times until the document view switches to "Normal" with a style margin.

22. In the KPC Template toolbar, click on the Page Setup button (labeled 1 in Figure 1). The page orientation is set to "Landscape" and all page margins are properly set.

23. Copy title information to the clipboard:

a) Position the cursor at the beginning of the test table.

b) Select View > Header and Footer. The header and footer view appears.

c) Copy everything after Validation Procedure for DII COE Kernel Platform Certification: in the header title to the clipboard. This information will be used later in three different locations, starting with step 27. 

d) Select View > Header and Footer. The header and footer view closes.

24. Position the cursor at the beginning of the document.

25. In the KPC Template toolbar, click on the Insert Test Preamble button (labeled 3 in Figure 1). The test preamble appears at the beginning of the document, separated from the old preamble by a section break.

26. In the KPC Template toolbar, click on the Insert Header and Footer button (labeled 2 in Figure 1). All headers and footers in the document are standardized. When the macro is finished, the document is in "Footer" view.

27. Adjust the footer as follows:

a) Select the text “<Test Title>” in the footer.

b) Select Edit > Paste Special.... The Paste Special window appears.

c) Select Unformatted Text.

d) Click on the OK button. The Paste Special window closes and the information in the clipboard replaces the selected text and preserves the footer title's existing format.

NOTE: Due to the length of the title, you may need to delete a tab in this line if the page number disappears from the right margin of the footer.

e) Replace the text “<Version>” with the appropriate version number, e.g. 4.2.0.0P2.

f) Replace the text “<dd Month 20yy>” with the current date using the format as shown.

g) Switch to the header using the Header and Footer toolbar.

28. Adjust the header as follows:

a) Select the text “<Test Title>” in the footer.

b) Select Edit > Paste Special.... The Paste Special window appears.

c) Select Unformatted Text.

d) Click on the OK button. The Paste Special window closes and the information in the clipboard replaces the selected text and preserves the header title's existing format.

e) Select View > Header and Footer. The header and footer view closes.

29. Adjust the test title as follows:

a) Position the cursor in the title at the top of the new preamble.

b) Select the text “<Test Title>” in the test title.

c) Select Edit > Paste Special.... The Paste Special window appears.

d) Select Unformatted Text.

e) Click on the OK button. The Paste Special window closes and the information in the clipboard replaces the selected text and preserves the test title's existing format.

30. Select Window -> Split and split the document into two windows.

31. Position the cursor in the top window at the beginning of the new preamble.

32. Position the cursor in the bottom window at the beginning of the old preamble.

NOTES:
1. The old preamble generally, but not always, consists of at least three tables, with the title of the first table being “Application Platform Under Validation.”

2. In some cases you may need to search to find the needed information, since not all preambles are alike.

33. Adjust the test purpose and scope as follows:

a) In the new preamble (top window), position the cursor at the paragraph beginning with "Test Purpose/Scope".

b) In the old preamble (bottom window), position the cursor to the row beginning with "Purpose/Scope".

c) Copy the purpose and scope from the old preamble into the clipboard.

d) In the new preamble, select the text "<Describe basic functionality of the test.>".

e) Select Edit > Paste Special.... The Paste Special window appears.

f) Select Unformatted Text.

g) Click on the OK button. The Paste Special window closes and the information in the clipboard replaces the selected text and preserves the preamble's existing format.

NOTE:  Be sure all the copied text is formatted with the “COE Body Text” style except for the header, footer and overall test title at the top of the first page. If any text is not formatted with the “COE Body Text” style, then select the text and click on the Body Text Style button in the KPC Template toolbar (labeled B in Figure 1).

34. Adjust the description as follows:

a) In the new preamble (top window), position the cursor at the paragraph beginning with "Description".

b) In the old preamble (bottom window), position the cursor at the row beginning with "Description".

c) Copy the description from the old preamble into the clipboard.

d) In the new preamble, select the text "<List basic functionality validated by the test, with the relevant test steps identified.  Use the example below:>".

e) Select Edit > Paste Special.... The Paste Special window appears.

f) Select Unformatted Text.

g) Click on the OK button. The Paste Special window closes and the information in the clipboard replaces the selected text and preserves the preamble's existing format.

NOTE:  Be sure all the copied text is formatted with the “COE Body Text” style except for the header, footer and overall test title at the top of the first page. If any text is not formatted with the “COE Body Text” style, then select the text and click on the Body Text Style button in the KPC Template toolbar (labeled B in Figure 1).

35. Adjust the test data and media required as follows:

a) In the new preamble (top window), position the cursor at the paragraph beginning with "Test Data/Media Required".

b) In the old preamble (bottom window), position the cursor at the row beginning with "Test/Data Media Required".

c) Copy the test data and media required from the old preamble into the clipboard.

d) In the new preamble, select the text "<Include CM reference numbers, release number, patch level, segments, and any test data as applicable required to execute the test.>".

e) Select Edit > Paste Special.... The Paste Special window appears.

f) Select Unformatted Text.

g) Click on the OK button. The Paste Special window closes and the information in the clipboard replaces the selected text and preserves the preamble's existing format.

NOTE:  Be sure all the copied text is formatted with the “COE Body Text” style except for the header, footer and overall test title at the top of the first page. If any text is not formatted with the “COE Body Text” style, then select the text and click on the Body Text Style button in the KPC Template toolbar (labeled B in Figure 1).

36. Adjust the setup and equipment required as follows:

a) In the new preamble (top window), position the cursor at the paragraph beginning with "Setup/Equipment Required".

b) In the old preamble (bottom window), position the cursor at the row beginning with "Setup/Equipment Required".

c) Copy the setup and equipment required from the old preamble into the clipboard.

d) In the new preamble, select the text "<Note any assumptions made regarding the configuration of the Validation Host or the Candidate Platform.  (e.g. Running a prior test)>".

e) Select Edit > Paste Special.... The Paste Special window appears.

f) Select Unformatted Text.

g) Click on the OK button. The Paste Special window closes and the information in the clipboard replaces the selected text and preserves the preamble's existing format.

NOTE:  Be sure all the copied text is formatted with the “COE Body Text” style except for the header, footer and overall test title at the top of the first page. If any text is not formatted with the “COE Body Text” style, then select the text and click on the Body Text Style button in the KPC Template toolbar (labeled B in Figure 1).

37. Select Window -> Remove Split. The entire document appears in one window.

38. In the KPC Template toolbar, click on the Toggle View button (labeled D in Figure 1) several times until the document view switches to "Normal" with a style margin.

39. Position the cursor at the beginning of the old preamble.

40. Delete the old preamble, including the section break between the new preamble and the old preamble.

WARNING:  Do not delete the section break between the old preamble and the beginning of the test table. If there is no section break before the test table, do not delete the section break at the end of the new preamble when deleting the old preamble.

41. Position the cursor in the first cell of the table’s first row.

42. Select Table -> Split Table. A single line space is created above the table.

43. Delete the old test table heading row.

44. In the KPC Template toolbar, click on the Create Test Table Heading button (labeled N in Figure 1). A new test table heading is created.

NOTES:

1. The test table heading may have different row widths than the rest of the table. These differences will be remedied later.

2. Be sure to leave a blank line between the test table heading and the rest of the table.

45. Position the cursor in the first cell of the table’s first row.

46. In the KPC Template toolbar, click on the Format Table button (labeled S in Figure 1). The test table's border thickness is properly set and no rows are allowed to break across pages.

47. Select Table -> Select Table from the menu bar.

48. In the KPC Template toolbar, click on the Text Table Style button (labeled A in Figure 1). All cells in the table are formatted to the text table style.

49. Position the cursor on the blank line following the test table heading.

50. Delete the blank line between the test table heading and the rest of the test table.

NOTE: Be sure that all rows, except for the test table heading, contain step numbers in the first column. For a quick way to guarantee that all cells contain text in the first column, click on the Fill First Column button (labeled R in Figure 1) in the KPC Template toolbar. This procedure removes all step numbers and replaces them with "??".

51. Ensure that the blurb "Circle one:  PASS/FAIL" appears in the Observed Result column of all test procedure rows:

NOTE: Sometimes wording may exist in an Observed Result cell that needs to remain, be moved or deleted. In such cases, follow the procedures in this step only if the wording is to be deleted. Otherwise, use your own judgment regarding how to proceed with the affected cell.

a) Position the cursor in the second row of the table.

b) Ensure that the wording in the Observed Result column does not need to be preserved.

c) In the KPC Template toolbar, click on the Insert Pass/Fail button (labeled T in Figure 1).

If the row is a test procedure row, then the Pass/Fail blurb appears in the Observed Result column of the current row and the cursor moves to the next row.

If the row is a section heading row, then the text in the Observed Result column is deleted.

d) Repeat substeps b) and c) until the entire table is processed.

52. Ensure that all test section heading rows contain two columns and that all test subsection heading rows contain three columns. To merge multiple cells into one, select the cells and select Table -> Merge Cells.

53. Position the cursor in the first cell of the table’s first row.

54. In the KPC Template toolbar, click on the Reset Column Widths (Entire Table) button (labeled P in Figure 1). All columns in the test table are adjusted to the proper widths.

55. Renumber test steps as necessary. To renumber an entire section, position the cursor in the test section heading row and click on the Renumber Test button (labeled Q in Figure 1) in the KPC Template toolbar.

NOTE: Be sure that all rows, except for the test table heading, contain step numbers in the first column. For a quick way to guarantee that all cells contain text in the first column, click on the Fill First Column button (labeled R in Figure 1) in the KPC Template toolbar. This procedure removes all step numbers and replaces them with "??".

56. At the very end of the document, change the style of the phrase “End of Validation Procedure” as follows:

a) Position the cursor at the beginning of the phrase "End of Validation Procedure".

b) Click on the Style window’s down arrow and select style “COE Start/End Section.”

57. Save the document.

At this point, the test document is ready for further editing.

4.5 Document Editing Guidelines

This section contains a brief list of guidelines for editing a KPC test document.

WARNING: To prevent unintentional text changes, it is highly recommended to disable the automatic capitalization of words. Select Tools > AutoCorrect... and deselect the following options:

· Correct TWo INitial CApitals

· Capitalize first letter of sentences

· Capitalize names of days

· Correct accidental usage of cAPS LOCK key

1. Test steps which are "grayed out" (i.e., the entire table row is set to a gray background) are to be considered as waived by DISA for this test version only.  Grayed-out test steps are not to be executed nor is observed behavior to be recorded.  These test steps may be returned to the overall test at a future date and are retained for informational purposes only.  PASS/FAIL criteria identified in these test steps will not be used in the determination of the overall test result.

2. Lower case “s” in brackets [s] denotes a blank space; lower case “r” in brackets [r] denotes a carriage return; lower case “s” and “r” together in brackets [s] [r] denotes a blank space and carriage return.

3. Each row shall consist of only one step. Multiple steps within a single procedure row is not allowed.

4. The first section, A, shall consist of initial login and/or setup steps. The last section, Z, shall consist of logout steps. If there are more than 26 sections, Section Y shall be followed by Section AA, and the last step shall be Section ZZ.

5. List of Changes

The following changes have been made in this version of the KPC Template:

1. The string "KPC Template 1.0.0.1" appears in the menu bar.

2. Lower case “s” in brackets [s] and lower case “r” in brackets [r] appears in Courier 12 font in the preamble.

6. Acronyms

The following acronyms are listed in this document:

COE
Common Operating Environment

DII
Defense Information Infrastructure

DISA
Defense Information Systems Agency

KPC
Kernel Platform Compliance

UM
User’s Manual
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A. Macro Code Listings

This appendix contains a listing of each Word 97 macro used in the KPC Template.

Constants and Definitions

Private Const templateVer$ = "KPC 1.0.0.1"      ' Template Version number

Private cr$

Private pr$

Private qt$

Private tb$

Private Sub COE_Characters()

    cr$ = Chr(13)           ' Carriage Return

    pr$ = Chr(13) + Chr(13) ' Paragraph

    qt$ = Chr(34)           ' Quote

    tb$ = Chr(9)            ' Tab

End Sub

Private Sub COE_ABORT()

    Stop

End Sub

Do Not Allow Row to Break Across Pages

Public Sub COE_CellPgBrkOff()

    For Each curRow In Selection.Rows

        curRow.AllowBreakAcrossPages = False

    Next curRow

End Sub

Allow Row to Break Across Pages

Public Sub COE_CellPgBrkOn()

    For Each curRow In Selection.Rows

        curRow.AllowBreakAcrossPages = True

    Next curRow

End Sub

Check Document Properties

Public Sub COE_CheckDocumentProps()

    Dim wordVerReq$

    Dim wordVerReq2$

    Dim docver$

    Dim failures$

    Dim cluster$

    Dim rtfcheck

    Dim filname$

    Dim appName$

    Dim warning$

    Dim header$

    Dim body$

    Dim footer$

    COE_Characters

    ' DII COE Document Verification Macro

    ' ****************************************************

    ' Macro verifies that the current document conforms to

    ' DII COE documentation standards.  An error is issued

    ' stating specific requirements which are not met.

    '

    ' Register your requirements in the 'USER VARIABLES'

    ' section below.

    ' ****************************************************

    ' ****************************************************

    ' USER VARIABLES

    ' ****************************************************

    ' Application requirements

    wordVerReq$ = "8.0"    ' Required MS Word version string.

    wordVerReq2$ = ""   ' Alternate required version.

    ' ****************************************************

    ' MAIN MACRO PROGRAM

    ' ****************************************************

    ' Application information variables

    docver$ = WordBasic.[AppInfo$](2)

    failures$ = ""

    cluster$ = ""

    rtfcheck = 0

    filname$ = WordBasic.[FileName$]()

    appName$ = WordBasic.[GetDocumentProperty$](WordBasic.[DocumentPropertyName$](22))

    WordBasic.EditFindClearFormatting

    ' Detect improper MS Word version

    Select Case docver$

        Case wordVerReq$

        Case wordVerReq2$

    Case Else

        failures$ = failures$ + "- MS Word not compliant.  " + _

            "Version: " + docver$ + ", " + appName$ + cr$

    End Select

    ' Detect RTF file

    WordBasic.SendKeys "^{home}+{down}%ec%{F4}", -1

    WordBasic.Shell "notepad " + filname$, 3

    ' Create a new doc and paste possible RTF data

    WordBasic.FileNewDefault

    WordBasic.EditPasteSpecial DataType:="Text"

    ' Get the first 5 characters of possible RTF data

    WordBasic.StartOfDocument

    cluster$ = WordBasic.[GetText$](0, 80)

    cluster$ = WordBasic.[CleanString$](cluster$)  ' Remove any non-printing chars

    ' Clean clipboard and close doc

    WordBasic.Insert Chr(65)

    WordBasic.SelType 2

    WordBasic.CharLeft 1, 1

    WordBasic.EditCut

    WordBasic.SelType 1

    WordBasic.DocClose 2

    rtfcheck = InStr(1, WordBasic.[Left$](cluster$, 5), "{\rtf")  ' 0 = not RTF

    ' DEBUG

    '   message$ = "rtfcheck: " + Str$(rtfcheck) + cr$ + \

    '       "cluster: " + cluster$ + cr$ + \

    '       "filname: " + filname$ + cr$ + \

    '       ""

    '

    '   MsgBox message$, "COE", 64

    Select Case rtfcheck

        Case 0

    Case Else

        failures$ = failures$ + _

            "- This document is in RTF format.  " + _

            "First 80 chars: " + cr$ + "       " + cluster$ + cr$

    End Select

    ' *** DISPLAY RESULTS ***

    ' Display verification status

    If (failures$ = "") Then

        ' No failures detected.

        warning$ = "No documentation failures detected."

        WordBasic.MsgBox warning$, "DII COE Document Validation", 48

        Exit Sub

    Else

        ' Generate failure message, listing specifics

        warning$ = "This document fails validation.  Please " + _

            "make corrections for DII COE compliancy." + pr$ + _

            "Click on OK for a detailed report."

        WordBasic.MsgBox warning$, "DII COE Document Validation", 16

        ' Display error information in new window

        WordBasic.FileNewDefault

        header$ = "DII COE Documentation Validation V." + _

            templateVer$ + cr$ + WordBasic.[Date$]() + ":" + WordBasic.[Time$]() + pr$

        body$ = "Report details of validation failure:" + pr$ + _

            failures$ + pr$

        footer$ = "END report" + cr$

        WordBasic.Insert header$ + body$ + footer$

    End If

End Sub

Create Test Table Heading

Public Sub COE_CreateTestTableHeader()

    COE_Characters

    ' Create Table

    Selection.Tables.Add Range:=Selection.Range, numrows:=1, numcolumns:=4

    Selection.Tables(1).Select

    ' Initial Table Formatting

    For Each curBorder In Selection.Tables(1).Borders

        curBorder.LineStyle = wdLineStyleSingle

        curBorder.LineWidth = wdLineWidth075pt

    Next curBorder

    Selection.Tables(1).Shading.Texture = wdTextureNone

    Selection.Style = ActiveDocument.Styles("COE Table Heading")

    Selection.Font.Bold = True

    Selection.Font.Name = "Times New Roman"

    Selection.Font.Size = 12

    ' Fill cells with text

    Selection.Tables(1).Cell(1, 1).Select

    Selection.TypeText ""

    Selection.Cells(1).Next.Select

    Selection.TypeText "Operator Action"

    Selection.Cells(1).Next.Select

    Selection.TypeText "Expected Result"

    Selection.Cells(1).Next.Select

    Selection.TypeText "Observed Result"

    ' Format Cell Size

    With Selection.Tables(1).Rows(1)

        .LeftIndent = InchesToPoints(0.01)

        .SpaceBetweenColumns = InchesToPoints(0.01)

        .Select

    End With

    Selection.Cells(1).Width = InchesToPoints(0.8)

    Selection.Cells(2).Width = InchesToPoints(3.6)

    Selection.Cells(3).Width = InchesToPoints(3.6)

    Selection.Cells(4).Width = InchesToPoints(2)

    ' Make table row a "Heading" for subsequent pages

    Selection.Tables(1).Rows.HeadingFormat = True

    ' Also KLT/KWN

    Selection.Tables(1).Select

    Selection.Paragraphs.KeepWithNext = True

    Selection.Paragraphs.KeepTogether = True

    ' Post-Process

    Selection.MoveDown

End Sub

Fill First Column

Public Sub COE_FillFirstColumn()

    Selection.Tables(1).Rows(2).Cells(1).Select

    While Selection.Information(wdWithInTable)

        Selection.Cells(1).Select

        Selection.Range.Delete

        Selection.ParagraphFormat.Alignment = wdAlignParagraphLeft

        Selection.Style = "COE Table Text"

        Selection.TypeText Text:="??"

        Selection.HomeKey

        Selection.MoveDown

    Wend

    Selection.Tables(1).Rows(2).Cells(1).Select

End Sub

Format Table

Public Sub COE_FormatTable()

    With Selection.Tables(1)

        For Each curBorder In .Borders

            curBorder.LineStyle = wdLineStyleSingle

            curBorder.LineWidth = wdLineWidth075pt

        Next curBorder

        For Each curRow In .Rows

            curRow.AllowBreakAcrossPages = False

        Next curRow

    End With

End Sub

Insert Header and Footer

Public Sub COE_HeaderFooter()

    Dim firstsection

    COE_Characters

    firstsection = True

    ' Add headers and footers for all sections

    For Each curSection In ActiveDocument.Sections

        ' Same header/footer for all pages in the section

        curSection.PageSetup.DifferentFirstPageHeaderFooter = False

        curSection.PageSetup.OddAndEvenPagesHeaderFooter = False

        If firstsection = True Then

            ' Process the first section's header

            For Each curHeader In curSection.Headers

                curHeader.Range.Select

                Selection.Style = "COE Header"

                Selection.TypeText Text:="Validation Procedure for DII COE Kernel Platform Compliance:  <Test Title>"

            Next curHeader

            ' Process the first section's footer

            For Each curFooter In curSection.Footers

                curFooter.Range.Select

                Selection.Style = "COE Footer"

                Selection.TypeText Text:="<Test Title> Validation Procedure"

                Selection.TypeText Text:=tb$

                Selection.TypeText Text:=tb$

                Selection.TypeText Text:="Page "

                Selection.Fields.Add Range:=Selection.Range, Type:=wdFieldPage

                Selection.TypeText Text:=" of "

                Selection.Fields.Add Range:=Selection.Range, Type:=wdFieldNumPages

                Selection.TypeText Text:=cr$

                Selection.TypeText Text:="DII COE <Version> / Rev. Date: <dd Month 20yy>"

            Next curFooter

        Else

            ' Link all subsequent headers/footers to the previous

            For Each curHeader In curSection.Headers

                curHeader.LinkToPrevious = True

            Next curHeader

            For Each curFooter In curSection.Footers

                curFooter.LinkToPrevious = True

            Next curFooter

        End If

        firstsection = False

    Next curSection

    ActiveWindow.View.Type = wdPageView

End Sub

Do Not Keep With Next or Keep Lines Together

Public Sub COE_KWNKLTOff()

    For Each par In Selection.Paragraphs

        par.KeepWithNext = False

        par.KeepTogether = False

    Next par

End Sub

Keep With Next and Keep Lines Together

Public Sub COE_KWNKLTOn()

    For Each par In Selection.Paragraphs

        par.KeepWithNext = True

        par.KeepTogether = True

    Next par

End Sub

No Shading

Public Sub COE_NoShade()

    Selection.Shading.Texture = wdTextureNone

End Sub

Number Down

Public Sub COE_NumberDown()

    Dim x

    x = Selection.Range.ListFormat.ListTemplate.ListLevels(1).StartAt

    If x > 0 Then

        Selection.Range.ListFormat.ListTemplate.ListLevels(1).StartAt = x - 1

    End If

End Sub

Number Up

Public Sub COE_NumberUp()

    Dim x

    x = Selection.Range.ListFormat.ListTemplate.ListLevels(1).StartAt

    Selection.Range.ListFormat.ListTemplate.ListLevels(1).StartAt = x + 1

End Sub

Page Setup

Public Sub COE_PageSetup()

    With ActiveDocument.PageSetup

        .PaperSize = wdPaperLetter

        .Orientation = wdOrientLandscape

        .LeftMargin = InchesToPoints(0.5)

        .RightMargin = InchesToPoints(0.5)

        .TopMargin = InchesToPoints(1)

        .BottomMargin = InchesToPoints(1)

        .Gutter = InchesToPoints(0)

        .HeaderDistance = InchesToPoints(0.5)

        .FooterDistance = InchesToPoints(0.5)

        .MirrorMargins = False

        .SectionStart = wdSectionNewPage

        .DifferentFirstPageHeaderFooter = False

        .OddAndEvenPagesHeaderFooter = False

        .VerticalAlignment = wdAlignVerticalTop

    End With

End Sub

Insert Pass/Fail

Public Sub COE_PassFail()

    Selection.Rows(1).Select

    numcolumns = Selection.Information(wdEndOfRangeColumnNumber) _

                 - Selection.Information(wdStartOfRangeColumnNumber) + 1

    If numcolumns = 3 Then

        Selection.Cells(3).Select

        Selection.Style = "COE Table Text"

        Selection.Style = "COE TNR12"

        Selection.Delete

    ElseIf numcolumns = 4 Then

        Selection.Cells(4).Select

        Selection.Style = "COE Table Text"

        Selection.Style = "COE TNR12"

        Selection.TypeText Text:="Circle one:  PASS / FAIL"

        Selection.TypeParagraph

        Selection.TypeParagraph
    End If

    Selection.Rows(1).Select

    Selection.HomeKey

    Selection.MoveDown

End Sub

Insert Test Preamble

Public Sub COE_Preamble()

    ActiveDocument.AttachedTemplate.AutoTextEntries("COE Preamble").Insert _

        Where:=Selection.Range, RichText:=True

End Sub

Insert Test Procedures

Public Sub COE_Procedure()

    ActiveDocument.AttachedTemplate.AutoTextEntries("COE Procedure").Insert _

        Where:=Selection.Range, RichText:=True

End Sub

Renumber Test

Public Sub COE_RenumberTest()

    Dim firstCell$

    Dim message$

    Dim buttonVal

    Dim letter$

    Dim data_$

    Dim amtcols

    Dim counter

    ' Renumber macro

    COE_Characters

    ' Set up cursor location and selection.  Should be in

    '   cell #1 of Row.

    WordBasic.StartOfRow

    WordBasic.NextCell

    WordBasic.PrevCell

    ' Verify that cell #1 contains data and isn't blank

    If (WordBasic.SelType() <> 2) Then

        WordBasic.MsgBox "Cell contains no data. Process halted.", "COE", 48

        Exit Sub

    End If

    firstCell$ = WordBasic.[Selection$]()

    WordBasic.BeginDialog 320, 100, "DII COE Renumber Cells"

        WordBasic.Text 10, 6, 115, 13, "Starting Letter:", "Text1"

        WordBasic.TextBox 127, 5, 50, 18, "TextBox1"

        WordBasic.PushButton 56, 71, 109, 21, "&Renumber", "Push1"

        WordBasic.CancelButton 171, 71, 88, 21

    WordBasic.EndDialog

    Dim dlg As Object: Set dlg = WordBasic.CurValues.UserDialog

    ' Default text for text box is what's in cell #1

    dlg.TextBox1 = UCase(firstCell$)

    message$ = ""

    ' Make sure it's a single letter

    If Len(dlg.TextBox1) > 2 Then

        message$ = "Cursor must be positioned on a Row containing " + _

            "one or two, boldface " + qt$ + "header" + qt$ + _

            " letters in Cell 1."

        WordBasic.MsgBox message$, "COE", 48

        Exit Sub

    End If

    ' Create dialog box and get values when user's done

    buttonVal = WordBasic.Dialog.UserDialog(dlg)

    WordBasic.CurValues.UserDialog dlg

    ' Determine which button was pressed

    Select Case buttonVal

        Case 0

            ' Cancel

            Exit Sub

        Case 1

            ' Renumber

            ' OK

        Case Else

            WordBasic.MsgBox "Error: Invalid button return"

            Exit Sub

    End Select

    ' Parse info from dialog box

    letter$ = UCase(dlg.TextBox1)

    ' START RENUMBERING

    Selection.Rows(1).Range.Font.Bold = True

    WordBasic.Insert letter$

    ' Add KLT/KWN

    WordBasic.TableSelectRow

    WordBasic.FormatParagraph KeepWithNext:=1, KeepTogether:=1

    WordBasic.EndOfRow

    ' Begin renumbering loop.

    WordBasic.SelType 1

    WordBasic.EndOfRow

    WordBasic.SelType 2

    WordBasic.NextCell

    data_$ = WordBasic.[Selection$]()

    WordBasic.TableSelectRow

    amtcols = WordBasic.SelInfo(18)

    ci = 0

    cj = 0

    ' Perform loop until we reach another header or empty cell

    While ((amtcols > 2) And (Len(data_$) > 1))

        ' Add the cell numbering text.

        If (amtcols = 3) Then

            ci = ci + 1

            cj = 0

            Selection.Rows(1).Range.Font.Bold = True

            WordBasic.Insert letter$ + "." + WordBasic.[LTrim$](Str(ci))

        ElseIf (amtcols = 4) Then

            cj = cj + 1

            Selection.Cells(1).Range.Font.Bold = False

            WordBasic.Insert letter$ + "." + WordBasic.[LTrim$](Str(ci)) + "." + WordBasic.[LTrim$](Str(cj))

        End If

        ' Add KLT/KWN for all appropriate rows.

        If (amtcols < 4) Then

            ' Header row: add KLT/KWN

            WordBasic.TableSelectRow

            WordBasic.FormatParagraph KeepWithNext:=1, KeepTogether:=1

            WordBasic.EndOfRow

        Else

            ' Procedure row: remove KLT/KWN unless it's the first step

            WordBasic.TableSelectRow

            WordBasic.FormatParagraph KeepWithNext:=0, KeepTogether:=0

            WordBasic.EndOfRow

            ' Move to the previous table row.

            WordBasic.StartOfRow

            WordBasic.PrevCell

            WordBasic.StartOfRow

            WordBasic.NextCell

            WordBasic.PrevCell

            ' Determine the number of columns in the previous table row.

            WordBasic.TableSelectRow

            amtcolsprev = WordBasic.SelInfo(18)

            ' Move back to the current row.

            WordBasic.EndOfRow

            WordBasic.NextCell

            WordBasic.EndOfRow

            ' If the previous row is a header row, add KLT/KWN.

            WordBasic.TableSelectRow

            If (amtcolsprev < 4) Then

                WordBasic.FormatParagraph KeepWithNext:=1, KeepTogether:=1

            End If

        End If

        WordBasic.EndOfRow

        WordBasic.SelType 1

        WordBasic.EndOfRow

        WordBasic.SelType 2

        If (WordBasic.NextCell() = 0) Then Exit Sub

        data_$ = WordBasic.[Selection$]()

        WordBasic.TableSelectRow

        amtcols = WordBasic.SelInfo(18)

    Wend

End Sub
Reset Column Widths (Single Row)

Public Sub COE_ResetColumnWidths()

    Dim numCols

    Dim numColsPrev

    COE_Characters

    Selection.Rows(1).Cells(1).Select

    ' Verify that cell #1 contains data and isn't blank

    If (Selection.Characters.Count < 2) Then

        MsgBox Prompt:="Cell contains no data. Process halted.", Title:="COE"

        Exit Sub

    End If

    ' Determine the number of columns in the table row.

    numCols = Selection.Rows(1).Cells.Count

    If (numCols > 4) Then

        MsgBox Prompt:="This row is not a " & qt$ & "procedure" & qt$ & " row. " & _

            "Process halted.", Title:="COE"

        Exit Sub

    End If

    ' Adjust all cells in the table row

    Select Case numCols

        Case 1

            Selection.Rows(1).Select

            Selection.Paragraphs.KeepWithNext = True

            Selection.Paragraphs.KeepTogether = True

            With Selection.Rows(1)

                .LeftIndent = InchesToPoints(0.01)

                .SpaceBetweenColumns = InchesToPoints(0.01)

                .Select

            End With

            Selection.Cells(1).Width = InchesToPoints(10)

        Case 2

            Selection.Rows(1).Select

            Selection.Paragraphs.KeepWithNext = True

            Selection.Paragraphs.KeepTogether = True

            With Selection.Rows(1)

                .LeftIndent = InchesToPoints(0.01)

                .SpaceBetweenColumns = InchesToPoints(0.01)

                .Select

            End With

            Selection.Cells(1).Width = InchesToPoints(0.8)

            Selection.Cells(2).Width = InchesToPoints(9.2)

        Case 3

            Selection.Rows(1).Select

            Selection.Paragraphs.KeepWithNext = True

            Selection.Paragraphs.KeepTogether = True

            With Selection.Rows(1)

                .LeftIndent = InchesToPoints(0.01)

                .SpaceBetweenColumns = InchesToPoints(0.01)

                .Select

            End With

            Selection.Cells(1).Width = InchesToPoints(0.8)

            Selection.Cells(2).Width = InchesToPoints(7.2)

            Selection.Cells(3).Width = InchesToPoints(2)

        Case 4

            With Selection.Rows(1)

                .LeftIndent = InchesToPoints(0.01)

                .SpaceBetweenColumns = InchesToPoints(0.01)

                .Select

            End With

            Selection.Cells(1).Width = InchesToPoints(0.8)

            Selection.Cells(2).Width = InchesToPoints(3.6)

            Selection.Cells(3).Width = InchesToPoints(3.6)

            Selection.Cells(4).Width = InchesToPoints(2)

            ' Determine the number of columns in the previous table row.

            numColsPrev = Selection.Rows(1).Previous.Cells.Count

            ' If the previous row is a header row, add KLT/KWN. Otherwise, remove KLT/KWN.

            Selection.Paragraphs.KeepWithNext = True

            Selection.Paragraphs.KeepTogether = True

            WordBasic.TableSelectRow

            If (numColsPrev < 4) Then

                Selection.Paragraphs.KeepWithNext = True

                Selection.Paragraphs.KeepTogether = True

            Else

                Selection.Paragraphs.KeepWithNext = False

                Selection.Paragraphs.KeepTogether = False

            End If

        Case Else

            MsgBox Prompt:="Failed assert: Row contains more than 4 columns."

            Exit Sub

    End Select

    ' Move to the next row

    Selection.MoveDown

End Sub

Reset Number Style (Not Used)

Public Sub COE_ResetNumberStyle()

    Selection.Style = wdStyleNormal

End Sub

Reset Column Widths (Entire Table)

Public Sub COE_ResetTableWidths()

    Dim firstCell

    firstCell = True

    For Each curCell In Selection.Tables(1).Rows

        If firstCell = False Then

            COE_ResetColumnWidths

        Else

            Selection.MoveDown

        End If

        firstCell = False

    Next curCell

End Sub

Shade 5%

Public Sub COE_Shade5Percent()

   Selection.Shading.Texture = wdTexture5Percent

End Sub

Toggle View

Public Sub COE_ToggleView()

    If ActiveWindow.View.Type = wdPageView Then

        ActiveWindow.View.Type = wdNormalView

        ActiveWindow.StyleAreaWidth = InchesToPoints(1)

    Else

        ActiveWindow.View.Type = wdPageView

    End If

End Sub
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